Microsoft Office Word Forum - WordBanter

Microsoft Office Word Forum - WordBanter (
-   Formatting Long Documents (
-   -   line break issue with fields (

Singer2000 November 26th 19 08:04 PM

line break issue with fields
Dear all,

this is my first post - I've read a few helpful ones regarding other issues I've had and thought I'd add to the body of knowledge, given that I finally managed to fix my issue but didn't see anyone else having the same issue.

I'm using Word 2010 and using the "cross-reference" tool to refer to different sections (as you do when you have a long document).
My section headings are all numbered 2.1.8, etc.
I've been creating references such as "for more info, see Section 2.1.8" successfully (as, for example, described here )

My issue:
I noticed that my references, in particular the bit "Section 2.1.8", was behaving as one word - i.e. they would stick together and not separate at the end of a line. However, where appropriate at the end of a line, I want "Section" and "2.1.8" to be on different lines. To show what I mean visually:

What I want:
Bla blabla bla bla bla bla bla bla
bla bla bla bla bla bla bla Section
2.1.8 bla bla.

What I got:
Bla blabla bla bla bla bla bla bla
bla bla bla bla bla bla bla
Section 2.1.8 bla bla.

Attempts to resolve:
So I thought: maybe the character between "Section" and "2.1.8" is a non-breaking-space that I inserted accidentally.
But no, it was a regular space!
I tried all sorts of different kinds of field codes and switches, and tried to have "cross-reference"s to both "heading"s and "numbered items" -- all to no avail.
The problem didn't occur when I inserted a "heading text" field instead of "heading number", though.

What was actually happening:
Word was inserting a 'LEFT-TO-RIGHT MARK' character (U+200E) at the beginning of the field. I was able to delete the character manually from the field (but not the field code) (it's fiddly, because the character has zero width), which solved the problem.... until I update the field (F9) and Word puts the LTR mark back in!!
Maybe Word is doing this is because I have used right-to-left languages (e.g. Arabic, Hebrew) on my computer in the past - who knows!

I've not been able to fully fix it, but my acceptable work-around is to insert a "no-width optional break" JUST BEFORE the field. You can find this special character under "insert" -- "Symbol" -- "more Symbols" -- "Special characters [Tab]".
This inserts Unicode character U+200C 'ZERO WIDTH NON-JOINER' (I don't know why Word calls it a "no-width optional break")
Putting this just before the field fixes my problem, even when I update all fields.
(Alternatively, to get that character, you can type "200C" in Word, then highlight the four characters you have just typed, and press Alt+X)

To sum up, the following is the final sequence of characters that I use - the [square brackets] indicate where the Word-generated field is:

Section (SPACE) (U+200C) [ (U+200E) 2.1.8 ]

(NB. this is after toggling the field codes, Shift+F9)

Closing words:
I hope anyone found this helpful. I'd appreciate also if maybe an admin could let me know if this is an appropriate post, given that it's my first one and I haven't been part of these kinds of forums before. Many thanks in advance.
Kind regards from Scotland, Singer2000

All times are GMT +1. The time now is 12:16 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.