A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Word 2007 - cross reference to figure reproduces figure plus capti



 
 
Thread Tools Display Modes
  #1  
Old September 6th 07, 04:54 PM posted to microsoft.public.word.docmanagement
Boris
external usenet poster
 
Posts: 6
Default Word 2007 - cross reference to figure reproduces figure plus capti

I have a problem that seems to have just occurred in Word 2007. I am trying
to you cross reference to give me a figure number. This normally works fine
but in the document I have been working on, it has suddenly started copying
the figure in addition to the caption and number when I insert a cross
reference. I have shut down Word and restarted, rebooted my machine and
restarted, and even copied the text up to (but not including) the figures I
am trying to reference in to a new, blank document, reproduced the figures in
question (Charts from Excel pasted in as Enhanced Metafile pictures) but the
problem persists. Does anyone have any ideas what might be causing this? I
have also just noticed, in my newly created document, the cross reference
labels for the figures that give rise to this problem begin with a forward
slash (i.e. "/Figure 3..." etc). If anyone has any idea of how to get rid of
this behaviour, I would really appreciate it as I must admit, I am stumped...
With best wishes, Boris.
Ads
  #2  
Old September 6th 07, 05:20 PM posted to microsoft.public.word.docmanagement
Boris
external usenet poster
 
Posts: 6
Default Word 2007 - cross reference to figure reproduces figure plus capti

Just some extra info...
I have just created a new blank document, copied the two charts that are
causing all my grief in to this document as Enhanced Metafiles, added a bland
caption to each and then tried to cross reference to them... Again, the cross
reference copies the chart as well as label and number! And again the figures
are preceded by a forward slash ("/") in the cross-reference dialogue box.
So, perhaps it is something specific to these two charts? Any ideas anyone?
Please please?
Many thanks and best wishes, Boris.


"Boris" wrote:

I have a problem that seems to have just occurred in Word 2007. I am trying
to you cross reference to give me a figure number. This normally works fine
but in the document I have been working on, it has suddenly started copying
the figure in addition to the caption and number when I insert a cross
reference. I have shut down Word and restarted, rebooted my machine and
restarted, and even copied the text up to (but not including) the figures I
am trying to reference in to a new, blank document, reproduced the figures in
question (Charts from Excel pasted in as Enhanced Metafile pictures) but the
problem persists. Does anyone have any ideas what might be causing this? I
have also just noticed, in my newly created document, the cross reference
labels for the figures that give rise to this problem begin with a forward
slash (i.e. "/Figure 3..." etc). If anyone has any idea of how to get rid of
this behaviour, I would really appreciate it as I must admit, I am stumped...
With best wishes, Boris.

  #3  
Old September 7th 07, 09:48 AM posted to microsoft.public.word.docmanagement
Boris
external usenet poster
 
Posts: 6
Default Word 2007 - cross reference to figure reproduces figure plus c

One more piece of information...
I have checked the fields that have been inserted by the cross-reference for
these two charts (stacked bar charts with two ordinate axes and one series
formatted as a line) and other charts than I pasted in as Microsoft Excel
Object for which the cross reference works as expected. The format of these
(ie those that work and those that also copy the pasted graphic and therefore
do not work) is exactly the same:
{REF_Refsomenumber\h} or {REF-Refsomenumber\p\h} when cross referencing
above \ below rather than "only label and number"...
As some of the charts copied in as pictures worked as expected before, but
no longer appear to, I suspect something has happened with the way Word puts
in the (hidden) bookmarks to embedded pictures.
I would be pulling my hair out - if I had any left! If anyone has any ideas,
I would really appreciate it.
Best wishes, Boris.

"Boris" wrote:

Just some extra info...
I have just created a new blank document, copied the two charts that are
causing all my grief in to this document as Enhanced Metafiles, added a bland
caption to each and then tried to cross reference to them... Again, the cross
reference copies the chart as well as label and number! And again the figures
are preceded by a forward slash ("/") in the cross-reference dialogue box.
So, perhaps it is something specific to these two charts? Any ideas anyone?
Please please?
Many thanks and best wishes, Boris.


"Boris" wrote:

I have a problem that seems to have just occurred in Word 2007. I am trying
to you cross reference to give me a figure number. This normally works fine
but in the document I have been working on, it has suddenly started copying
the figure in addition to the caption and number when I insert a cross
reference. I have shut down Word and restarted, rebooted my machine and
restarted, and even copied the text up to (but not including) the figures I
am trying to reference in to a new, blank document, reproduced the figures in
question (Charts from Excel pasted in as Enhanced Metafile pictures) but the
problem persists. Does anyone have any ideas what might be causing this? I
have also just noticed, in my newly created document, the cross reference
labels for the figures that give rise to this problem begin with a forward
slash (i.e. "/Figure 3..." etc). If anyone has any idea of how to get rid of
this behaviour, I would really appreciate it as I must admit, I am stumped...
With best wishes, Boris.

  #4  
Old June 7th 10, 03:49 PM
Bibo Bibo is offline
Junior Member
 
First recorded activity by WordBanter: Jun 2010
Posts: 0
Smile

My friend
it is so simple
You must have the same style as your caption on your figure
click on your figure and check its style and change it to normal or whatever your style is.
cross reference works on style and picks up the figure and its caption as one item because they have the same style
Good luck
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cross reference inserts entire figure digitig Microsoft Word Help 4 October 10th 14 11:56 AM
Customizing a Figure Cross Reference? binar Microsoft Word Help 1 March 26th 07 08:35 AM
Make a cross reference say Fig. instead of Figure Bill Microsoft Word Help 1 April 27th 06 01:20 AM
A figure doesn't appear in the Cross-reference dialog box Berkbuns Microsoft Word Help 2 February 8th 06 04:37 PM
Figure List when inserting cross-reference. jaykay Microsoft Word Help 1 December 22nd 04 12:03 AM


All times are GMT +1. The time now is 12:22 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.