A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Mailmerge
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Merge Excel/Word 2007, getting 12:00AM in merge which is NOT in ex



 
 
Thread Tools Display Modes
  #1  
Old October 4th 08, 04:45 AM posted to microsoft.public.word.mailmerge.fields
Onalee
external usenet poster
 
Posts: 5
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT in ex

Hi,
I am merging data from excel into a word document. I am getting data in
word that is showing "12:00AM", however, there is data in the excel sheet and
it is NOT a date and it is not blank - it is part of an address line, such as
"Deliver to Front Desk" or any kinds of words, but definately not a date and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in front
of it to show it is text - nothing gets rid of this . It doesn't do it on
every field or even every record on the same field, just some and seemingly
randomly.

Any idea how to fix this other than manually changing the data in the final
merged document?

Thanks ,
Onalee
Ads
  #2  
Old October 4th 08, 09:11 AM posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
external usenet poster
 
Posts: 4,583
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT in ex

It's possible that you have encountered a new problem that is not described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column as
a text column. However, selecting the column and using Format|Cells to set
the format as Text does not appear to be enough. One way that does appear to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data in
word that is showing "12:00AM", however, there is data in the excel sheet
and
it is NOT a date and it is not blank - it is part of an address line, such
as
"Deliver to Front Desk" or any kinds of words, but definately not a date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in front
of it to show it is text - nothing gets rid of this . It doesn't do it on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee


  #3  
Old October 4th 08, 04:06 PM posted to microsoft.public.word.mailmerge.fields
Onalee
external usenet poster
 
Posts: 5
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

Hi,
Ok, I tried changing the format of the column as you describe, that didn't
help, so I changed the way word connects to excel to DDE as described in one
of the links. That fixed this problem but created a much larger problem.

I have 3 columns in a table in word. There is one field per column merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where q1 is
supposed to be, it is putting the data from the field Product 1 and where p1
is supposed to be, it is putting the data from q1 and where Product 1 is
supposed to be it is putting the data from p1. It's got them all messed up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column as
a text column. However, selecting the column and using Format|Cells to set
the format as Text does not appear to be enough. One way that does appear to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data in
word that is showing "12:00AM", however, there is data in the excel sheet
and
it is NOT a date and it is not blank - it is part of an address line, such
as
"Deliver to Front Desk" or any kinds of words, but definately not a date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in front
of it to show it is text - nothing gets rid of this . It doesn't do it on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee



  #4  
Old October 4th 08, 08:42 PM posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP
external usenet poster
 
Posts: 8,832
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

It seems like you must have the mergefields in the wrong columns.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that didn't
help, so I changed the way word connects to excel to DDE as described in
one
of the links. That fixed this problem but created a much larger problem.

I have 3 columns in a table in word. There is one field per column merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where q1
is
supposed to be, it is putting the data from the field Product 1 and where
p1
is supposed to be, it is putting the data from q1 and where Product 1 is
supposed to be it is putting the data from p1. It's got them all messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee





  #5  
Old October 6th 08, 03:59 AM posted to microsoft.public.word.mailmerge.fields
Onalee
external usenet poster
 
Posts: 5
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

Hi,
No, the data is not in the wrong fields. If I go back to the the original
way to connect (OLB?) they go back to the right places on the word merge - I
did not change where they were in the excel sheet,just changed to DDE.

Apparently, this is just some cruel bug in excel that I'll just have to deal
with.

Onalee

"Doug Robbins - Word MVP" wrote:

It seems like you must have the mergefields in the wrong columns.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that didn't
help, so I changed the way word connects to excel to DDE as described in
one
of the links. That fixed this problem but created a much larger problem.

I have 3 columns in a table in word. There is one field per column merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where q1
is
supposed to be, it is putting the data from the field Product 1 and where
p1
is supposed to be, it is putting the data from q1 and where Product 1 is
supposed to be it is putting the data from p1. It's got them all messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee





  #6  
Old October 6th 08, 05:42 AM posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP
external usenet poster
 
Posts: 8,832
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

If the arrangement of the fields is correct in Word, then I would agree that
it must be a bug in Excel. Phew!

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Onalee" wrote in message
...
Hi,
No, the data is not in the wrong fields. If I go back to the the original
way to connect (OLB?) they go back to the right places on the word
erge - I
did not change where they were in the excel sheet,just changed to DDE.

Apparently, this is just some cruel bug in excel that I'll just have to
deal
with.

Onalee

"Doug Robbins - Word MVP" wrote:

It seems like you must have the mergefields in the wrong columns.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that
didn't
help, so I changed the way word connects to excel to DDE as described
in
one
of the links. That fixed this problem but created a much larger
problem.

I have 3 columns in a table in word. There is one field per column
merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where
q1
is
supposed to be, it is putting the data from the field Product 1 and
where
p1
is supposed to be, it is putting the data from q1 and where Product 1
is
supposed to be it is putting the data from p1. It's got them all
messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in
the
first 8 rows, you may need to get the OLE DB provider to "see" the
column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does
appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting
data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address
line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do
it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in
the
final
merged document?

Thanks ,
Onalee







  #7  
Old October 6th 08, 05:50 AM posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
external usenet poster
 
Posts: 4,583
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i


Apparently, this is just some cruel bug in excel that I'll just have to deal
with.


Could be.

1. Which column is causing the problem (when you do not use DDE) ?

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

3. When you save the sheet, are you saving as .xls or .xlsx?

NB is your sheet simple enough to (a) save the data using e.g. .csv format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?

Another thing you can try is to copy/paste your Excel data into Word and use
that as the data source for a merge.

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that didn't
help, so I changed the way word connects to excel to DDE as described in
one
of the links. That fixed this problem but created a much larger problem.

I have 3 columns in a table in word. There is one field per column merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where q1
is
supposed to be, it is putting the data from the field Product 1 and where
p1
is supposed to be, it is putting the data from q1 and where Product 1 is
supposed to be it is putting the data from p1. It's got them all messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee




  #8  
Old October 8th 08, 04:58 AM posted to microsoft.public.word.mailmerge.fields
Onalee
external usenet poster
 
Posts: 5
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

Hi,
Answers to questions:

1. Which column is causing the problem (when you do not use DDE) ?

The column is called Address2, it is column "j" if that matters.

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

Most are blank - some have things like "Apt: 202" or "Suite 101", things lik
that in them.

3. When you save the sheet, are you saving as .xls or .xlsx?


xlsx

NB is your sheet simple enough to (a) save the data using e.g. .csv format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?


Yes, it is pretty straight forward, only one or two formulas, I could try
that.

Another thing you can try is to copy/paste your Excel data into Word and use
that as the data source for a merge.


I think I'll try the csv download - upload thing first. The field that is
messed up is not used that often -when it is blank, nothing shows on the
merge, if something is in it however, it shows 12:00AM . I have tried
converting to text (per previous posts here), I have tried deleting that
column and reinserting it, I've tried typing over the data in it, none of
that has changed it.


I'll give the download to csv and upload to a different sheet a try.

thank you,
Onalee


"Peter Jamieson" wrote:


Apparently, this is just some cruel bug in excel that I'll just have to deal
with.


Could be.

1. Which column is causing the problem (when you do not use DDE) ?

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

3. When you save the sheet, are you saving as .xls or .xlsx?

NB is your sheet simple enough to (a) save the data using e.g. .csv format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?

Another thing you can try is to copy/paste your Excel data into Word and use
that as the data source for a merge.

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that didn't
help, so I changed the way word connects to excel to DDE as described in
one
of the links. That fixed this problem but created a much larger problem.

I have 3 columns in a table in word. There is one field per column merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where q1
is
supposed to be, it is putting the data from the field Product 1 and where
p1
is supposed to be, it is putting the data from q1 and where Product 1 is
supposed to be it is putting the data from p1. It's got them all messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in the
first 8 rows, you may need to get the OLE DB provider to "see" the column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in the
final
merged document?

Thanks ,
Onalee




  #9  
Old October 8th 08, 12:24 PM posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
external usenet poster
 
Posts: 4,583
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

Does the column have blanks or just numbers in its first 8 rows?

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Answers to questions:

1. Which column is causing the problem (when you do not use DDE) ?

The column is called Address2, it is column "j" if that matters.

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

Most are blank - some have things like "Apt: 202" or "Suite 101", things
lik
that in them.

3. When you save the sheet, are you saving as .xls or .xlsx?


xlsx

NB is your sheet simple enough to (a) save the data using e.g. .csv
format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?


Yes, it is pretty straight forward, only one or two formulas, I could try
that.

Another thing you can try is to copy/paste your Excel data into Word and
use
that as the data source for a merge.


I think I'll try the csv download - upload thing first. The field that is
messed up is not used that often -when it is blank, nothing shows on the
merge, if something is in it however, it shows 12:00AM . I have tried
converting to text (per previous posts here), I have tried deleting that
column and reinserting it, I've tried typing over the data in it, none of
that has changed it.


I'll give the download to csv and upload to a different sheet a try.

thank you,
Onalee


"Peter Jamieson" wrote:


Apparently, this is just some cruel bug in excel that I'll just have to
deal
with.


Could be.

1. Which column is causing the problem (when you do not use DDE) ?

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

3. When you save the sheet, are you saving as .xls or .xlsx?

NB is your sheet simple enough to (a) save the data using e.g. .csv
format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?

Another thing you can try is to copy/paste your Excel data into Word and
use
that as the data source for a merge.

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that
didn't
help, so I changed the way word connects to excel to DDE as described
in
one
of the links. That fixed this problem but created a much larger
problem.

I have 3 columns in a table in word. There is one field per column
merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where
q1
is
supposed to be, it is putting the data from the field Product 1 and
where
p1
is supposed to be, it is putting the data from q1 and where Product 1
is
supposed to be it is putting the data from p1. It's got them all
messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in
the
first 8 rows, you may need to get the OLE DB provider to "see" the
column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does
appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting
data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address
line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do
it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in
the
final
merged document?

Thanks ,
Onalee





  #10  
Old October 8th 08, 03:46 PM posted to microsoft.public.word.mailmerge.fields
Onalee
external usenet poster
 
Posts: 5
Default Merge Excel/Word 2007, getting 12:00AM in merge which is NOT i

Hi,
Right now it has blanks in the first 8 rows - the spread sheet changes daily
as I add rows (I add to the top the most recent data). None of the rows are
'just numbers', if there is anything in them, it is letters AND numbers
usually. When I merge, I don't merge all rows, I pick out the particular
ones I need with a filter in word. If there is nothing in that column, then
nothing prints in word, it's only if there is something (words) in that
column it prints 12:00AM.

Onalee

"Peter Jamieson" wrote:

Does the column have blanks or just numbers in its first 8 rows?

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Answers to questions:

1. Which column is causing the problem (when you do not use DDE) ?

The column is called Address2, it is column "j" if that matters.

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

Most are blank - some have things like "Apt: 202" or "Suite 101", things
lik
that in them.

3. When you save the sheet, are you saving as .xls or .xlsx?


xlsx

NB is your sheet simple enough to (a) save the data using e.g. .csv
format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?


Yes, it is pretty straight forward, only one or two formulas, I could try
that.

Another thing you can try is to copy/paste your Excel data into Word and
use
that as the data source for a merge.


I think I'll try the csv download - upload thing first. The field that is
messed up is not used that often -when it is blank, nothing shows on the
merge, if something is in it however, it shows 12:00AM . I have tried
converting to text (per previous posts here), I have tried deleting that
column and reinserting it, I've tried typing over the data in it, none of
that has changed it.


I'll give the download to csv and upload to a different sheet a try.

thank you,
Onalee


"Peter Jamieson" wrote:


Apparently, this is just some cruel bug in excel that I'll just have to
deal
with.


Could be.

1. Which column is causing the problem (when you do not use DDE) ?

2. Can you give some examples of the kind of data you have in it? (That's
what I didn't understand the first time you asked)

3. When you save the sheet, are you saving as .xls or .xlsx?

NB is your sheet simple enough to (a) save the data using e.g. .csv
format
and (b) recreate the sheet from scratch by opening the .csv, making a few
changes, and saving it as .xls (or .xlsx) ?

Another thing you can try is to copy/paste your Excel data into Word and
use
that as the data source for a merge.

--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
Ok, I tried changing the format of the column as you describe, that
didn't
help, so I changed the way word connects to excel to DDE as described
in
one
of the links. That fixed this problem but created a much larger
problem.

I have 3 columns in a table in word. There is one field per column
merged
from excel, the three fields are : Product 1, q1 and p1 . Now, where
q1
is
supposed to be, it is putting the data from the field Product 1 and
where
p1
is supposed to be, it is putting the data from q1 and where Product 1
is
supposed to be it is putting the data from p1. It's got them all
messed
up
somehow in the mapping or something.

I think it was better the other way, at least that was just one field
messed
up and only sometimes.

any other thoughts?

Thanks,
Onalee

"Peter Jamieson" wrote:

It's possible that you have encountered a new problem that is not
described
at http://tips.pjmsn.me.uk/t0003.htm, but it may be worth trying this
suggestion from that page on your Excel sheet (or one of the following
suggestions):


1. Format a column as text via Data|Text to Columns...

If you have a mixture of numbers and texts in a column but numbers in
the
first 8 rows, you may need to get the OLE DB provider to "see" the
column
as
a text column. However, selecting the column and using Format|Cells to
set
the format as Text does not appear to be enough. One way that does
appear
to
work is
- select the column
- select the Data|Text to Columns... menu option
- click Next through the wizard until you reach Step 3 of 3, then
select
Text as the Column Data Format.



--
Peter Jamieson
http://tips.pjmsn.me.uk

"Onalee" wrote in message
...
Hi,
I am merging data from excel into a word document. I am getting
data
in
word that is showing "12:00AM", however, there is data in the excel
sheet
and
it is NOT a date and it is not blank - it is part of an address
line,
such
as
"Deliver to Front Desk" or any kinds of words, but definately not a
date
and
not blank.

I have tried re-typing the data in excel, I have even put a " ' " in
front
of it to show it is text - nothing gets rid of this . It doesn't do
it
on
every field or even every record on the same field, just some and
seemingly
randomly.

Any idea how to fix this other than manually changing the data in
the
final
merged document?

Thanks ,
Onalee






 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
format field percentage merge Word 2007 from excel 2007 LoisInAlaska Mailmerge 3 September 15th 08 06:47 PM
Mail Merge Labels (Word 2007) w/ Excel (2007) aedcone Microsoft Word Help 2 August 11th 08 03:14 PM
Mail Merge Labels (Word 2007) from Excel (2007) aedcone Microsoft Word Help 3 August 8th 08 03:29 PM
Merge excel 2007 to word 2007 in labels Paula Mailmerge 1 October 17th 07 06:03 AM
mail merge freezes when completing merge - using excel 2007 as sou traci Mailmerge 0 June 19th 07 06:34 PM


All times are GMT +1. The time now is 01:35 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.