A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Caption numbering in chapters



 
 
Thread Tools Display Modes
  #1  
Old October 4th 05, 03:41 PM
Rachel H
external usenet poster
 
Posts: n/a
Default Caption numbering in chapters

I am having trouble numbering tables and figures using the captions command
in Word 97. I am using 3 heading styles in my document which are numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are based on the pre-set
styles for Headings 1-3. I want my tables to be numbered according to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter 2), irrespective of
which sub-section they are in. When I enter a caption, I have ticked the box
'Include chapter number' and set the Chapter number with style 'Heading 1'.
The numbering is fine within a sub-section, but when I move to the next
sub-section within the same chapter, the numbering starts again (still with
the correct chapter number). I can't see why this is or how to override it.
Please can anyone advise me?
Ads
  #2  
Old October 7th 05, 01:38 PM
Stefan Blom
external usenet poster
 
Posts: n/a
Default

Verify that the captions are set up the way you want them (in the
Caption and Caption Numbering dialog boxes). Then select the entire
document and press F9 to update the Seq fields that take care of the
numbering. Does that help? If it doesn't, what field codes show if you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the captions

command
in Word 97. I am using 3 heading styles in my document which are

numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are based on

the pre-set
styles for Headings 1-3. I want my tables to be numbered according

to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter 2),

irrespective of
which sub-section they are in. When I enter a caption, I have ticked

the box
'Include chapter number' and set the Chapter number with style

'Heading 1'.
The numbering is fine within a sub-section, but when I move to the

next
sub-section within the same chapter, the numbering starts again

(still with
the correct chapter number). I can't see why this is or how to

override it.
Please can anyone advise me?




  #3  
Old October 10th 05, 12:05 PM
Rachel H
external usenet poster
 
Posts: n/a
Default

Hi Stefan

Thank you so much for your reply. I am pretty sure I have my settings the
way I want them in the Caption and Caption numbering boxes. I have ticked the
box 'Include chapter number' and set 'Chapter starts with style' to 'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes which I hadn't
looked at before. I don't completely understand what the different parts of
the field code mean, but (with a little help from 'help') I changed the
endings and it now seems to work. The Field codes previously read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now works.

However, although the changes remain when I save the document and re-open
it, if I enter a new caption, they all revert back to the old field codes.
Have you any idea how I can correct my settings so the ending is always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them (in the
Caption and Caption Numbering dialog boxes). Then select the entire
document and press F9 to update the Seq fields that take care of the
numbering. Does that help? If it doesn't, what field codes show if you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the captions

command
in Word 97. I am using 3 heading styles in my document which are

numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are based on

the pre-set
styles for Headings 1-3. I want my tables to be numbered according

to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter 2),

irrespective of
which sub-section they are in. When I enter a caption, I have ticked

the box
'Include chapter number' and set the Chapter number with style

'Heading 1'.
The numbering is fine within a sub-section, but when I move to the

next
sub-section within the same chapter, the numbering starts again

(still with
the correct chapter number). I can't see why this is or how to

override it.
Please can anyone advise me?





  #4  
Old October 10th 05, 12:37 PM
Stefan Blom
external usenet poster
 
Posts: n/a
Default

When you add a chapter number to captions, Word assumes that you also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart the
numbering of this field when it follows a Heading 1 paragraph".

If you don't want the numbering to restart, you can replace \s 1 with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by Word, you
cannot use the Caption dialog box to insert subsequent captions; if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have my

settings the
way I want them in the Caption and Caption numbering boxes. I have

ticked the
box 'Include chapter number' and set 'Chapter starts with style' to

'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes which I

hadn't
looked at before. I don't completely understand what the different

parts of
the field code mean, but (with a little help from 'help') I changed

the
endings and it now seems to work. The Field codes previously read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now works.

However, although the changes remain when I save the document and

re-open
it, if I enter a new caption, they all revert back to the old field

codes.
Have you any idea how I can correct my settings so the ending is

always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them (in the
Caption and Caption Numbering dialog boxes). Then select the

entire
document and press F9 to update the Seq fields that take care of

the
numbering. Does that help? If it doesn't, what field codes show if

you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the

captions
command
in Word 97. I am using 3 heading styles in my document which are

numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are based

on
the pre-set
styles for Headings 1-3. I want my tables to be numbered

according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter 2),

irrespective of
which sub-section they are in. When I enter a caption, I have

ticked
the box
'Include chapter number' and set the Chapter number with style

'Heading 1'.
The numbering is fine within a sub-section, but when I move to

the
next
sub-section within the same chapter, the numbering starts again

(still with
the correct chapter number). I can't see why this is or how to

override it.
Please can anyone advise me?














  #5  
Old October 10th 05, 01:08 PM
Rachel H
external usenet poster
 
Posts: n/a
Default

Thanks Stefan. I do want the numbering to start again after a Heading 1
paragraph, but not after a Heading 2 or 3 paragraph. Unfortunately, this is
what is happening. I realise now that the changes I described before mean
that numbering does not restart in a new chapter, so I had not really worked
out the problem.

I will look into the option of using AutoText entry instead.

Rachel


"Stefan Blom" wrote:

When you add a chapter number to captions, Word assumes that you also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart the
numbering of this field when it follows a Heading 1 paragraph".

If you don't want the numbering to restart, you can replace \s 1 with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by Word, you
cannot use the Caption dialog box to insert subsequent captions; if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have my

settings the
way I want them in the Caption and Caption numbering boxes. I have

ticked the
box 'Include chapter number' and set 'Chapter starts with style' to

'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes which I

hadn't
looked at before. I don't completely understand what the different

parts of
the field code mean, but (with a little help from 'help') I changed

the
endings and it now seems to work. The Field codes previously read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now works.

However, although the changes remain when I save the document and

re-open
it, if I enter a new caption, they all revert back to the old field

codes.
Have you any idea how I can correct my settings so the ending is

always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them (in the
Caption and Caption Numbering dialog boxes). Then select the

entire
document and press F9 to update the Seq fields that take care of

the
numbering. Does that help? If it doesn't, what field codes show if

you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the

captions
command
in Word 97. I am using 3 heading styles in my document which are
numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are based

on
the pre-set
styles for Headings 1-3. I want my tables to be numbered

according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter 2),
irrespective of
which sub-section they are in. When I enter a caption, I have

ticked
the box
'Include chapter number' and set the Chapter number with style
'Heading 1'.
The numbering is fine within a sub-section, but when I move to

the
next
sub-section within the same chapter, the numbering starts again
(still with
the correct chapter number). I can't see why this is or how to
override it.
Please can anyone advise me?














  #6  
Old October 10th 05, 01:47 PM
Stefan Blom
external usenet poster
 
Posts: n/a
Default

Well, if you do want caption numbering to restart after each Heading 1
paragraph, you should be able to do that without changing the field
code by hand (or via AutoText). As explained previously, Word
automatically makes the necessary adjustements to field codes.

Just in case, try again to verify the settings in the Caption
Numbering dialog box. Select the options you want, and click OK
to confirm. Note that if you have multiple captions (for example,
tables and figures), this must be performed for each caption
separately. Then select the whole document and press F9 to update
fields.

If this doesn't help, look at the field codes again. (Use Alt+F9 to
toggle field code display.) Pay attention to the "name", the so-called
identifier, following SEQ. Are there some other sequences in your
document? If you have Figures in addition to Tables, this is to be
expected. You would see { SEQ Figure }, { SEQ Table } where the
different identifiers indicate different numbering sequences.

Another question, if everything else fails: Are you tracking changes?
This apparently prevents the correct updating of Seq fields, until all
changes have been accepted.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote:
Thanks Stefan. I do want the numbering to start again after a

Heading 1
paragraph, but not after a Heading 2 or 3 paragraph. Unfortunately,

this is
what is happening. I realise now that the changes I described before

mean
that numbering does not restart in a new chapter, so I had not

really worked
out the problem.

I will look into the option of using AutoText entry instead.

Rachel


"Stefan Blom" wrote:

When you add a chapter number to captions, Word assumes that you

also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart the
numbering of this field when it follows a Heading 1 paragraph".

If you don't want the numbering to restart, you can replace \s 1

with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by Word, you
cannot use the Caption dialog box to insert subsequent captions;

if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have my

settings the
way I want them in the Caption and Caption numbering boxes. I

have
ticked the
box 'Include chapter number' and set 'Chapter starts with style'

to
'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes which

I
hadn't
looked at before. I don't completely understand what the

different
parts of
the field code mean, but (with a little help from 'help') I

changed
the
endings and it now seems to work. The Field codes previously

read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now works.

However, although the changes remain when I save the document

and
re-open
it, if I enter a new caption, they all revert back to the old

field
codes.
Have you any idea how I can correct my settings so the ending is

always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them (in

the
Caption and Caption Numbering dialog boxes). Then select the

entire
document and press F9 to update the Seq fields that take care

of
the
numbering. Does that help? If it doesn't, what field codes

show if
you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the

captions
command
in Word 97. I am using 3 heading styles in my document which

are
numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are

based
on
the pre-set
styles for Headings 1-3. I want my tables to be numbered

according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter

2),
irrespective of
which sub-section they are in. When I enter a caption, I

have
ticked
the box
'Include chapter number' and set the Chapter number with

style
'Heading 1'.
The numbering is fine within a sub-section, but when I move

to
the
next
sub-section within the same chapter, the numbering starts

again
(still with
the correct chapter number). I can't see why this is or how

to
override it.
Please can anyone advise me?






















  #7  
Old October 10th 05, 04:01 PM
Rachel H
external usenet poster
 
Posts: n/a
Default

I have double checked all the fields and I only have { SEQ Figure } or { SEQ
Table } identifiers. I have double checked the numbering is up to date by
selecting all and pressing F9. I am not using track changes so I don't think
that is a problem.

Although I have set the numbering to restart with Heading 1, Word is also
restarting the numbering (for both tables and figures) after Heading 2 and
Heading 3. I tried starting a new document from scratch using the preset
heading styles and still had the same problem, so I don't think I have
altered the style settings in any way that will cause Word to think that
Headings 2 or 3 are Heading 1.

I have now written macros to inset the captions how I want them and,
although not perfect, I think I can manage my numbering better now. I really
appreciate all your advice - you have helped me to understand field codes a
little and work out a way around my problem.

Rachel


"Stefan Blom" wrote:

Well, if you do want caption numbering to restart after each Heading 1
paragraph, you should be able to do that without changing the field
code by hand (or via AutoText). As explained previously, Word
automatically makes the necessary adjustements to field codes.

Just in case, try again to verify the settings in the Caption
Numbering dialog box. Select the options you want, and click OK
to confirm. Note that if you have multiple captions (for example,
tables and figures), this must be performed for each caption
separately. Then select the whole document and press F9 to update
fields.

If this doesn't help, look at the field codes again. (Use Alt+F9 to
toggle field code display.) Pay attention to the "name", the so-called
identifier, following SEQ. Are there some other sequences in your
document? If you have Figures in addition to Tables, this is to be
expected. You would see { SEQ Figure }, { SEQ Table } where the
different identifiers indicate different numbering sequences.

Another question, if everything else fails: Are you tracking changes?
This apparently prevents the correct updating of Seq fields, until all
changes have been accepted.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote:
Thanks Stefan. I do want the numbering to start again after a

Heading 1
paragraph, but not after a Heading 2 or 3 paragraph. Unfortunately,

this is
what is happening. I realise now that the changes I described before

mean
that numbering does not restart in a new chapter, so I had not

really worked
out the problem.

I will look into the option of using AutoText entry instead.

Rachel


"Stefan Blom" wrote:

When you add a chapter number to captions, Word assumes that you

also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart the
numbering of this field when it follows a Heading 1 paragraph".

If you don't want the numbering to restart, you can replace \s 1

with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by Word, you
cannot use the Caption dialog box to insert subsequent captions;

if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have my
settings the
way I want them in the Caption and Caption numbering boxes. I

have
ticked the
box 'Include chapter number' and set 'Chapter starts with style'

to
'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes which

I
hadn't
looked at before. I don't completely understand what the

different
parts of
the field code mean, but (with a little help from 'help') I

changed
the
endings and it now seems to work. The Field codes previously

read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now works.

However, although the changes remain when I save the document

and
re-open
it, if I enter a new caption, they all revert back to the old

field
codes.
Have you any idea how I can correct my settings so the ending is
always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them (in

the
Caption and Caption Numbering dialog boxes). Then select the
entire
document and press F9 to update the Seq fields that take care

of
the
numbering. Does that help? If it doesn't, what field codes

show if
you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using the
captions
command
in Word 97. I am using 3 heading styles in my document which

are
numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are

based
on
the pre-set
styles for Headings 1-3. I want my tables to be numbered
according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in Chapter

2),
irrespective of
which sub-section they are in. When I enter a caption, I

have
ticked
the box
'Include chapter number' and set the Chapter number with

style
'Heading 1'.
The numbering is fine within a sub-section, but when I move

to
the
next
sub-section within the same chapter, the numbering starts

again
(still with
the correct chapter number). I can't see why this is or how

to
override it.
Please can anyone advise me?























  #8  
Old October 13th 05, 11:55 AM
Stefan Blom
external usenet poster
 
Posts: n/a
Default

Strange! If you want to, I could take a look at the document (or
relevant parts of it). Just send it to

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
news
I have double checked all the fields and I only have { SEQ Figure }

or { SEQ
Table } identifiers. I have double checked the numbering is up to

date by
selecting all and pressing F9. I am not using track changes so I

don't think
that is a problem.

Although I have set the numbering to restart with Heading 1, Word is

also
restarting the numbering (for both tables and figures) after Heading

2 and
Heading 3. I tried starting a new document from scratch using the

preset
heading styles and still had the same problem, so I don't think I

have
altered the style settings in any way that will cause Word to think

that
Headings 2 or 3 are Heading 1.

I have now written macros to inset the captions how I want them and,
although not perfect, I think I can manage my numbering better now.

I really
appreciate all your advice - you have helped me to understand field

codes a
little and work out a way around my problem.

Rachel


"Stefan Blom" wrote:

Well, if you do want caption numbering to restart after each

Heading 1
paragraph, you should be able to do that without changing the

field
code by hand (or via AutoText). As explained previously, Word
automatically makes the necessary adjustements to field codes.

Just in case, try again to verify the settings in the Caption
Numbering dialog box. Select the options you want, and click OK
to confirm. Note that if you have multiple captions (for example,
tables and figures), this must be performed for each caption
separately. Then select the whole document and press F9 to update
fields.

If this doesn't help, look at the field codes again. (Use Alt+F9

to
toggle field code display.) Pay attention to the "name", the

so-called
identifier, following SEQ. Are there some other sequences in your
document? If you have Figures in addition to Tables, this is to be
expected. You would see { SEQ Figure }, { SEQ Table } where the
different identifiers indicate different numbering sequences.

Another question, if everything else fails: Are you tracking

changes?
This apparently prevents the correct updating of Seq fields, until

all
changes have been accepted.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote:
Thanks Stefan. I do want the numbering to start again after a

Heading 1
paragraph, but not after a Heading 2 or 3 paragraph.

Unfortunately,
this is
what is happening. I realise now that the changes I described

before
mean
that numbering does not restart in a new chapter, so I had not

really worked
out the problem.

I will look into the option of using AutoText entry instead.

Rachel


"Stefan Blom" wrote:

When you add a chapter number to captions, Word assumes that

you
also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart the
numbering of this field when it follows a Heading 1

paragraph".

If you don't want the numbering to restart, you can replace \s

1
with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by Word,

you
cannot use the Caption dialog box to insert subsequent

captions;
if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and

create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have my
settings the
way I want them in the Caption and Caption numbering boxes.

I
have
ticked the
box 'Include chapter number' and set 'Chapter starts with

style'
to
'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes

which
I
hadn't
looked at before. I don't completely understand what the

different
parts of
the field code mean, but (with a little help from 'help') I

changed
the
endings and it now seems to work. The Field codes previously

read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now

works.

However, although the changes remain when I save the

document
and
re-open
it, if I enter a new caption, they all revert back to the

old
field
codes.
Have you any idea how I can correct my settings so the

ending is
always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want them

(in
the
Caption and Caption Numbering dialog boxes). Then select

the
entire
document and press F9 to update the Seq fields that take

care
of
the
numbering. Does that help? If it doesn't, what field codes

show if
you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
I am having trouble numbering tables and figures using

the
captions
command
in Word 97. I am using 3 heading styles in my document

which
are
numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These are

based
on
the pre-set
styles for Headings 1-3. I want my tables to be numbered
according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in

Chapter
2),
irrespective of
which sub-section they are in. When I enter a caption, I

have
ticked
the box
'Include chapter number' and set the Chapter number with

style
'Heading 1'.
The numbering is fine within a sub-section, but when I

move
to
the
next
sub-section within the same chapter, the numbering

starts
again
(still with
the correct chapter number). I can't see why this is or

how
to
override it.
Please can anyone advise me?




























  #9  
Old October 19th 05, 10:21 AM
Stefan Blom
external usenet poster
 
Posts: n/a
Default Caption numbering in chapters

I received an example document from Rachel, and it turned out to work
correctly on my system. Here's the explanation:

WD97: Caption with Chapter Numbering Reset to 1
http://support.microsoft.com/default...b;en-us;160915

--
Stefan Blom
Microsoft Word MVP


"Stefan Blom" wrote in message
...
Strange! If you want to, I could take a look at the document (or
relevant parts of it). Just send it to

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
news
I have double checked all the fields and I only have { SEQ

Figure }
or { SEQ
Table } identifiers. I have double checked the numbering is up to

date by
selecting all and pressing F9. I am not using track changes so I

don't think
that is a problem.

Although I have set the numbering to restart with Heading 1, Word

is
also
restarting the numbering (for both tables and figures) after

Heading
2 and
Heading 3. I tried starting a new document from scratch using the

preset
heading styles and still had the same problem, so I don't think I

have
altered the style settings in any way that will cause Word to

think
that
Headings 2 or 3 are Heading 1.

I have now written macros to inset the captions how I want them

and,
although not perfect, I think I can manage my numbering better

now.
I really
appreciate all your advice - you have helped me to understand

field
codes a
little and work out a way around my problem.

Rachel


"Stefan Blom" wrote:

Well, if you do want caption numbering to restart after each

Heading 1
paragraph, you should be able to do that without changing the

field
code by hand (or via AutoText). As explained previously, Word
automatically makes the necessary adjustements to field codes.

Just in case, try again to verify the settings in the Caption
Numbering dialog box. Select the options you want, and click OK
to confirm. Note that if you have multiple captions (for

example,
tables and figures), this must be performed for each caption
separately. Then select the whole document and press F9 to

update
fields.

If this doesn't help, look at the field codes again. (Use Alt+F9

to
toggle field code display.) Pay attention to the "name", the

so-called
identifier, following SEQ. Are there some other sequences in

your
document? If you have Figures in addition to Tables, this is to

be
expected. You would see { SEQ Figure }, { SEQ Table } where the
different identifiers indicate different numbering sequences.

Another question, if everything else fails: Are you tracking

changes?
This apparently prevents the correct updating of Seq fields,

until
all
changes have been accepted.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote:
Thanks Stefan. I do want the numbering to start again after a
Heading 1
paragraph, but not after a Heading 2 or 3 paragraph.

Unfortunately,
this is
what is happening. I realise now that the changes I described

before
mean
that numbering does not restart in a new chapter, so I had not
really worked
out the problem.

I will look into the option of using AutoText entry instead.

Rachel


"Stefan Blom" wrote:

When you add a chapter number to captions, Word assumes that

you
also
want to restart caption numbering after the selected chapter
(heading). That's what \s 1 means in a Seq field: "restart

the
numbering of this field when it follows a Heading 1

paragraph".

If you don't want the numbering to restart, you can replace

\s
1
with
\n (as you've seen), or more easily just delete \s 1.

But once you've manually changed the fields inserted by

Word,
you
cannot use the Caption dialog box to insert subsequent

captions;
if
you do, Word will re-insert the \s switch.

Instead, you can select the caption label and number and

create an
AutoText entry for the insertion.

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message
...
Hi Stefan

Thank you so much for your reply. I am pretty sure I have

my
settings the
way I want them in the Caption and Caption numbering

boxes.
I
have
ticked the
box 'Include chapter number' and set 'Chapter starts with

style'
to
'Heading
1'.

I pressed Alt+F9 as advised and looked at the field codes

which
I
hadn't
looked at before. I don't completely understand what the
different
parts of
the field code mean, but (with a little help from 'help')

I
changed
the
endings and it now seems to work. The Field codes

previously
read:

{ STYLEREF 1 \s }.{ SEQ Table \* ARABIC \s 1}

I changed the final \s 1} to \n} and the numbering now

works.

However, although the changes remain when I save the

document
and
re-open
it, if I enter a new caption, they all revert back to the

old
field
codes.
Have you any idea how I can correct my settings so the

ending is
always \n} ?

Thanks

Rachel


"Stefan Blom" wrote:

Verify that the captions are set up the way you want

them
(in
the
Caption and Caption Numbering dialog boxes). Then select

the
entire
document and press F9 to update the Seq fields that take

care
of
the
numbering. Does that help? If it doesn't, what field

codes
show if
you
press Alt+F9?

--
Stefan Blom
Microsoft Word MVP


"Rachel H" wrote in message

...
I am having trouble numbering tables and figures using

the
captions
command
in Word 97. I am using 3 heading styles in my document

which
are
numbered
(e.g.) Chapter 1, 1.1, 1.1.1 and respectively. These

are
based
on
the pre-set
styles for Headings 1-3. I want my tables to be

numbered
according
to the
chapter number (e.g. Table 2.1, Table 2.2 etc. in

Chapter
2),
irrespective of
which sub-section they are in. When I enter a caption,

I
have
ticked
the box
'Include chapter number' and set the Chapter number

with
style
'Heading 1'.
The numbering is fine within a sub-section, but when I

move
to
the
next
sub-section within the same chapter, the numbering

starts
again
(still with
the correct chapter number). I can't see why this is

or
how
to
override it.
Please can anyone advise me?
































 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto-insert numbering when caption style applied termiflyer Microsoft Word Help 6 August 18th 05 09:00 PM
Caption numbering reset Guy Tables 1 March 9th 05 07:40 AM
Numbering - skip a level BruceM Microsoft Word Help 4 February 10th 05 07:56 PM
caption numbering Jin Tables 3 December 22nd 04 08:27 AM
table caption numbering scottkinsey Tables 1 November 11th 04 11:47 AM


All times are GMT +1. The time now is 11:10 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2004-2021 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.