A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

"Do not check spelling or grammar" will not turn off



 
 
Thread Tools Display Modes
  #1  
Old July 10th 08, 09:48 PM posted to microsoft.public.word.docmanagement
HelpIsOnTheWay
external usenet poster
 
Posts: 2
Default "Do not check spelling or grammar" will not turn off

I am a highly advanced Word user and I can't turn off the "Do not check
spelling or grammar" feature. I tried the following, none of them worked:
- Selected the entire document (Ctrl+A), then go to Tools Language Set
Language and clear the check box for "Do not check spelling or grammar".
(did this multiple times)
- Did a Find/Replace for the formatting (Crrl+F, more, Format, Language, etc.)
- I even pasted unformatted into a new document

Some sections still have it turned on and I can't seem to get rid of it!
Any help would be appreciated,
Thanks.

Ads
  #2  
Old July 11th 08, 02:55 PM posted to microsoft.public.word.docmanagement
Cindy M.
external usenet poster
 
Posts: 2,416
Default "Do not check spelling or grammar" will not turn off

Hi =?Utf-8?B?SGVscElzT25UaGVXYXk=?=,

I am a highly advanced Word user and I can't turn off the "Do not check
spelling or grammar" feature. I tried the following, none of them worked:
- Selected the entire document (Ctrl+A), then go to Tools Language Set
Language and clear the check box for "Do not check spelling or grammar".
(did this multiple times)
- Did a Find/Replace for the formatting (Crrl+F, more, Format, Language, etc.)
- I even pasted unformatted into a new document

Some sections still have it turned on and I can't seem to get rid of it!

Which version of Word is involved, here?

Are FIELDS involved in any of these "sections" where you're having difficulties?
If yes, what kinds of fields?

What is the language of these sections? And do they use any special fonts?

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 17 2005)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)

  #3  
Old July 11th 08, 05:21 PM posted to microsoft.public.word.docmanagement
HelpIsOnTheWay
external usenet poster
 
Posts: 2
Default "Do not check spelling or grammar" will not turn off

I'm using a corporate version of Word 2003, SP2. There are some fields
(Table of Contents and Page Numbers), but even when I strip them out, and I
select All, I can never get the "Do Not Check Spelling or Grammar" box to
permanently clear. I clear the check box, I click OK, then I go back to
Tools, Language, Set Language, and the box is highlighted (not checked, but
highlighted) again!

The language is English, US and I am only using Times New Roman.

"Cindy M." wrote:

Hi =?Utf-8?B?SGVscElzT25UaGVXYXk=?=,

I am a highly advanced Word user and I can't turn off the "Do not check
spelling or grammar" feature. I tried the following, none of them worked:
- Selected the entire document (Ctrl+A), then go to Tools Language Set
Language and clear the check box for "Do not check spelling or grammar".
(did this multiple times)
- Did a Find/Replace for the formatting (Crrl+F, more, Format, Language, etc.)
- I even pasted unformatted into a new document

Some sections still have it turned on and I can't seem to get rid of it!

Which version of Word is involved, here?

Are FIELDS involved in any of these "sections" where you're having difficulties?
If yes, what kinds of fields?

What is the language of these sections? And do they use any special fonts?

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 17 2005)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)


  #4  
Old July 12th 08, 04:26 PM posted to microsoft.public.word.docmanagement
Cindy M.
external usenet poster
 
Posts: 2,416
Default "Do not check spelling or grammar" will not turn off

Hi =?Utf-8?B?SGVscElzT25UaGVXYXk=?=,

I'm using a corporate version of Word 2003, SP2. There are some fields
(Table of Contents and Page Numbers), but even when I strip them out, and I
select All, I can never get the "Do Not Check Spelling or Grammar" box to
permanently clear. I clear the check box, I click OK, then I go back to
Tools, Language, Set Language, and the box is highlighted (not checked, but
highlighted) again!

The language is English, US and I am only using Times New Roman.

Thanks for emphasizing the "not checked, but highlighted". This means a
"mixed" setting.

I now recognize what you're seeing, and I'm pretty sure there's no way you can
get rid of it. A while back (year? Two years?) this came up and a number of us
did some intensive testing, I also reported it to MSFT.

As soon as a document grows beyond a certain size (number of pages) Word
starts formatting the "automatic page breaks" with some kind of language
formatting. Very difficult to track down - I had to examine the XML (saveas to
that file format) to actually see where it was coming from. Even deleting it
out of the XML didn't clean the mixed formatting out of the document.

I chalk the behavior up to the increasing tendency of the Word team thinking
it's good and OK to apply the language set in Windows as the default. As often
as I, and others, have tried to explain that this is a BAD idea in the world
professional documentation, they still haven't grasped the underlying logic of
that viewpoint...

If you need to be sure that none of the actual text is formatted with a
different language, your best bet may be to "walk" the pages or the paragraphs
in a macro, checking the LanguageID of the range. If it's not your language
(US English) then you (the editor) need to take a closer look at that range.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 17 2005)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or
reply in the newsgroup and not by e-mail :-)

  #5  
Old September 7th 08, 04:30 PM posted to microsoft.public.word.docmanagement
Aldo
external usenet poster
 
Posts: 1
Default "Do not check spelling or grammar" will not turn off

Same problem. It's very annoying. My document only had 3 pages. I had to
select the text page by page to apply the setting, otherwise it won't work.


"Cindy M." wrote:

Hi =?Utf-8?B?SGVscElzT25UaGVXYXk=?=,

I'm using a corporate version of Word 2003, SP2. There are some fields
(Table of Contents and Page Numbers), but even when I strip them out, and I
select All, I can never get the "Do Not Check Spelling or Grammar" box to
permanently clear. I clear the check box, I click OK, then I go back to
Tools, Language, Set Language, and the box is highlighted (not checked, but
highlighted) again!

The language is English, US and I am only using Times New Roman.

Thanks for emphasizing the "not checked, but highlighted". This means a
"mixed" setting.

I now recognize what you're seeing, and I'm pretty sure there's no way you can
get rid of it. A while back (year? Two years?) this came up and a number of us
did some intensive testing, I also reported it to MSFT.

As soon as a document grows beyond a certain size (number of pages) Word
starts formatting the "automatic page breaks" with some kind of language
formatting. Very difficult to track down - I had to examine the XML (saveas to
that file format) to actually see where it was coming from. Even deleting it
out of the XML didn't clean the mixed formatting out of the document.

I chalk the behavior up to the increasing tendency of the Word team thinking
it's good and OK to apply the language set in Windows as the default. As often
as I, and others, have tried to explain that this is a BAD idea in the world
professional documentation, they still haven't grasped the underlying logic of
that viewpoint...

If you need to be sure that none of the actual text is formatted with a
different language, your best bet may be to "walk" the pages or the paragraphs
in a macro, checking the LanguageID of the range. If it's not your language
(US English) then you (the editor) need to take a closer look at that range.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 17 2005)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or
reply in the newsgroup and not by e-mail :-)


  #6  
Old April 20th 18, 03:21 AM
MSWordGuy MSWordGuy is offline
Junior Member
 
First recorded activity by WordBanter: Aug 2010
Posts: 1
Default

Sorry to ping an old thread but this comes up in searches, so needs answering... and I think I have the solution.

First switch to Draft view (where the whole document appears in one long view without pages), then using Ctrl+A, going to Review / Language / Set Proofing Language and clearing the "do not check spelling or grammar" option.

**Only works in Draft view**.* For some strange reason the same thing does not work in standard print layout view.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
find text marked "Do not check spelling or grammar" cayce Microsoft Word Help 5 January 18th 17 08:22 AM
turn of 'do not check spelling and grammar" simeon Microsoft Word Help 2 January 16th 08 08:08 AM
"Text marked do not check spelling or grammar was skipped." flamestar Microsoft Word Help 1 May 8th 07 03:54 AM
Text erroneously flagged "do not check spelling or grammar" mgmooney Microsoft Word Help 2 August 28th 06 10:13 PM
Word should say "Spelling and grammar check ARE complete" not "is" JAD240 Microsoft Word Help 1 January 1st 06 01:10 AM


All times are GMT +1. The time now is 11:08 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.