A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Macro Security ?



 
 
Thread Tools Display Modes
  #1  
Old March 6th 06, 08:49 PM posted to microsoft.public.word.docmanagement
external usenet poster
 
Posts: n/a
Default Macro Security ?

I have created several Macros that won't run from buttons on the toolbar. If
I go to Tools - Macros - Macros and select the Macro from the list and
click on 'Run', they work just fine. To make things faster, I have created
(dragged) them to a button on the toolbar (Tools - Customize - etc.). But,
when I use the button, I get the "macro cannot be found or disabled due to
security settings" error. My security settings are at "Medium". I am
running Word 2002. (These same macros worked just fine under Word 2000.
Note: I didn't copy in the VB commands, I created them by stepping through
the actions.)

Thanks in advance.
Ads
  #2  
Old March 7th 06, 02:28 AM posted to microsoft.public.word.docmanagement
external usenet poster
 
Posts: n/a
Default Macro Security ?


In your macro security settings, check the box to trust installed templates
and Add-Ins. See http://addbalance.com/word/movetotemplate.htm for
step-by-step instructions on moving / sharing / copying / backing-up
customizations including AutoText, AutoCorrect, keyboard assignments,
toolbars, macros, etc.
--

Charles Kenyon

Word New User FAQ & Web Directory: http://addbalance.com/word

Intermediate User's Guide to Microsoft Word (supplemented version of
Microsoft's Legal Users' Guide) http://addbalance.com/usersguide

See also the MVP FAQ: http://word.mvps.org/FAQs/ which is awesome!
--------- --------- --------- --------- --------- ---------
This message is posted to a newsgroup. Please post replies
and questions to the newsgroup so that others can learn
from my ignorance and your wisdom.

"GaijinSue" wrote in message
...
I have created several Macros that won't run from buttons on the toolbar.
If
I go to Tools - Macros - Macros and select the Macro from the list and
click on 'Run', they work just fine. To make things faster, I have
created
(dragged) them to a button on the toolbar (Tools - Customize - etc.).
But,
when I use the button, I get the "macro cannot be found or disabled due to
security settings" error. My security settings are at "Medium". I am
running Word 2002. (These same macros worked just fine under Word 2000.
Note: I didn't copy in the VB commands, I created them by stepping
through
the actions.)

Thanks in advance.



  #3  
Old March 7th 06, 07:10 PM posted to microsoft.public.word.docmanagement
external usenet poster
 
Posts: n/a
Default Macro Security ?

Ooops. Should have mentioned that in my original post. That option is
already checked. I've even unchecked it and re-checked it again to no avail.

Thanks in advance.

"Charles Kenyon" wrote:


In your macro security settings, check the box to trust installed templates
and Add-Ins. See http://addbalance.com/word/movetotemplate.htm for
step-by-step instructions on moving / sharing / copying / backing-up
customizations including AutoText, AutoCorrect, keyboard assignments,
toolbars, macros, etc.
--

Charles Kenyon

Word New User FAQ & Web Directory: http://addbalance.com/word

Intermediate User's Guide to Microsoft Word (supplemented version of
Microsoft's Legal Users' Guide) http://addbalance.com/usersguide

See also the MVP FAQ: http://word.mvps.org/FAQs/ which is awesome!
--------- --------- --------- --------- --------- ---------
This message is posted to a newsgroup. Please post replies
and questions to the newsgroup so that others can learn
from my ignorance and your wisdom.

"GaijinSue" wrote in message
...
I have created several Macros that won't run from buttons on the toolbar.
If
I go to Tools - Macros - Macros and select the Macro from the list and
click on 'Run', they work just fine. To make things faster, I have
created
(dragged) them to a button on the toolbar (Tools - Customize - etc.).
But,
when I use the button, I get the "macro cannot be found or disabled due to
security settings" error. My security settings are at "Medium". I am
running Word 2002. (These same macros worked just fine under Word 2000.
Note: I didn't copy in the VB commands, I created them by stepping
through
the actions.)

Thanks in advance.




 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update field and macro security Redapples Microsoft Word Help 2 February 2nd 06 04:41 PM
Macro Security Dan Mailmerge 5 January 5th 06 11:37 AM
Macro Security JD Microsoft Word Help 11 April 24th 05 03:02 PM
macro security will not stay set jam Microsoft Word Help 1 April 6th 05 12:03 PM
Save As is not working due to macro security settings Craig Meritz Microsoft Word Help 1 December 16th 04 04:53 AM


All times are GMT +1. The time now is 05:33 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.