A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Setting the default encoding...?



 
 
Thread Tools Display Modes
  #1  
Old May 10th 05, 01:04 PM
Kenneth
external usenet poster
 
Posts: n/a
Default Setting the default encoding...?


Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,
--
Kenneth

If you email... Please remove the "SPAMLESS."
Ads
  #2  
Old May 10th 05, 06:03 PM
Bob Buckland ?:-\)
external usenet poster
 
Posts: n/a
Default

Hi Kenneth,

This article may help:
http://support.microsoft.com/default...us;256060&FR=1

========
"Kenneth" wrote in message ...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth
--
Let us know if this helped you,

Bob Buckland ?:-)
MS Office System Products MVP

*Courtesy is not expensive and can pay big dividends*

Office 2003 Editions explained
http://www.microsoft.com/uk/office/editions.mspx


  #3  
Old May 10th 05, 06:43 PM
Kenneth
external usenet poster
 
Posts: n/a
Default

On Tue, 10 May 2005 10:03:42 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:

Hi Kenneth,

This article may help:
http://support.microsoft.com/default...us;256060&FR=1

========
"Kenneth" wrote in message ...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth


Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."
  #4  
Old May 10th 05, 07:00 PM
Bob Buckland ?:-\)
external usenet poster
 
Posts: n/a
Default

Hi Kenneth,

Did you use the macro technique in method 1?

=======
"Kenneth" wrote in message ...
Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth
--
Bob Buckland ?:-)
MS Office System Products MVP

*Courtesy is not expensive and can pay big dividends*


  #5  
Old May 10th 05, 07:33 PM
Klaus Linke
external usenet poster
 
Posts: n/a
Default

Hi Kenneth,

You must have seen a different KB article. And I don't think there is a =
registry setting for a default "open" encoding, since such a default =
setting would be a terrible idea.

You can use a macro to open text files using the specific encoding you =
want (maybe using some more sophisticated macro than the one from the KB =
article, which lets you specify the file using the "File Open" =
dialog).

You can even replace the "File Open" dialog with your sophisticated =
macro (though I wouldn't do that).

You can't set a default encoding for text files. The default in Windows =
apps is the Windows code page, or Unicode.
Either you let Word guess (with "confirm conversions" turned off), which =
will work for Windows text files and Unicode text files, or you'll have =
to specify the encoding (manually or by writing a macro).

Regards,
Klaus


"Kenneth" wrote:
On Tue, 10 May 2005 10:03:42 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:
=20
Hi Kenneth,

This article may help:
=

http://support.microsoft.com/default...;256060&FR=3D1

=3D=3D=3D=3D=3D=3D=3D=3D
"Kenneth" wrote in message =

...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth

=20
Hi Bob,
=20
I appreciate your response, but...
=20
I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.
=20
Do you know if there was something beyond the reg hack that
I was to have done?
=20
Thanks again,
--=20
Kenneth
=20
If you email... Please remove the "SPAMLESS."

  #6  
Old May 10th 05, 07:44 PM
Kenneth
external usenet poster
 
Posts: n/a
Default

On Tue, 10 May 2005 11:00:58 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:

Hi Kenneth,

Did you use the macro technique in method 1?

=======
"Kenneth" wrote in message ...
Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth


Hi Bob,

Well I "tried" the Macro technique...

I got the file with the macros, but when I attempted to run
the appropriate one, it did not succeed (with regret, I
cannot remember the precise error.)

In summary, "No" I did not run the macro.

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."
  #7  
Old May 10th 05, 07:46 PM
Kenneth
external usenet poster
 
Posts: n/a
Default

On Tue, 10 May 2005 20:33:26 +0200, "Klaus Linke"
wrote:



"Kenneth" wrote:
On Tue, 10 May 2005 10:03:42 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:

Hi Kenneth,

This article may help:
http://support.microsoft.com/default...us;256060&FR=1

========
"Kenneth" wrote in message ...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth


Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."


Hi Kenneth,

You must have seen a different KB article. And I don't think there is a registry setting for a default "open" encoding, since such a default setting would be a terrible idea.

You can use a macro to open text files using the specific encoding you want (maybe using some more sophisticated macro than the one from the KB article, which lets you specify the file using the "File Open" dialog).

You can even replace the "File Open" dialog with your sophisticated macro (though I wouldn't do that).

You can't set a default encoding for text files. The default in Windows apps is the Windows code page, or Unicode.
Either you let Word guess (with "confirm conversions" turned off), which will work for Windows text files and Unicode text files, or you'll have to specify the encoding (manually or by writing a macro).

Regards,
Klaus


Hi Klaus,

It is only for TXT files that I would like to set a default
encoding.

Is there a way to do that?

Or, if I wish to have Word "guess", is there a way to have
it do that?

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."
  #8  
Old May 10th 05, 09:09 PM
Klaus Linke
external usenet poster
 
Posts: n/a
Default

Hi Kenneth,

I'd like to take a step back, because I'm still not sure what you are =
trying to do.
The (recoded) macro you posted in the other thread contained =
"InsertFile".
I don't see how you can specify the encoding for "InsertFile", either.

Here, you're talking about "File Open", where you can specify the =
encoding.
But I'm not sure why you'd need to (either opening or inserting a text =
file).

As far as I understood, you're saving the text files yourself.=20
If you use "Plain text" (=3D Windows text) for saving the text file, you =
shouldn't need to specify any encoding when you re-open or insert the =
file.=20
And if the "Confirm conversions" dialog (in "File Open" or "Insert =
File") bothers you, you should be able to turn that off.

In this thread, you said that the "Confirm conversion" dialog comes up. =
Did you uncheck the option in "Tools General" and it still comes up? =
Then maybe that's the bug that might be solved by the hotfix from =
http://support.microsoft.com/kb/817140
(Can't say for sure because I've never run into this bug)

In the other thread, you said that some characters change into blanks if =
you re-open the text file.
Are you sure those characters *can* be saved in a Windows plain text =
file? Which characters are turned into blanks?

Regards,
Klaus



"Kenneth" schrieb im Newsbeitrag =
...
On Tue, 10 May 2005 20:33:26 +0200, "Klaus Linke"
wrote:
=20
=20

"Kenneth" wrote:
On Tue, 10 May 2005 10:03:42 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:
=20
Hi Kenneth,

This article may help:
=

http://support.microsoft.com/default...;256060&FR=3D1

=3D=3D=3D=3D=3D=3D=3D=3D
"Kenneth" wrote in message =

...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth
=20
Hi Bob,
=20
I appreciate your response, but...
=20
I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.
=20
Do you know if there was something beyond the reg hack that
I was to have done?
=20
Thanks again,
--=20
Kenneth
=20
If you email... Please remove the "SPAMLESS."

=20
Hi Kenneth,

You must have seen a different KB article. And I don't think there is =

a registry setting for a default "open" encoding, since such a default =
setting would be a terrible idea.

You can use a macro to open text files using the specific encoding =

you want (maybe using some more sophisticated macro than the one from =
the KB article, which lets you specify the file using the "File Open" =
dialog).

You can even replace the "File Open" dialog with your sophisticated =

macro (though I wouldn't do that).

You can't set a default encoding for text files. The default in =

Windows apps is the Windows code page, or Unicode.
Either you let Word guess (with "confirm conversions" turned off), =

which will work for Windows text files and Unicode text files, or you'll =
have to specify the encoding (manually or by writing a macro).

Regards,
Klaus

=20
Hi Klaus,
=20
It is only for TXT files that I would like to set a default
encoding.
=20
Is there a way to do that?
=20
Or, if I wish to have Word "guess", is there a way to have
it do that?
=20
Thanks again,
--=20
Kenneth
=20
If you email... Please remove the "SPAMLESS."

  #9  
Old May 10th 05, 09:13 PM
Kenneth
external usenet poster
 
Posts: n/a
Default

On Tue, 10 May 2005 14:44:02 -0400, Kenneth
wrote:

On Tue, 10 May 2005 11:00:58 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:

Hi Kenneth,

Did you use the macro technique in method 1?

=======
"Kenneth" wrote in message ...
Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth


Hi Bob,

Well I "tried" the Macro technique...

I got the file with the macros, but when I attempted to run
the appropriate one, it did not succeed (with regret, I
cannot remember the precise error.)

In summary, "No" I did not run the macro.

Thanks again,


Hi again Bob,

I just tried to run the macro again.

The Word Basic error is

Compile Error:

Ambiguous name detected HKEY_LOCAL_MACHINE

Thanks for any further thoughts,
--
Kenneth

If you email... Please remove the "SPAMLESS."
  #10  
Old May 10th 05, 09:28 PM
Kenneth
external usenet poster
 
Posts: n/a
Default

On Tue, 10 May 2005 22:09:28 +0200, "Klaus Linke"
wrote:

Hi Kenneth,

I'd like to take a step back, because I'm still not sure what you are trying to do.
The (recoded) macro you posted in the other thread contained "InsertFile".
I don't see how you can specify the encoding for "InsertFile", either.

Here, you're talking about "File Open", where you can specify the encoding.
But I'm not sure why you'd need to (either opening or inserting a text file).

As far as I understood, you're saving the text files yourself.
If you use "Plain text" (= Windows text) for saving the text file, you shouldn't need to specify any encoding when you re-open or insert the file.
And if the "Confirm conversions" dialog (in "File Open" or "Insert File") bothers you, you should be able to turn that off.

In this thread, you said that the "Confirm conversion" dialog comes up. Did you uncheck the option in "Tools General" and it still comes up? Then maybe that's the bug that might be solved by the hotfix from http://support.microsoft.com/kb/817140
(Can't say for sure because I've never run into this bug)

In the other thread, you said that some characters change into blanks if you re-open the text file.
Are you sure those characters *can* be saved in a Windows plain text file? Which characters are turned into blanks?

Regards,
Klaus



"Kenneth" schrieb im Newsbeitrag ...
On Tue, 10 May 2005 20:33:26 +0200, "Klaus Linke"
wrote:



"Kenneth" wrote:
On Tue, 10 May 2005 10:03:42 -0700, "Bob Buckland ?:-\)"
75214.226(At Beautiful Downtown)compuserve.com wrote:

Hi Kenneth,

This article may help:
http://support.microsoft.com/default...us;256060&FR=1

========
"Kenneth" wrote in message ...

Howdy,

When I open a TXT file in Word 2000 (or insert a TXT file in
another open DOC) a dialog opens asking how I want the
characters in the file converted.

How can I set the default to a particular conversion so that
the dialog does not open each time?

Sincere thanks,

Kenneth

Hi Bob,

I appreciate your response, but...

I had found that article on my own. I made the registry
modification as described, re-booted, but still had the
problem.

Do you know if there was something beyond the reg hack that
I was to have done?

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."


Hi Kenneth,

You must have seen a different KB article. And I don't think there is a registry setting for a default "open" encoding, since such a default setting would be a terrible idea.

You can use a macro to open text files using the specific encoding you want (maybe using some more sophisticated macro than the one from the KB article, which lets you specify the file using the "File Open" dialog).

You can even replace the "File Open" dialog with your sophisticated macro (though I wouldn't do that).

You can't set a default encoding for text files. The default in Windows apps is the Windows code page, or Unicode.
Either you let Word guess (with "confirm conversions" turned off), which will work for Windows text files and Unicode text files, or you'll have to specify the encoding (manually or by writing a macro).

Regards,
Klaus


Hi Klaus,

It is only for TXT files that I would like to set a default
encoding.

Is there a way to do that?

Or, if I wish to have Word "guess", is there a way to have
it do that?

Thanks again,
--
Kenneth

If you email... Please remove the "SPAMLESS."


Hi Kenneth,

I'd like to take a step back, because I'm still not sure what you are trying to do.
The (recoded) macro you posted in the other thread contained "InsertFile".
I don't see how you can specify the encoding for "InsertFile", either.

Here, you're talking about "File Open", where you can specify the encoding.
But I'm not sure why you'd need to (either opening or inserting a text file).

As far as I understood, you're saving the text files yourself.
If you use "Plain text" (= Windows text) for saving the text file, you shouldn't need to specify any encoding when you re-open or insert the file.
And if the "Confirm conversions" dialog (in "File Open" or "Insert File") bothers you, you should be able to turn that off.

In this thread, you said that the "Confirm conversion" dialog comes up. Did you uncheck the option in "Tools General" and it still comes up? Then maybe that's the bug that might be solved by the hotfix from http://support.microsoft.com/kb/817140
(Can't say for sure because I've never run into this bug)

In the other thread, you said that some characters change into blanks if you re-open the text file.
Are you sure those characters *can* be saved in a Windows plain text file? Which characters are turned into blanks?

Regards,
Klaus


Hi Klaus,

My apologies for any confusion...

Let's start with the macro that I posted:

I recorded those two macros only so that I could see the
code that might do what I needed. Other than that, the
macros are of no significance.

So, let me describe again what it is that I am trying to do:

I have a TXT file. (It happens that the file is written by
my database, but, as with the issue of the macros, I believe
that to be of no relevance here.)

If I launch Word 2000 and try to open the TXT file (or if I
open a new DOC and attempt to insert the TXT file) a dialog
opens in Word that asks how I want the TXT file converted.

I want to prevent that from happening, that is, I would like
to set a default in Word, to open all TXT files with a
particular conversion rather than choosing each time.

Now, it happens that I want that not merely to avoid having
to make the selection. I have a Word macro that formats and
prints the TXT file in a certain way and when the macro
runs, the conversion dialog stops it. It would appear that
the problem could be solved either by having the default
that I described, or by inserting something in the macro
that would tell Word (in effect) Open the TXT file converted
as "Plain Text."

In addition, there might be other approaches, but either of
those above would give me what I need.

Sincere thanks once again,
--
Kenneth

If you email... Please remove the "SPAMLESS."
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
default font setting for Document Map sflworduser Microsoft Word Help 1 May 2nd 05 05:35 AM
*Permanent* Default Tab Setting Zigmund Microsoft Word Help 6 April 19th 05 08:20 AM
Default Font, etc. setting M_Kline Microsoft Word Help 1 March 23rd 05 03:39 PM
Default font - possible bulletproof fix in Word 2003 [email protected] Microsoft Word Help 0 January 14th 05 09:14 PM
change view track changes default setting Clarke Microsoft Word Help 1 December 9th 04 08:32 PM


All times are GMT +1. The time now is 02:12 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.