A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Page Layout
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Link to Previous vs Protected View



 
 
Thread Tools Display Modes
  #1  
Old January 23rd 18, 08:39 AM
Merridas Merridas is offline
Junior Member
 
First recorded activity by WordBanter: Jan 2018
Posts: 1
Default Link to Previous vs Protected View

I have written a macro that creates a new section with new page and in that page it goes to the header and turns off "Link to Previous" (by default is "on") option and makes changes to the header in the new section. Works perfectly.

However I have a specially formated table on first page that has to be filled by other but not changed in any way. I employed to protect it from formatting a Protected View. This also works perfectly.

The problem I have is that when I turn on "Protected View" the option "Link to Previous" turns grey (not clickable) which means my macro crashes.

Any thoughts how to solve my problem?
- maybe a way to change default "Link to Previous" to "off" or
- a way to enable "Link to previous" checking/unchecking while in "Protected View" or
- some other option.

Thanks in advance.
Ads
  #2  
Old February 5th 18, 03:30 PM
Charles K. Kenyon Charles K. Kenyon is offline
Junior Member
 
First recorded activity by WordBanter: Feb 2016
Posts: 12
Default

Quote:
Originally Posted by Merridas View Post
I have written a macro that creates a new section with new page and in that page it goes to the header and turns off "Link to Previous" (by default is "on") option and makes changes to the header in the new section. Works perfectly.

However I have a specially formated table on first page that has to be filled by other but not changed in any way. I employed to protect it from formatting a Protected View. This also works perfectly.

The problem I have is that when I turn on "Protected View" the option "Link to Previous" turns grey (not clickable) which means my macro crashes.

Any thoughts how to solve my problem?
- maybe a way to change default "Link to Previous" to "off" or
- a way to enable "Link to previous" checking/unchecking while in "Protected View" or
- some other option.

Thanks in advance.
You could, in your macro, turn off the protection, unlink, and then re-protect.

However, that may be overkill. I suspect that the StyleRef field may get you the result you want without adding a section break or changing the header/footer. http://www.addbalance.com/usersguide...s.htm#STYLEREF

You could, also, only protect the portion with your table and leave other parts unprotected.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Link to Previous Pwal Microsoft Word Help 2 January 23rd 10 10:09 AM
Link to Previous Pwal Microsoft Word Help 0 January 23rd 10 09:40 AM
heading won't link to previous Sharon Microsoft Word Help 1 March 12th 08 10:45 PM
link to previous disabled Lord of Gore Microsoft Word Help 1 January 22nd 07 09:43 PM
Link to previous - help Bob Microsoft Word Help 3 November 4th 05 01:19 AM


All times are GMT +1. The time now is 12:28 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.