A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Mailmerge
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Merge field displays 0



 
 
Thread Tools Display Modes
  #1  
Old November 13th 06, 09:15 PM posted to microsoft.public.word.mailmerge.fields
Serendipity
external usenet poster
 
Posts: 20
Default Merge field displays 0

Using Word 2003. Using Excel as my data source. In Excel the "Quantity" field
is formatted as "text" because it may have a value of 23 or 1 bag. When I do
the Word merge, the fields that have any alphabetic characters in them
display a 0. What is going on? Thanks for your help!
Marie
Ads
  #2  
Old November 14th 06, 05:03 AM posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
external usenet poster
 
Posts: 4,583
Default Merge field displays 0

The simplest workaround is to check Word Tools|Options|General|"Confirm
conversion at open", then go through the process of connecting to your data
source again and select the DDE option when it is eventually offered. Your
sheet will need to be the first in the workbook or the one previously opened
in Excel.

In essence, the problem results from the fact that the Jet OLEDB provider
that Word 2003 uses by default to get data from Excel tries to determine a
data type for each coloumn, looking at the first 25 rows in the column. If
the column has more than one data type, the provider is likely to use the
"majority" type - if it decides that's "numeric", text values will be set to
0.
  #3  
Old December 13th 12, 05:04 AM
TimJ TimJ is offline
Junior Member
 
First recorded activity by WordBanter: Dec 2012
Posts: 1
Default

Quote:
Originally Posted by Peter Jamieson View Post
The simplest workaround is to check Word Tools|Options|General|"Confirm
conversion at open", then go through the process of connecting to your data
source again and select the DDE option when it is eventually offered. Your
sheet will need to be the first in the workbook or the one previously opened
in Excel.

In essence, the problem results from the fact that the Jet OLEDB provider
that Word 2003 uses by default to get data from Excel tries to determine a
data type for each coloumn, looking at the first 25 rows in the column. If
the column has more than one data type, the provider is likely to use the
"majority" type - if it decides that's "numeric", text values will be set to
0.
Another reason why Word is an absolute dog of a program.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Merge letter requiring one or more different different mege letters depending on entry in fields rjr Microsoft Word Help 1 May 21st 06 05:16 PM
Suppressing Merge Field and text before/after julie Microsoft Word Help 8 November 14th 05 02:50 PM
How do I omit an empty date merge field? Phildeman Microsoft Word Help 5 June 13th 05 03:29 PM
Enhance merge to email feature of word with cc: merge field. Efficeint Word User Mailmerge 2 April 5th 05 05:05 AM
suppress invalid merge field word 2003 Mike Mailmerge 3 December 9th 04 11:13 AM


All times are GMT +1. The time now is 02:50 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.