A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Page Layout
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Bring custom toolbars with templates



 
 
Thread Tools Display Modes
  #1  
Old January 20th 05, 07:05 PM
art
external usenet poster
 
Posts: n/a
Default Bring custom toolbars with templates

I have created a couple of templates with styles that my group uses to
create documents. The templates have buttons that I use as shortcuts to
various style setting within the templates. When people open the template
the custom buttons for the template show up with all the other menu buttons
on their desktop, but .... for one person in my group they do not. Each time
this one person opens the template they have to go to templates and addins to
get the toolbar of buttons to show up and I can not get it to stick, if they
open another document at the same time the toolbar disappears and they have
to do it all over again. The styles are there but the buttons seem to appear
for a split second and disappear when they toggle between 2 opened documents.
I am out of ideas how to fix this. Any help would be appriciated
Ads
  #2  
Old January 20th 05, 08:40 PM
Charles Kenyon
external usenet poster
 
Posts: n/a
Default

The proper way to use a template is to create new documents based on the
template, not to open the template. I assume this is what you are talking
about.

If the toolbars and macros are in the template, and the template remains
attached to the document, they should be showing up, when the document is on
the screen. They should _not_ be showing up in documents that are not based
on the template unless the template is a global template. If it is a global
template, it should not be the attached template or used as the basis for
document creation.

When they go to templates and addins dialog, what do they do? Your template
should be the attached template, not an Add-in. Is it showing as the
attached template when you first see the dialog?

You can modify the formatting toolbar to include your buttons or a custom
style menu. Make sure that the changes are saved in your template, not in
normal.dot. My preference is to build a custom toolbar with the menu I want
and then copy the menu to the built-in template. The custom toolbar is then
hidden. If you do this, the settings should be about as firm as you can get.

To have a custom toolbar display, I simply put it in the template the way I
want it displayed. Some commercial Add-Ins mess with toolbars and this may
be your users problem. You can put in AutoNew and AutoOpen macros to force
display of your custom toolbar (and specify the location if you want). This
requires an environment in which macros in your template can run.
--

Charles Kenyon

Word New User FAQ & Web Directory: http://addbalance.com/word

Intermediate User's Guide to Microsoft Word (supplemented version of
Microsoft's Legal Users' Guide) http://addbalance.com/usersguide

See also the MVP FAQ: http://www.mvps.org/word which is awesome!
--------- --------- --------- --------- --------- ---------
This message is posted to a newsgroup. Please post replies
and questions to the newsgroup so that others can learn
from my ignorance and your wisdom.

"art" wrote in message
...
I have created a couple of templates with styles that my group uses to
create documents. The templates have buttons that I use as shortcuts to
various style setting within the templates. When people open the template
the custom buttons for the template show up with all the other menu
buttons
on their desktop, but .... for one person in my group they do not. Each
time
this one person opens the template they have to go to templates and addins
to
get the toolbar of buttons to show up and I can not get it to stick, if
they
open another document at the same time the toolbar disappears and they
have
to do it all over again. The styles are there but the buttons seem to
appear
for a split second and disappear when they toggle between 2 opened
documents.
I am out of ideas how to fix this. Any help would be appriciated



  #3  
Old January 21st 05, 05:35 PM
art
external usenet poster
 
Posts: n/a
Default

Thank you so much for replying so quickly. Your reply sparked something that
I wanted to try. I am not sure exactly how the template was originated but I
am pretty sure that it does affect normal.dot, so I tryed to copy in the
normal.dot from the template, but that didnt work. But then again there are
5 different templates with 5 different button styles. When I talked with
her, she has a fix that she uses that works, Seems that the buttons are
there but dont show up when the template is opened. When I toggle to a new
window to copy and paste back to the first window I see a flash and then the
buttons disappear. Her fix is to go to tools-- custom-- close. That action
forces the buttons the appear and re-appear. Weird, I am lost as far as what
else to try.

"Charles Kenyon" wrote:

The proper way to use a template is to create new documents based on the
template, not to open the template. I assume this is what you are talking
about.

If the toolbars and macros are in the template, and the template remains
attached to the document, they should be showing up, when the document is on
the screen. They should _not_ be showing up in documents that are not based
on the template unless the template is a global template. If it is a global
template, it should not be the attached template or used as the basis for
document creation.

When they go to templates and addins dialog, what do they do? Your template
should be the attached template, not an Add-in. Is it showing as the
attached template when you first see the dialog?

You can modify the formatting toolbar to include your buttons or a custom
style menu. Make sure that the changes are saved in your template, not in
normal.dot. My preference is to build a custom toolbar with the menu I want
and then copy the menu to the built-in template. The custom toolbar is then
hidden. If you do this, the settings should be about as firm as you can get.

To have a custom toolbar display, I simply put it in the template the way I
want it displayed. Some commercial Add-Ins mess with toolbars and this may
be your users problem. You can put in AutoNew and AutoOpen macros to force
display of your custom toolbar (and specify the location if you want). This
requires an environment in which macros in your template can run.
--

Charles Kenyon

Word New User FAQ & Web Directory: http://addbalance.com/word

Intermediate User's Guide to Microsoft Word (supplemented version of
Microsoft's Legal Users' Guide) http://addbalance.com/usersguide

See also the MVP FAQ: http://www.mvps.org/word which is awesome!
--------- --------- --------- --------- --------- ---------
This message is posted to a newsgroup. Please post replies
and questions to the newsgroup so that others can learn
from my ignorance and your wisdom.

"art" wrote in message
...
I have created a couple of templates with styles that my group uses to
create documents. The templates have buttons that I use as shortcuts to
various style setting within the templates. When people open the template
the custom buttons for the template show up with all the other menu
buttons
on their desktop, but .... for one person in my group they do not. Each
time
this one person opens the template they have to go to templates and addins
to
get the toolbar of buttons to show up and I can not get it to stick, if
they
open another document at the same time the toolbar disappears and they
have
to do it all over again. The styles are there but the buttons seem to
appear
for a split second and disappear when they toggle between 2 opened
documents.
I am out of ideas how to fix this. Any help would be appriciated




 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating Custom Word Templates Jeph Microsoft Word Help 5 February 7th 05 09:45 PM
custom templates usable by all users plannernyc Microsoft Word Help 5 January 20th 05 03:21 PM
Setting custom size problem Bob S Page Layout 0 December 24th 04 03:25 PM
Custom toolbars in Word 2000 - not saving to document or template? RS Lanigan Microsoft Word Help 4 December 10th 04 05:31 PM
Templates in too many languages. Only need English. capt_dalton Microsoft Word Help 0 December 2nd 04 10:29 PM


All times are GMT +1. The time now is 08:02 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2004-2021 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.