A Microsoft Word forum. Microsoft Office Word Forum - WordBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Microsoft Office Word Forum - WordBanter forum » Microsoft Word Newsgroups » Microsoft Word Help
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Stop Word from capitalizing new lines



 
 
Thread Tools Display Modes
  #1  
Old September 19th 06, 08:08 PM posted to microsoft.public.word.docmanagement
Todd Michaels
external usenet poster
 
Posts: 2
Default Stop Word from capitalizing new lines

The question:
- How do I stop Word from capitalizing the first letter of a new paragraph?
(XP, Office/Word 2003) Specifically, this happens on the very first line of a
new document and after hitting the Enter key and starting a new line (which I
understand Word interprets as a paragraph).

What I've tried:
- Tools Autocorrect Options. That worked for a while, but something was
always causing my settings to revert to a default setting.
- writing macros with lines such as:
With AutoCorrect
.CorrectInitialCaps = False
.CorrectSentenceCaps = False
End With
These macros are set to run automatically when I start a new document and
when I edit an existing document. This worked for quite some time but
recently stopped working. The autocorrect behavior is back.

What I've already seen--several times--when searching for an answer:
- "Ctrl+z after the autocorrection will reverse the capitalization"
Undoing the autocorrection that shouldn't have been performed is really a
workaround for a bug, not a solution.
- "Stop hitting enter at the end of a line; let Word automatically wrap to
the next line."
- "Stop using Word like a typewriter."
I find comments like these to be EXTREMELY unhelpful, and more than a little
condescending. It's really not up to anyone else to tell me how Word is
"supposed" to be used. What I need is a way to tell Word that "this is how I
like to work; these are the settings I want to use--always; I want you to
stop trying to be so helpful and guessing--incorrectly--what you think I want
you to do. If I typed a word with a lowercase first letter when I meant to
start with an uppercase first letter, I will deal with the repercussions of
my actions on my own."

So. Are there any other suggestions for settings I might examine, or ways I
can poke Word to make it behave the way I've told it to?
Ads
  #2  
Old September 19th 06, 08:44 PM posted to microsoft.public.word.docmanagement
Jay Freedman
external usenet poster
 
Posts: 9,855
Default Stop Word from capitalizing new lines

Setting the AutoCorrect options should work, but there are sometimes
problems that prevent the options from being saved. Of course, it would be
best to find out what's interfering in your system and fix that. You may get
some help from
http://www.word.mvps.org/FAQs/Custom...eySettings.htm and the link
in that article to
http://www.word.mvps.org/FAQs/AppErr...ngMenusEtc.htm. Read the whole
of both articles before doing anything in the registry.

If the options settings don't hold, the AutoNew and AutoOpen macros really
are the primary "nail it to the wall" method. The only thing I can think of
that would interfere with them is having the macro security level set to
High or Very High. That would prevent the macros from running at all. To
check on this, modify the macros to include a MsgBox statement at the
beginning. If the message box doesn't show up, the macro isn't being
executed. If this is the problem, you can use the selfcert.exe program to
make a digital certificate and sign the macro code (read the Help topics
"Create your own digital certificate" and "Digitally sign a file or macro
project").

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

Todd Michaels wrote:
The question:
- How do I stop Word from capitalizing the first letter of a new
paragraph? (XP, Office/Word 2003) Specifically, this happens on the
very first line of a new document and after hitting the Enter key and
starting a new line (which I understand Word interprets as a
paragraph).

What I've tried:
- Tools Autocorrect Options. That worked for a while, but something
was always causing my settings to revert to a default setting.
- writing macros with lines such as:
With AutoCorrect
.CorrectInitialCaps = False
.CorrectSentenceCaps = False
End With
These macros are set to run automatically when I start a new document
and when I edit an existing document. This worked for quite some time
but recently stopped working. The autocorrect behavior is back.

What I've already seen--several times--when searching for an answer:
- "Ctrl+z after the autocorrection will reverse the capitalization"
Undoing the autocorrection that shouldn't have been performed is
really a workaround for a bug, not a solution.
- "Stop hitting enter at the end of a line; let Word automatically
wrap to the next line."
- "Stop using Word like a typewriter."
I find comments like these to be EXTREMELY unhelpful, and more than a
little condescending. It's really not up to anyone else to tell me
how Word is "supposed" to be used. What I need is a way to tell Word
that "this is how I like to work; these are the settings I want to
use--always; I want you to stop trying to be so helpful and
guessing--incorrectly--what you think I want you to do. If I typed a
word with a lowercase first letter when I meant to start with an
uppercase first letter, I will deal with the repercussions of my
actions on my own."

So. Are there any other suggestions for settings I might examine, or
ways I can poke Word to make it behave the way I've told it to?



  #3  
Old September 20th 06, 11:29 AM posted to microsoft.public.word.docmanagement
Tony Jollans
external usenet poster
 
Posts: 1,308
Default Stop Word from capitalizing new lines

There are a couple of possible reasons I can think of::

1. Auto macros don't run against the blank document you get by default when
you just start Word.

2. AutCorrect is language-specific so setting the options will only affect
the language in effect at the time. Any change - perhaps by having
"automatically detect language" set - will change the set of AutoCorrect
settings in use.

--
Enjoy,
Tony

"Jay Freedman" wrote in message
...
Setting the AutoCorrect options should work, but there are sometimes
problems that prevent the options from being saved. Of course, it would be
best to find out what's interfering in your system and fix that. You may

get
some help from
http://www.word.mvps.org/FAQs/Custom...eySettings.htm and the

link
in that article to
http://www.word.mvps.org/FAQs/AppErr...ngMenusEtc.htm. Read the

whole
of both articles before doing anything in the registry.

If the options settings don't hold, the AutoNew and AutoOpen macros really
are the primary "nail it to the wall" method. The only thing I can think

of
that would interfere with them is having the macro security level set to
High or Very High. That would prevent the macros from running at all. To
check on this, modify the macros to include a MsgBox statement at the
beginning. If the message box doesn't show up, the macro isn't being
executed. If this is the problem, you can use the selfcert.exe program to
make a digital certificate and sign the macro code (read the Help topics
"Create your own digital certificate" and "Digitally sign a file or macro
project").

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup

so
all may benefit.

Todd Michaels wrote:
The question:
- How do I stop Word from capitalizing the first letter of a new
paragraph? (XP, Office/Word 2003) Specifically, this happens on the
very first line of a new document and after hitting the Enter key and
starting a new line (which I understand Word interprets as a
paragraph).

What I've tried:
- Tools Autocorrect Options. That worked for a while, but something
was always causing my settings to revert to a default setting.
- writing macros with lines such as:
With AutoCorrect
.CorrectInitialCaps = False
.CorrectSentenceCaps = False
End With
These macros are set to run automatically when I start a new document
and when I edit an existing document. This worked for quite some time
but recently stopped working. The autocorrect behavior is back.

What I've already seen--several times--when searching for an answer:
- "Ctrl+z after the autocorrection will reverse the capitalization"
Undoing the autocorrection that shouldn't have been performed is
really a workaround for a bug, not a solution.
- "Stop hitting enter at the end of a line; let Word automatically
wrap to the next line."
- "Stop using Word like a typewriter."
I find comments like these to be EXTREMELY unhelpful, and more than a
little condescending. It's really not up to anyone else to tell me
how Word is "supposed" to be used. What I need is a way to tell Word
that "this is how I like to work; these are the settings I want to
use--always; I want you to stop trying to be so helpful and
guessing--incorrectly--what you think I want you to do. If I typed a
word with a lowercase first letter when I meant to start with an
uppercase first letter, I will deal with the repercussions of my
actions on my own."

So. Are there any other suggestions for settings I might examine, or
ways I can poke Word to make it behave the way I've told it to?





  #4  
Old September 20th 06, 11:51 AM posted to microsoft.public.word.docmanagement
Tony Jollans
external usenet poster
 
Posts: 1,308
Default Stop Word from capitalizing new lines

Sorry - I wasn't thinking straight :-)

While it is true that AutoCorrections are language-specific, that affects
the explicit list of corrections and not the other options.

--
Enjoy,
Tony

"Tony Jollans" my forename at my surname dot com wrote in message
...
There are a couple of possible reasons I can think of::

1. Auto macros don't run against the blank document you get by default

when
you just start Word.

2. AutCorrect is language-specific so setting the options will only affect
the language in effect at the time. Any change - perhaps by having
"automatically detect language" set - will change the set of AutoCorrect
settings in use.

--
Enjoy,
Tony

"Jay Freedman" wrote in message
...
Setting the AutoCorrect options should work, but there are sometimes
problems that prevent the options from being saved. Of course, it would

be
best to find out what's interfering in your system and fix that. You may

get
some help from
http://www.word.mvps.org/FAQs/Custom...eySettings.htm and the

link
in that article to
http://www.word.mvps.org/FAQs/AppErr...ngMenusEtc.htm. Read the

whole
of both articles before doing anything in the registry.

If the options settings don't hold, the AutoNew and AutoOpen macros

really
are the primary "nail it to the wall" method. The only thing I can think

of
that would interfere with them is having the macro security level set to
High or Very High. That would prevent the macros from running at all. To
check on this, modify the macros to include a MsgBox statement at the
beginning. If the message box doesn't show up, the macro isn't being
executed. If this is the problem, you can use the selfcert.exe program

to
make a digital certificate and sign the macro code (read the Help topics
"Create your own digital certificate" and "Digitally sign a file or

macro
project").

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup
so
all may benefit.

Todd Michaels wrote:
The question:
- How do I stop Word from capitalizing the first letter of a new
paragraph? (XP, Office/Word 2003) Specifically, this happens on the
very first line of a new document and after hitting the Enter key and
starting a new line (which I understand Word interprets as a
paragraph).

What I've tried:
- Tools Autocorrect Options. That worked for a while, but something
was always causing my settings to revert to a default setting.
- writing macros with lines such as:
With AutoCorrect
.CorrectInitialCaps = False
.CorrectSentenceCaps = False
End With
These macros are set to run automatically when I start a new document
and when I edit an existing document. This worked for quite some time
but recently stopped working. The autocorrect behavior is back.

What I've already seen--several times--when searching for an answer:
- "Ctrl+z after the autocorrection will reverse the capitalization"
Undoing the autocorrection that shouldn't have been performed is
really a workaround for a bug, not a solution.
- "Stop hitting enter at the end of a line; let Word automatically
wrap to the next line."
- "Stop using Word like a typewriter."
I find comments like these to be EXTREMELY unhelpful, and more than a
little condescending. It's really not up to anyone else to tell me
how Word is "supposed" to be used. What I need is a way to tell Word
that "this is how I like to work; these are the settings I want to
use--always; I want you to stop trying to be so helpful and
guessing--incorrectly--what you think I want you to do. If I typed a
word with a lowercase first letter when I meant to start with an
uppercase first letter, I will deal with the repercussions of my
actions on my own."

So. Are there any other suggestions for settings I might examine, or
ways I can poke Word to make it behave the way I've told it to?







  #5  
Old September 23rd 06, 01:19 AM posted to microsoft.public.word.docmanagement
Todd Michaels
external usenet poster
 
Posts: 2
Default Stop Word from capitalizing new lines

I hadn't thought about Security, so I took a look at that a couple of days
ago. I reset my security to low and tried reopening Word. No joy.

I had MsgBox lines commented out from when I wrote the macros, so I
uncommented them. The macros were running, but not changing my settings back.

So today, a few days later, I tried looking at the issue again. The first
times I opened Word or a new document, the caps setting was still in effect.
Then for no apparent reason, the macros started sticking.

I have absolutely no idea why, but the macros are working again. I guess
we'll have to chalk this one up to "sometimes hitting your TV gets better
reception."

But thanks for your help, guys. I appreciate it.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why dont MS just f**king re-write Word from scratch? Its dogsh*t Word Hater Microsoft Word Help 32 November 4th 13 10:19 PM
How to put graphics on envelopes? Steve Koenig Microsoft Word Help 20 September 14th 07 04:40 PM
I am having difficulty with deleting headers and footers LHD New Users 5 July 24th 06 01:44 AM
Word & WordPerfect MrsMac Microsoft Word Help 5 June 10th 06 03:14 AM
hard space between words. Sandy L Microsoft Word Help 7 May 5th 06 08:25 PM


All times are GMT +1. The time now is 03:03 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2004-2014 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.