#1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Michael Koerner
 
Posts: n/a
Default How Come?

Using Office 2003 all patches. I run a mailmerge using Excel as the data
source, and was wondering why every time I open my merge document I receive
the following message:

Opening this document will run the following SQL command:
SELECT * FROM `NominalRoll$`
Data from your database will be placed in the document. Do you want to
continue?

When I select yes I still have to go looking for the NominalRoll.xls file
You would think that once you did an initial merge it would remember where
the file was located.

--

Regards
Michael Koerner



  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default How Come?

You've probably seen the following article befo...

http://support.microsoft.com/default...b;en-us;825765

While there may be some other workaround for this problem, I suggest you
e-mail and ask that they fix this, saying that from
your perspective,
a. all you are trying to do is use a simple data source
b. all that SQL command stuff is something Microsoft does internally and
perhaps if that is the way they insist on doing it, they could hide it from
you more effectively, not least because you never actually asked their
software to "run an SQL command"
c. could they please fix it so that you can do what you want without facing
the kind of barrage of questions you usually only face when asking about
software, trying to leave/enter the country, or at a supermarket checkout
(sorry, I'm rambling:-))

Peter Jamieson
"Michael Koerner" wrote in message
...
Using Office 2003 all patches. I run a mailmerge using Excel as the data
source, and was wondering why every time I open my merge document I
receive
the following message:

Opening this document will run the following SQL command:
SELECT * FROM `NominalRoll$`
Data from your database will be placed in the document. Do you want to
continue?

When I select yes I still have to go looking for the NominalRoll.xls file
You would think that once you did an initial merge it would remember where
the file was located.

--

Regards
Michael Koerner





  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Michael Koerner
 
Posts: n/a
Default How Come?

Peter;

Thanks very much. Now how do I make it stop asking me for the Excel file
after I have once ran the merge and saved all the files?

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| You've probably seen the following article befo...
|
| http://support.microsoft.com/default...b;en-us;825765
|
| While there may be some other workaround for this problem, I suggest you
| e-mail and ask that they fix this, saying that from
| your perspective,
| a. all you are trying to do is use a simple data source
| b. all that SQL command stuff is something Microsoft does internally and
| perhaps if that is the way they insist on doing it, they could hide it
from
| you more effectively, not least because you never actually asked their
| software to "run an SQL command"
| c. could they please fix it so that you can do what you want without
facing
| the kind of barrage of questions you usually only face when asking about
| software, trying to leave/enter the country, or at a supermarket checkout
| (sorry, I'm rambling:-))
|
| Peter Jamieson
| "Michael Koerner" wrote in message
| ...
| Using Office 2003 all patches. I run a mailmerge using Excel as the data
| source, and was wondering why every time I open my merge document I
| receive
| the following message:
|
| Opening this document will run the following SQL command:
| SELECT * FROM `NominalRoll$`
| Data from your database will be placed in the document. Do you want
to
| continue?
|
| When I select yes I still have to go looking for the NominalRoll.xls
file
| You would think that once you did an initial merge it would remember
where
| the file was located.
|
| --
|
| Regards
| Michael Koerner
|
|
|
|
|



  #4   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default How Come?

Here, once I have made the change to the registry in the article I referred
to, I don't see the question again. If I don't make the change, I always see
the question.

I'm not sure exactly what you are doing but in an attempt to replicate "ran
the merge and save all the files" I ran a merge, outputting to a new
document, saved and closed the new document and the mail merge main
document, then re-opened the mail merge main document. No questions,
connection was fine. This is Word 2003, also up to date as far as I know.
What's happening with your copy of Word?

Peter Jamieson

"Michael Koerner" wrote in message
...
Peter;

Thanks very much. Now how do I make it stop asking me for the Excel file
after I have once ran the merge and saved all the files?

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| You've probably seen the following article befo...
|
| http://support.microsoft.com/default...b;en-us;825765
|
| While there may be some other workaround for this problem, I suggest you
| e-mail and ask that they fix this, saying that from
| your perspective,
| a. all you are trying to do is use a simple data source
| b. all that SQL command stuff is something Microsoft does internally and
| perhaps if that is the way they insist on doing it, they could hide it
from
| you more effectively, not least because you never actually asked their
| software to "run an SQL command"
| c. could they please fix it so that you can do what you want without
facing
| the kind of barrage of questions you usually only face when asking about
| software, trying to leave/enter the country, or at a supermarket
checkout
| (sorry, I'm rambling:-))
|
| Peter Jamieson
| "Michael Koerner" wrote in message
| ...
| Using Office 2003 all patches. I run a mailmerge using Excel as the
data
| source, and was wondering why every time I open my merge document I
| receive
| the following message:
|
| Opening this document will run the following SQL command:
| SELECT * FROM `NominalRoll$`
| Data from your database will be placed in the document. Do you
want
to
| continue?
|
| When I select yes I still have to go looking for the NominalRoll.xls
file
| You would think that once you did an initial merge it would remember
where
| the file was located.
|
| --
|
| Regards
| Michael Koerner
|
|
|
|
|





  #5   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Michael Koerner
 
Posts: n/a
Default How Come?

After changing the registry, I no longer see the question true. But, I still
have to navigate to the data source and select it before the
document/template whatever opens

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| Here, once I have made the change to the registry in the article I
referred
| to, I don't see the question again. If I don't make the change, I always
see
| the question.
|
| I'm not sure exactly what you are doing but in an attempt to replicate
"ran
| the merge and save all the files" I ran a merge, outputting to a new
| document, saved and closed the new document and the mail merge main
| document, then re-opened the mail merge main document. No questions,
| connection was fine. This is Word 2003, also up to date as far as I know.
| What's happening with your copy of Word?
|
| Peter Jamieson
|
| "Michael Koerner" wrote in message
| ...
| Peter;
|
| Thanks very much. Now how do I make it stop asking me for the Excel file
| after I have once ran the merge and saved all the files?
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | You've probably seen the following article befo...
| |
| | http://support.microsoft.com/default...b;en-us;825765
| |
| | While there may be some other workaround for this problem, I suggest
you
| | e-mail and ask that they fix this, saying that
from
| | your perspective,
| | a. all you are trying to do is use a simple data source
| | b. all that SQL command stuff is something Microsoft does internally
and
| | perhaps if that is the way they insist on doing it, they could hide it
| from
| | you more effectively, not least because you never actually asked their
| | software to "run an SQL command"
| | c. could they please fix it so that you can do what you want without
| facing
| | the kind of barrage of questions you usually only face when asking
about
| | software, trying to leave/enter the country, or at a supermarket
| checkout
| | (sorry, I'm rambling:-))
| |
| | Peter Jamieson
| | "Michael Koerner" wrote in message
| | ...
| | Using Office 2003 all patches. I run a mailmerge using Excel as the
| data
| | source, and was wondering why every time I open my merge document I
| | receive
| | the following message:
| |
| | Opening this document will run the following SQL command:
| | SELECT * FROM `NominalRoll$`
| | Data from your database will be placed in the document. Do you
| want
| to
| | continue?
| |
| | When I select yes I still have to go looking for the NominalRoll.xls
| file
| | You would think that once you did an initial merge it would remember
| where
| | the file was located.
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| |
| |
| |
|
|
|
|
|




  #6   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default How Come?

document/template whatever opens

1. Are you creating your mail merges from a template that's attached to the
data source?

if so, that could be the source of the problem, since Word seems to keep the
template's connection open (it didn't used to) and sometimes the connection
is excusive. I haven't checked in this particular case, but maybe you could
have a look, and if that's what you're doing, either disconnect the template
from the data source or create a new template that's not connected to a data
source and try that.

2. Are you applying any sorts, filters or selections to the Data Source (via
"Mail Merge Recipients") before closing your document?

I'm about to sign off for today...

Peter Jamieson
"Michael Koerner" wrote in message
...
After changing the registry, I no longer see the question true. But, I
still
have to navigate to the data source and select it before the
document/template whatever opens

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| Here, once I have made the change to the registry in the article I
referred
| to, I don't see the question again. If I don't make the change, I always
see
| the question.
|
| I'm not sure exactly what you are doing but in an attempt to replicate
"ran
| the merge and save all the files" I ran a merge, outputting to a new
| document, saved and closed the new document and the mail merge main
| document, then re-opened the mail merge main document. No questions,
| connection was fine. This is Word 2003, also up to date as far as I
know.
| What's happening with your copy of Word?
|
| Peter Jamieson
|
| "Michael Koerner" wrote in message
| ...
| Peter;
|
| Thanks very much. Now how do I make it stop asking me for the Excel
file
| after I have once ran the merge and saved all the files?
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | You've probably seen the following article befo...
| |
| | http://support.microsoft.com/default...b;en-us;825765
| |
| | While there may be some other workaround for this problem, I suggest
you
| | e-mail and ask that they fix this, saying that
from
| | your perspective,
| | a. all you are trying to do is use a simple data source
| | b. all that SQL command stuff is something Microsoft does internally
and
| | perhaps if that is the way they insist on doing it, they could hide
it
| from
| | you more effectively, not least because you never actually asked
their
| | software to "run an SQL command"
| | c. could they please fix it so that you can do what you want without
| facing
| | the kind of barrage of questions you usually only face when asking
about
| | software, trying to leave/enter the country, or at a supermarket
| checkout
| | (sorry, I'm rambling:-))
| |
| | Peter Jamieson
| | "Michael Koerner" wrote in message
| | ...
| | Using Office 2003 all patches. I run a mailmerge using Excel as
the
| data
| | source, and was wondering why every time I open my merge document
I
| | receive
| | the following message:
| |
| | Opening this document will run the following SQL command:
| | SELECT * FROM `NominalRoll$`
| | Data from your database will be placed in the document. Do you
| want
| to
| | continue?
| |
| | When I select yes I still have to go looking for the
NominalRoll.xls
| file
| | You would think that once you did an initial merge it would
remember
| where
| | the file was located.
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| |
| |
| |
|
|
|
|
|




  #7   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Michael Koerner
 
Posts: n/a
Default How Come?

1. Are you creating your mail merges from a template that's attached to the
data source?

I'm not sure (don't know). After clicking on the .XLS file and the template
opens I have the option to "Merge to new document" which is what I usually
do to create the finished file.


if so, that could be the source of the problem, since Word seems to keep the
template's connection open (it didn't used to) and sometimes the connection
is excusive. I haven't checked in this particular case, but maybe you could
have a look, and if that's what you're doing, either disconnect the template
from the data source or create a new template that's not connected to a data
source and try that.

How does one go about disconnecting a template from the data source? I
believe if the template were attached to the data source, I would not have
to select it each time I open the template to run the merge.


2. Are you applying any sorts, filters or selections to the Data Source (via
"Mail Merge Recipients") before closing your document?

No.


--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| document/template whatever opens
|
| 1. Are you creating your mail merges from a template that's attached to
the
| data source?
|
| if so, that could be the source of the problem, since Word seems to keep
the
| template's connection open (it didn't used to) and sometimes the
connection
| is excusive. I haven't checked in this particular case, but maybe you
could
| have a look, and if that's what you're doing, either disconnect the
template
| from the data source or create a new template that's not connected to a
data
| source and try that.
|
| 2. Are you applying any sorts, filters or selections to the Data Source
(via
| "Mail Merge Recipients") before closing your document?
|
| I'm about to sign off for today...
|
| Peter Jamieson
| "Michael Koerner" wrote in message
| ...
| After changing the registry, I no longer see the question true. But, I
| still
| have to navigate to the data source and select it before the
| document/template whatever opens
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | Here, once I have made the change to the registry in the article I
| referred
| | to, I don't see the question again. If I don't make the change, I
always
| see
| | the question.
| |
| | I'm not sure exactly what you are doing but in an attempt to replicate
| "ran
| | the merge and save all the files" I ran a merge, outputting to a new
| | document, saved and closed the new document and the mail merge main
| | document, then re-opened the mail merge main document. No questions,
| | connection was fine. This is Word 2003, also up to date as far as I
| know.
| | What's happening with your copy of Word?
| |
| | Peter Jamieson
| |
| | "Michael Koerner" wrote in message
| | ...
| | Peter;
| |
| | Thanks very much. Now how do I make it stop asking me for the Excel
| file
| | after I have once ran the merge and saved all the files?
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| | "Peter Jamieson" wrote in message
| | ...
| | | You've probably seen the following article befo...
| | |
| | | http://support.microsoft.com/default...b;en-us;825765
| | |
| | | While there may be some other workaround for this problem, I
suggest
| you
| | | e-mail and ask that they fix this, saying
that
| from
| | | your perspective,
| | | a. all you are trying to do is use a simple data source
| | | b. all that SQL command stuff is something Microsoft does
internally
| and
| | | perhaps if that is the way they insist on doing it, they could
hide
| it
| | from
| | | you more effectively, not least because you never actually asked
| their
| | | software to "run an SQL command"
| | | c. could they please fix it so that you can do what you want
without
| | facing
| | | the kind of barrage of questions you usually only face when asking
| about
| | | software, trying to leave/enter the country, or at a supermarket
| | checkout
| | | (sorry, I'm rambling:-))
| | |
| | | Peter Jamieson
| | | "Michael Koerner" wrote in message
| | | ...
| | | Using Office 2003 all patches. I run a mailmerge using Excel as
| the
| | data
| | | source, and was wondering why every time I open my merge
document
| I
| | | receive
| | | the following message:
| | |
| | | Opening this document will run the following SQL command:
| | | SELECT * FROM `NominalRoll$`
| | | Data from your database will be placed in the document. Do
you
| | want
| | to
| | | continue?
| | |
| | | When I select yes I still have to go looking for the
| NominalRoll.xls
| | file
| | | You would think that once you did an initial merge it would
| remember
| | where
| | | the file was located.
| | |
| | | --
| | |
| | | Regards
| | | Michael Koerner
| | |
| | |
| | |
| | |
| | |
| |
| |
| |
| |
| |
|
|
|
|


  #8   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default How Come?

I'm not sure (don't know). After clicking on the .XLS file and the
template
opens I have the option to "Merge to new document" which is what I usually
do to create the finished file.


My question has really to do with how you are creating your Word documents
in the first place. "Template" has a specific meaning in Word. When you
create a new document it's always based on a Word template (i.e. .dot file).
If you are not aware of using .dot files then the chances are that you are
always using the standard template, normal.dot. If you always start with the
blank document icon at the left hand end of the standard toolbar then your
document will be attached to the standard template, normal.dot. If you
always start by copying an existing document then the new document will
(probably) be attached to whatever template the old document was attached
to. You can find out which template a document is attached to by opening the
document and looking at Tools|Templates and Addins...|Templates|Document
Template.

By default, normal.dot is /not/ attached to a data source. It's possible
that at some point you may have attached it to a data source but I suspect
you would know about it if you had. Ditto for any other use of templates.

So that's probably not the explanation in this case. But it's still worth
checking.

Does anything else (e.g. Excel) have the data source open when you open your
Word document?

How does one go about disconnecting a template from the data source? I
believe if the template were attached to the data source, I would not have
to select it each time I open the template to run the merge.


You would have to find the template, open it, then e.g. use the first icon
on the mail merge toolbar to set the thing back to being Normal Word
Document (even though it isn't, it's a template), then save and close it.
You will probably find your templates in a folder with the following name:

C:\Documents and Settings\username\Application Data\Microsoft\Templates

where username is your Windows login name.

I
believe if the template were attached to the data source, I would not have
to select it each time I open the template to run the merge.


That's how it should work, and how it used to work using Word 2000 I think.
But now the fact that the template has the data source open sometimes means
that the a document attached to the template cannot also open it.

It's possible that you use the word template in the way many people do, i.e.
a document (.doc) that you copy and use as the basis of a new document. In
that case, you certainly should be able to open the data source in the way
that you suggest, unless something else also has the data source open.

Peter Jamieson

"Michael Koerner" wrote in message
...
1. Are you creating your mail merges from a template that's attached to
the
data source?

I'm not sure (don't know). After clicking on the .XLS file and the
template
opens I have the option to "Merge to new document" which is what I usually
do to create the finished file.


if so, that could be the source of the problem, since Word seems to keep
the
template's connection open (it didn't used to) and sometimes the
connection
is excusive. I haven't checked in this particular case, but maybe you
could
have a look, and if that's what you're doing, either disconnect the
template
from the data source or create a new template that's not connected to a
data
source and try that.

How does one go about disconnecting a template from the data source? I
believe if the template were attached to the data source, I would not have
to select it each time I open the template to run the merge.


2. Are you applying any sorts, filters or selections to the Data Source
(via
"Mail Merge Recipients") before closing your document?

No.


--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| document/template whatever opens
|
| 1. Are you creating your mail merges from a template that's attached to
the
| data source?
|
| if so, that could be the source of the problem, since Word seems to keep
the
| template's connection open (it didn't used to) and sometimes the
connection
| is excusive. I haven't checked in this particular case, but maybe you
could
| have a look, and if that's what you're doing, either disconnect the
template
| from the data source or create a new template that's not connected to a
data
| source and try that.
|
| 2. Are you applying any sorts, filters or selections to the Data Source
(via
| "Mail Merge Recipients") before closing your document?
|
| I'm about to sign off for today...
|
| Peter Jamieson
| "Michael Koerner" wrote in message
| ...
| After changing the registry, I no longer see the question true. But, I
| still
| have to navigate to the data source and select it before the
| document/template whatever opens
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | Here, once I have made the change to the registry in the article I
| referred
| | to, I don't see the question again. If I don't make the change, I
always
| see
| | the question.
| |
| | I'm not sure exactly what you are doing but in an attempt to
replicate
| "ran
| | the merge and save all the files" I ran a merge, outputting to a new
| | document, saved and closed the new document and the mail merge main
| | document, then re-opened the mail merge main document. No questions,
| | connection was fine. This is Word 2003, also up to date as far as I
| know.
| | What's happening with your copy of Word?
| |
| | Peter Jamieson
| |
| | "Michael Koerner" wrote in message
| | ...
| | Peter;
| |
| | Thanks very much. Now how do I make it stop asking me for the
Excel
| file
| | after I have once ran the merge and saved all the files?
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| | "Peter Jamieson" wrote in message
| | ...
| | | You've probably seen the following article befo...
| | |
| | | http://support.microsoft.com/default...b;en-us;825765
| | |
| | | While there may be some other workaround for this problem, I
suggest
| you
| | | e-mail and ask that they fix this, saying
that
| from
| | | your perspective,
| | | a. all you are trying to do is use a simple data source
| | | b. all that SQL command stuff is something Microsoft does
internally
| and
| | | perhaps if that is the way they insist on doing it, they could
hide
| it
| | from
| | | you more effectively, not least because you never actually asked
| their
| | | software to "run an SQL command"
| | | c. could they please fix it so that you can do what you want
without
| | facing
| | | the kind of barrage of questions you usually only face when
asking
| about
| | | software, trying to leave/enter the country, or at a supermarket
| | checkout
| | | (sorry, I'm rambling:-))
| | |
| | | Peter Jamieson
| | | "Michael Koerner" wrote in message
| | | ...
| | | Using Office 2003 all patches. I run a mailmerge using Excel
as
| the
| | data
| | | source, and was wondering why every time I open my merge
document
| I
| | | receive
| | | the following message:
| | |
| | | Opening this document will run the following SQL command:
| | | SELECT * FROM `NominalRoll$`
| | | Data from your database will be placed in the document. Do
you
| | want
| | to
| | | continue?
| | |
| | | When I select yes I still have to go looking for the
| NominalRoll.xls
| | file
| | | You would think that once you did an initial merge it would
| remember
| | where
| | | the file was located.
| | |
| | | --
| | |
| | | Regards
| | | Michael Koerner
| | |
| | |
| | |
| | |
| | |
| |
| |
| |
| |
| |
|
|
|
|




  #9   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Michael Koerner
 
Posts: n/a
Default How Come?

I'm sorry, I knew that. It is not a .dot file. it is just a .doc file that
has all the merge information in it and when it opens up, the mailmerge
toolbar give me the option to complete the merge.

I think the problem may have evolved through different versions of Word and
Excel I started this thing I think when I was using Office 97, and just kept
opening the appropriate files with each new version of Office that came
along. I did something this morning (don't know what) which forced Word to
look for a new data source. When I selected the .XLS file, then saved the
document. I closed the document shut down Word reopened Word, the document,
it opened without asking for the data source. Have done a number of warm,
cold boots (paranoia that it might revert back to the old display) and tried
the merge with great success. Thanks again for all you help

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| I'm not sure (don't know). After clicking on the .XLS file and the
| template
| opens I have the option to "Merge to new document" which is what I
usually
| do to create the finished file.
|
| My question has really to do with how you are creating your Word documents
| in the first place. "Template" has a specific meaning in Word. When you
| create a new document it's always based on a Word template (i.e. .dot
file).
| If you are not aware of using .dot files then the chances are that you are
| always using the standard template, normal.dot. If you always start with
the
| blank document icon at the left hand end of the standard toolbar then your
| document will be attached to the standard template, normal.dot. If you
| always start by copying an existing document then the new document will
| (probably) be attached to whatever template the old document was attached
| to. You can find out which template a document is attached to by opening
the
| document and looking at Tools|Templates and Addins...|Templates|Document
| Template.
|
| By default, normal.dot is /not/ attached to a data source. It's possible
| that at some point you may have attached it to a data source but I suspect
| you would know about it if you had. Ditto for any other use of templates.
|
| So that's probably not the explanation in this case. But it's still worth
| checking.
|
| Does anything else (e.g. Excel) have the data source open when you open
your
| Word document?
|
| How does one go about disconnecting a template from the data source? I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
| You would have to find the template, open it, then e.g. use the first icon
| on the mail merge toolbar to set the thing back to being Normal Word
| Document (even though it isn't, it's a template), then save and close it.
| You will probably find your templates in a folder with the following name:
|
| C:\Documents and Settings\username\Application Data\Microsoft\Templates
|
| where username is your Windows login name.
|
| I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
| That's how it should work, and how it used to work using Word 2000 I
think.
| But now the fact that the template has the data source open sometimes
means
| that the a document attached to the template cannot also open it.
|
| It's possible that you use the word template in the way many people do,
i.e.
| a document (.doc) that you copy and use as the basis of a new document. In
| that case, you certainly should be able to open the data source in the way
| that you suggest, unless something else also has the data source open.
|
| Peter Jamieson
|
| "Michael Koerner" wrote in message
| ...
| 1. Are you creating your mail merges from a template that's attached to
| the
| data source?
|
| I'm not sure (don't know). After clicking on the .XLS file and the
| template
| opens I have the option to "Merge to new document" which is what I
usually
| do to create the finished file.
|
|
| if so, that could be the source of the problem, since Word seems to keep
| the
| template's connection open (it didn't used to) and sometimes the
| connection
| is excusive. I haven't checked in this particular case, but maybe you
| could
| have a look, and if that's what you're doing, either disconnect the
| template
| from the data source or create a new template that's not connected to a
| data
| source and try that.
|
| How does one go about disconnecting a template from the data source? I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
|
| 2. Are you applying any sorts, filters or selections to the Data Source
| (via
| "Mail Merge Recipients") before closing your document?
|
| No.
|
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | document/template whatever opens
| |
| | 1. Are you creating your mail merges from a template that's attached
to
| the
| | data source?
| |
| | if so, that could be the source of the problem, since Word seems to
keep
| the
| | template's connection open (it didn't used to) and sometimes the
| connection
| | is excusive. I haven't checked in this particular case, but maybe you
| could
| | have a look, and if that's what you're doing, either disconnect the
| template
| | from the data source or create a new template that's not connected to
a
| data
| | source and try that.
| |
| | 2. Are you applying any sorts, filters or selections to the Data
Source
| (via
| | "Mail Merge Recipients") before closing your document?
| |
| | I'm about to sign off for today...
| |
| | Peter Jamieson
| | "Michael Koerner" wrote in message
| | ...
| | After changing the registry, I no longer see the question true. But,
I
| | still
| | have to navigate to the data source and select it before the
| | document/template whatever opens
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| | "Peter Jamieson" wrote in message
| | ...
| | | Here, once I have made the change to the registry in the article I
| | referred
| | | to, I don't see the question again. If I don't make the change, I
| always
| | see
| | | the question.
| | |
| | | I'm not sure exactly what you are doing but in an attempt to
| replicate
| | "ran
| | | the merge and save all the files" I ran a merge, outputting to a
new
| | | document, saved and closed the new document and the mail merge
main
| | | document, then re-opened the mail merge main document. No
questions,
| | | connection was fine. This is Word 2003, also up to date as far as
I
| | know.
| | | What's happening with your copy of Word?
| | |
| | | Peter Jamieson
| | |
| | | "Michael Koerner" wrote in message
| | | ...
| | | Peter;
| | |
| | | Thanks very much. Now how do I make it stop asking me for the
| Excel
| | file
| | | after I have once ran the merge and saved all the files?
| | |
| | | --
| | |
| | | Regards
| | | Michael Koerner
| | |
| | |
| | | "Peter Jamieson" wrote in
message
| | | ...
| | | | You've probably seen the following article befo...
| | | |
| | | | http://support.microsoft.com/default...b;en-us;825765
| | | |
| | | | While there may be some other workaround for this problem, I
| suggest
| | you
| | | | e-mail and ask that they fix this, saying
| that
| | from
| | | | your perspective,
| | | | a. all you are trying to do is use a simple data source
| | | | b. all that SQL command stuff is something Microsoft does
| internally
| | and
| | | | perhaps if that is the way they insist on doing it, they could
| hide
| | it
| | | from
| | | | you more effectively, not least because you never actually
asked
| | their
| | | | software to "run an SQL command"
| | | | c. could they please fix it so that you can do what you want
| without
| | | facing
| | | | the kind of barrage of questions you usually only face when
| asking
| | about
| | | | software, trying to leave/enter the country, or at a
supermarket
| | | checkout
| | | | (sorry, I'm rambling:-))
| | | |
| | | | Peter Jamieson
| | | | "Michael Koerner" wrote in message
| | | | ...
| | | | Using Office 2003 all patches. I run a mailmerge using Excel
| as
| | the
| | | data
| | | | source, and was wondering why every time I open my merge
| document
| | I
| | | | receive
| | | | the following message:
| | | |
| | | | Opening this document will run the following SQL
command:
| | | | SELECT * FROM `NominalRoll$`
| | | | Data from your database will be placed in the document.
Do
| you
| | | want
| | | to
| | | | continue?
| | | |
| | | | When I select yes I still have to go looking for the
| | NominalRoll.xls
| | | file
| | | | You would think that once you did an initial merge it would
| | remember
| | | where
| | | | the file was located.
| | | |
| | | | --
| | | |
| | | | Regards
| | | | Michael Koerner
| | | |
| | | |
| | | |
| | | |
| | | |
| | |
| | |
| | |
| | |
| | |
| |
| |
| |
| |
|
|
|
|


  #10   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default How Come?

Glad it's solved anyway!

Peter Jamieson
"Michael Koerner" wrote in message
...
I'm sorry, I knew that. It is not a .dot file. it is just a .doc file that
has all the merge information in it and when it opens up, the mailmerge
toolbar give me the option to complete the merge.

I think the problem may have evolved through different versions of Word
and
Excel I started this thing I think when I was using Office 97, and just
kept
opening the appropriate files with each new version of Office that came
along. I did something this morning (don't know what) which forced Word to
look for a new data source. When I selected the .XLS file, then saved the
document. I closed the document shut down Word reopened Word, the
document,
it opened without asking for the data source. Have done a number of warm,
cold boots (paranoia that it might revert back to the old display) and
tried
the merge with great success. Thanks again for all you help

--

Regards
Michael Koerner


"Peter Jamieson" wrote in message
...
| I'm not sure (don't know). After clicking on the .XLS file and the
| template
| opens I have the option to "Merge to new document" which is what I
usually
| do to create the finished file.
|
| My question has really to do with how you are creating your Word
documents
| in the first place. "Template" has a specific meaning in Word. When you
| create a new document it's always based on a Word template (i.e. .dot
file).
| If you are not aware of using .dot files then the chances are that you
are
| always using the standard template, normal.dot. If you always start with
the
| blank document icon at the left hand end of the standard toolbar then
your
| document will be attached to the standard template, normal.dot. If you
| always start by copying an existing document then the new document will
| (probably) be attached to whatever template the old document was
attached
| to. You can find out which template a document is attached to by opening
the
| document and looking at Tools|Templates and Addins...|Templates|Document
| Template.
|
| By default, normal.dot is /not/ attached to a data source. It's possible
| that at some point you may have attached it to a data source but I
suspect
| you would know about it if you had. Ditto for any other use of
templates.
|
| So that's probably not the explanation in this case. But it's still
worth
| checking.
|
| Does anything else (e.g. Excel) have the data source open when you open
your
| Word document?
|
| How does one go about disconnecting a template from the data source? I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
| You would have to find the template, open it, then e.g. use the first
icon
| on the mail merge toolbar to set the thing back to being Normal Word
| Document (even though it isn't, it's a template), then save and close
it.
| You will probably find your templates in a folder with the following
name:
|
| C:\Documents and Settings\username\Application
Data\Microsoft\Templates
|
| where username is your Windows login name.
|
| I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
| That's how it should work, and how it used to work using Word 2000 I
think.
| But now the fact that the template has the data source open sometimes
means
| that the a document attached to the template cannot also open it.
|
| It's possible that you use the word template in the way many people do,
i.e.
| a document (.doc) that you copy and use as the basis of a new document.
In
| that case, you certainly should be able to open the data source in the
way
| that you suggest, unless something else also has the data source open.
|
| Peter Jamieson
|
| "Michael Koerner" wrote in message
| ...
| 1. Are you creating your mail merges from a template that's attached
to
| the
| data source?
|
| I'm not sure (don't know). After clicking on the .XLS file and the
| template
| opens I have the option to "Merge to new document" which is what I
usually
| do to create the finished file.
|
|
| if so, that could be the source of the problem, since Word seems to
keep
| the
| template's connection open (it didn't used to) and sometimes the
| connection
| is excusive. I haven't checked in this particular case, but maybe you
| could
| have a look, and if that's what you're doing, either disconnect the
| template
| from the data source or create a new template that's not connected to
a
| data
| source and try that.
|
| How does one go about disconnecting a template from the data source? I
| believe if the template were attached to the data source, I would not
have
| to select it each time I open the template to run the merge.
|
|
| 2. Are you applying any sorts, filters or selections to the Data
Source
| (via
| "Mail Merge Recipients") before closing your document?
|
| No.
|
|
| --
|
| Regards
| Michael Koerner
|
|
| "Peter Jamieson" wrote in message
| ...
| | document/template whatever opens
| |
| | 1. Are you creating your mail merges from a template that's attached
to
| the
| | data source?
| |
| | if so, that could be the source of the problem, since Word seems to
keep
| the
| | template's connection open (it didn't used to) and sometimes the
| connection
| | is excusive. I haven't checked in this particular case, but maybe
you
| could
| | have a look, and if that's what you're doing, either disconnect the
| template
| | from the data source or create a new template that's not connected
to
a
| data
| | source and try that.
| |
| | 2. Are you applying any sorts, filters or selections to the Data
Source
| (via
| | "Mail Merge Recipients") before closing your document?
| |
| | I'm about to sign off for today...
| |
| | Peter Jamieson
| | "Michael Koerner" wrote in message
| | ...
| | After changing the registry, I no longer see the question true.
But,
I
| | still
| | have to navigate to the data source and select it before the
| | document/template whatever opens
| |
| | --
| |
| | Regards
| | Michael Koerner
| |
| |
| | "Peter Jamieson" wrote in message
| | ...
| | | Here, once I have made the change to the registry in the article
I
| | referred
| | | to, I don't see the question again. If I don't make the change,
I
| always
| | see
| | | the question.
| | |
| | | I'm not sure exactly what you are doing but in an attempt to
| replicate
| | "ran
| | | the merge and save all the files" I ran a merge, outputting to a
new
| | | document, saved and closed the new document and the mail merge
main
| | | document, then re-opened the mail merge main document. No
questions,
| | | connection was fine. This is Word 2003, also up to date as far
as
I
| | know.
| | | What's happening with your copy of Word?
| | |
| | | Peter Jamieson
| | |
| | | "Michael Koerner" wrote in message
| | | ...
| | | Peter;
| | |
| | | Thanks very much. Now how do I make it stop asking me for the
| Excel
| | file
| | | after I have once ran the merge and saved all the files?
| | |
| | | --
| | |
| | | Regards
| | | Michael Koerner
| | |
| | |
| | | "Peter Jamieson" wrote in
message
| | | ...
| | | | You've probably seen the following article befo...
| | | |
| | | |
http://support.microsoft.com/default...b;en-us;825765
| | | |
| | | | While there may be some other workaround for this problem, I
| suggest
| | you
| | | | e-mail and ask that they fix this,
saying
| that
| | from
| | | | your perspective,
| | | | a. all you are trying to do is use a simple data source
| | | | b. all that SQL command stuff is something Microsoft does
| internally
| | and
| | | | perhaps if that is the way they insist on doing it, they
could
| hide
| | it
| | | from
| | | | you more effectively, not least because you never actually
asked
| | their
| | | | software to "run an SQL command"
| | | | c. could they please fix it so that you can do what you want
| without
| | | facing
| | | | the kind of barrage of questions you usually only face when
| asking
| | about
| | | | software, trying to leave/enter the country, or at a
supermarket
| | | checkout
| | | | (sorry, I'm rambling:-))
| | | |
| | | | Peter Jamieson
| | | | "Michael Koerner" wrote in message
| | | | ...
| | | | Using Office 2003 all patches. I run a mailmerge using
Excel
| as
| | the
| | | data
| | | | source, and was wondering why every time I open my merge
| document
| | I
| | | | receive
| | | | the following message:
| | | |
| | | | Opening this document will run the following SQL
command:
| | | | SELECT * FROM `NominalRoll$`
| | | | Data from your database will be placed in the
document.
Do
| you
| | | want
| | | to
| | | | continue?
| | | |
| | | | When I select yes I still have to go looking for the
| | NominalRoll.xls
| | | file
| | | | You would think that once you did an initial merge it
would
| | remember
| | | where
| | | | the file was located.
| | | |
| | | | --
| | | |
| | | | Regards
| | | | Michael Koerner
| | | |
| | | |
| | | |
| | | |
| | | |
| | |
| | |
| | |
| | |
| | |
| |
| |
| |
| |
|
|
|
|




Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:41 AM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"