Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
kim kim is offline
external usenet poster
 
Posts: 183
Default Merging Time Fields

My data source has the time formatted in this manner: 08.30.00 and I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is 13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim
  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP Doug Robbins - Word MVP is offline
external usenet poster
 
Posts: 8,832
Default Merging Time Fields

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed when you use
Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and I want
it
to print 8:30 am in Word yet it prints 12:00 am. If the time is 13.30.00,
it
will print fine: 1:30 pm. What is wrong?
--
Kim



  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
kim kim is offline
external usenet poster
 
Posts: 183
Default Merging Time Fields

Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00 prints 0:00

It's treating these values differently.
--
Kim


"Doug Robbins - Word MVP" wrote:

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed when you use
Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and I want
it
to print 8:30 am in Word yet it prints 12:00 am. If the time is 13.30.00,
it
will print fine: 1:30 pm. What is wrong?
--
Kim




  #4   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default Merging Time Fields

From the Tools menu in Word, select Options and then go to the General tab
and check the box against the "Confirm conversions at open" item. (In Word
2007 it is Office Button Word Options Advanced General Confirm file
format conversion on open). Then when you attach the data source to the mail
merge main document, you will be given the option of using the DDE method of
connection which should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00
prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed when
you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and
I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim



  #5   Report Post  
Posted to microsoft.public.word.mailmerge.fields
kim kim is offline
external usenet poster
 
Posts: 183
Default Merging Time Fields

My data source is a .txt file, it's generated from another application. I
tried all 3 DDE options available: Excel, Access, and Query, and none of
them work
--
Kim


"Graham Mayor" wrote:

From the Tools menu in Word, select Options and then go to the General tab
and check the box against the "Confirm conversions at open" item. (In Word
2007 it is Office Button Word Options Advanced General Confirm file
format conversion on open). Then when you attach the data source to the mail
merge main document, you will be given the option of using the DDE method of
connection which should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00
prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed when
you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and
I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim






  #6   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP Doug Robbins - Word MVP is offline
external usenet poster
 
Posts: 8,832
Default Merging Time Fields

I cannot replicate your problem using

{ MERGEFIELD "Start" \@ "h:mm am/pm" } { MERGEFIELD "Start" \@ "h:mm
am/pm" }

and a tab delimited text file containing

Start Finish
08:30:00 09:25:00
12:30:00 13:30:00
15:30:00 16:00:00

as the data source.

The result for the first record is

8:30 AM 9:25 AM

The connection to the datasource was the default method of connection.


--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source is a .txt file, it's generated from another application. I
tried all 3 DDE options available: Excel, Access, and Query, and none of
them work
--
Kim


"Graham Mayor" wrote:

From the Tools menu in Word, select Options and then go to the General
tab
and check the box against the "Confirm conversions at open" item. (In
Word
2007 it is Office Button Word Options Advanced General Confirm
file
format conversion on open). Then when you attach the data source to the
mail
merge main document, you will be given the option of using the DDE method
of
connection which should read the data as you have it formatted in the
table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00
prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed when
you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and
I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim






  #7   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default Merging Time Fields

Post an offending sample of your data - like Doug I cannot reproduce the
fault on the basis of the information you have provided.

DDE is for Excel/Access, TXT should not be an issue.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
My data source is a .txt file, it's generated from another
application. I tried all 3 DDE options available: Excel, Access,
and Query, and none of them work

From the Tools menu in Word, select Options and then go to the
General tab and check the box against the "Confirm conversions at
open" item. (In Word 2007 it is Office Button Word Options
Advanced General Confirm file format conversion on open). Then
when you attach the data source to the mail merge main document, you
will be given the option of using the DDE method of connection which
should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00
prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed
when you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of
my services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and
I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim



  #8   Report Post  
Posted to microsoft.public.word.mailmerge.fields
kim kim is offline
external usenet poster
 
Posts: 183
Default Merging Time Fields

The time field in my text file is formatted like this:

08.30.00 13.30.00

separated by decimals not colons.
--
Kim


"Graham Mayor" wrote:

Post an offending sample of your data - like Doug I cannot reproduce the
fault on the basis of the information you have provided.

DDE is for Excel/Access, TXT should not be an issue.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
My data source is a .txt file, it's generated from another
application. I tried all 3 DDE options available: Excel, Access,
and Query, and none of them work

From the Tools menu in Word, select Options and then go to the
General tab and check the box against the "Confirm conversions at
open" item. (In Word 2007 it is Office Button Word Options
Advanced General Confirm file format conversion on open). Then
when you attach the data source to the mail merge main document, you
will be given the option of using the DDE method of connection which
should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but 08.30.00
prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed
when you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of
my services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00 and
I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim




  #9   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default Merging Time Fields

Change the text file to produce a legitimate time format by using colons
instead of decimals.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
The time field in my text file is formatted like this:

08.30.00 13.30.00

separated by decimals not colons.

Post an offending sample of your data - like Doug I cannot reproduce
the fault on the basis of the information you have provided.

DDE is for Excel/Access, TXT should not be an issue.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
My data source is a .txt file, it's generated from another
application. I tried all 3 DDE options available: Excel, Access,
and Query, and none of them work

From the Tools menu in Word, select Options and then go to the
General tab and check the box against the "Confirm conversions at
open" item. (In Word 2007 it is Office Button Word Options
Advanced General Confirm file format conversion on open). Then
when you attach the data source to the mail merge main document,
you will be given the option of using the DDE method of connection
which should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but
08.30.00 prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed
when you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself
of my services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00
and I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim



  #10   Report Post  
Posted to microsoft.public.word.mailmerge.fields
kim kim is offline
external usenet poster
 
Posts: 183
Default Merging Time Fields

I have no control over the text file since it's produced by another
application. I don't understand why 13.30.00 is interpretted correctly but
08.30.00 isn't.
--
Kim


"Graham Mayor" wrote:

Change the text file to produce a legitimate time format by using colons
instead of decimals.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
The time field in my text file is formatted like this:

08.30.00 13.30.00

separated by decimals not colons.

Post an offending sample of your data - like Doug I cannot reproduce
the fault on the basis of the information you have provided.

DDE is for Excel/Access, TXT should not be an issue.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
My data source is a .txt file, it's generated from another
application. I tried all 3 DDE options available: Excel, Access,
and Query, and none of them work

From the Tools menu in Word, select Options and then go to the
General tab and check the box against the "Confirm conversions at
open" item. (In Word 2007 it is Office Button Word Options
Advanced General Confirm file format conversion on open). Then
when you attach the data source to the mail merge main document,
you will be given the option of using the DDE method of connection
which should read the data as you have it formatted in the table.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



Kim wrote:
Does not work. 13.30.00 will print correctly as 13:30 but
08.30.00 prints 0:00

It's treating these values differently.

Try adding a

\@ "H:mm"

switch inside the closing } of the mergefield that is displayed
when you use Alt+F9 to toggle on the display of the field codes

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself
of my services on a paid consulting basis.

Doug Robbins - Word MVP

"Kim" wrote in message
...
My data source has the time formatted in this manner: 08.30.00
and I want it
to print 8:30 am in Word yet it prints 12:00 am. If the time is
13.30.00, it
will print fine: 1:30 pm. What is wrong?
--
Kim






  #11   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Rich/rerat Rich/rerat is offline
external usenet poster
 
Posts: 93
Default Merging Time Fields

Kim,
I believe your data/values are being read like this:
08.30.00 = August 30, 2000 or just August 30 at midnight or 00:00:00 hrs
Because the "08" can represent the month of August
13.30.00 = 13:30:00
Since there is no 13th month, the "13" (or higher figure), will reflect the
24/military time correctly.

--
Add MS to your News Reader: news://msnews.microsoft.com
Rich/rerat (RRR News) message rule
Previous Text Snipped to Save Bandwidth When Appropriate

"Kim" wrote in message
...
I have no control over the text file since it's produced by another
application. I don't understand why 13.30.00 is interpretted correctly but
08.30.00 isn't.
--
Kim



Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Merging fields with more than 256 characters Rhapsody Mailmerge 1 March 6th 08 09:13 AM
Excel Date and Time not merging correctly to word Heather Fabries Mailmerge 2 December 20th 07 02:08 PM
Blank date fields in Excel merging with Date/Time margaret Mailmerge 1 March 16th 06 04:36 PM
linking documents together and mail merging at the same time carrol Mailmerge 5 June 15th 05 04:33 PM
Word2000 Merging Fields B. Wingert Microsoft Word Help 1 June 1st 05 09:38 PM


All times are GMT +1. The time now is 10:20 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"