Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.docmanagement
Vivian P
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for entire d

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field basis
but this is not practical in the environment. I need to set the spell check
for the entire document. Can anyone help please?
  #2   Report Post  
Posted to microsoft.public.word.docmanagement
Cindy M -WordMVP-
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for entire d

Hi ?B?Vml2aWFuIFA=?=,

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field basis
but this is not practical in the environment. I need to set the spell check
for the entire document.

There's no way to force field code results to automatically support spelling.
But you can use Ctrl+A to select the entire document and apply the language in
one step.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)

  #3   Report Post  
Posted to microsoft.public.word.docmanagement
Mike DiCanio
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for enti

I am having the same problems when merging from a SQL database into Word
2003. Merge fields that are pulled from the SQL server are not spell
checking. I have tried Ctrl - A and set the language default and unchecked
the box for "Do Not Spell Check."
This did not work. I have also gone to Cindy's web site and done what she
has recommended by enclosing the merge field in quotes and then applying a
specific style. This worked partially. The only merge fields that are spell
check enabled are fields that are data entry fields.

According to the steps on Cindy's site, what she recommends should work.
Can anyone tell me why it does not?

Thanks.

Mike



"Cindy M -WordMVP-" wrote:

Hi ?B?Vml2aWFuIFA=?=,

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field basis
but this is not practical in the environment. I need to set the spell check
for the entire document.

There's no way to force field code results to automatically support spelling.
But you can use Ctrl+A to select the entire document and apply the language in
one step.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)


  #4   Report Post  
Posted to microsoft.public.word.docmanagement
Mike DiCanio
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for enti

an update to this email...... I found some reason as to why the merge fields
direct from the database were not spell checking when using the solution
provided by Cindy's web-site. Depending on the data, some of it was entered
into the database in CAPS or letter number combinations. I found that Word
was set to ignore words in all uppercase and words with letters and number.
Once I unchecked these, it greatly improved the spell check process and
picked up on many of the merged words. -Mike

"Mike DiCanio" wrote:

I am having the same problems when merging from a SQL database into Word
2003. Merge fields that are pulled from the SQL server are not spell
checking. I have tried Ctrl - A and set the language default and unchecked
the box for "Do Not Spell Check."
This did not work. I have also gone to Cindy's web site and done what she
has recommended by enclosing the merge field in quotes and then applying a
specific style. This worked partially. The only merge fields that are spell
check enabled are fields that are data entry fields.

According to the steps on Cindy's site, what she recommends should work.
Can anyone tell me why it does not?

Thanks.

Mike



"Cindy M -WordMVP-" wrote:

Hi ?B?Vml2aWFuIFA=?=,

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field basis
but this is not practical in the environment. I need to set the spell check
for the entire document.

There's no way to force field code results to automatically support spelling.
But you can use Ctrl+A to select the entire document and apply the language in
one step.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)


  #5   Report Post  
Posted to microsoft.public.word.docmanagement
Merge Spell Check
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for enti

Ok, so I have a Word document with a whole bunch of mail merge fields. I
figured out how to spell check the merge fields like Cindy says to set the
language. The problem is that it spell checks last names of people I'm
sending letters to. Is there a way to just set a specific field or two to be
spell checked without having it check every single field???

"Cindy M -WordMVP-" wrote:

Hi ?B?Vml2aWFuIFA=?=,

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field basis
but this is not practical in the environment. I need to set the spell check
for the entire document.

There's no way to force field code results to automatically support spelling.
But you can use Ctrl+A to select the entire document and apply the language in
one step.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :-)




  #6   Report Post  
Posted to microsoft.public.word.docmanagement
John McGhie [MVP - Word and Word Macintosh]
 
Posts: n/a
Default Document with mail merge fields - turn on spell check for enti

Yes: Any text you mark as "No Proofing" will be ignored by the
spell-checker.

Obviously, you need to do this in your Main Document.

Normally, one would use a Style for this. Define a style named "No
Spelling" that has all the properties of the underlying style plus a
"Language" of "Do not check spelling or grammar".

Apply the style to all of the fields you do not want checked. The others
will be checked.

Hope this helps


On 30/3/06 8:56 AM, in article
, "Merge Spell Check"
Merge Spell
wrote:

Ok, so I have a Word document with a whole bunch of mail merge fields. I
figured out how to spell check the merge fields like Cindy says to set the
language. The problem is that it spell checks last names of people I'm
sending letters to. Is there a way to just set a specific field or two to be
spell checked without having it check every single field???

"Cindy M -WordMVP-" wrote:

Hi ?B?Vml2aWFuIFA=?=,

I have a Word document with several mail merge fields. When the document is
gnerated, the mail merge fields default to 'do not check spelling'. How do
I
get the document to generate to permit spell checking for the entire
document. I am aware that I can uncheck the option on a field by field
basis
but this is not practical in the environment. I need to set the spell check
for the entire document.

There's no way to force field code results to automatically support spelling.
But you can use Ctrl+A to select the entire document and apply the language
in
one step.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or
reply
in the newsgroup and not by e-mail :-)



--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I make footnote numners static in a mail merge document? Heather Mailmerge 5 October 14th 05 04:59 AM
Populate Merge Fields via VB.NET ben Mailmerge 5 June 21st 05 05:43 PM
mail merge with attachments AS Mailmerge 5 April 9th 05 09:49 AM
How to protect the main document in a mail merge process Antonio O Mailmerge 0 February 16th 05 04:29 PM
Mail Merge Issue With Office 97 - Excel Data Source Matt Thorley Mailmerge 1 February 15th 05 11:38 PM


All times are GMT +1. The time now is 04:33 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"