#1   Report Post  
robin
 
Posts: n/a
Default Header and Footer

I have Office 2003.

I am trying to access the header and footer feature in Word but when I
choose View\header and footer\insert auto text\filename and path i get this
message:
filename\p
but it does not give me the actual name and path of the file. I toggled the
Alt F9 but it does not change the coding in the header. I even went to
Tools\options\view tab and checked and uncheck the box that says "field
codes" but nothing change. I hightled the code in the header box and toggled
the field codes on and off and the coding in the header never changed. Is
there something that I am missing? It has something to do with the profile
b\c when I log on to the same computer but with a different profile the
toggle of 'field code' works but it is only with the other profile that we
have the problem. Is there a registry setting that I can check either under
his profile or somewhere else?
Can you help me?

Thanks for your help


  #2   Report Post  
Jay Freedman
 
Posts: n/a
Default

Hi Robin,

It sounds like the AutoText entry for Filename and Path (which normally is a
field containing the field code filename \p) has been replaced with plain
text. That's stored in the Normal.dot template, not in the registry.

Select the text filename \p and then press Ctrl+F9 to turn it into a field.
Press F9 to update it. While that field is selected, press Alt+F3 and type
in the name Filename and Path. Word should ask you whether you want to
replace the existing AutoText entry of that name; answer yes. If you're
asked to save Normal.dot when you exit from Word, answer yes again.

All of this will affect only the user profile in which you do it, since each
profile has its own copy of Normal.dot.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
I have Office 2003.

I am trying to access the header and footer feature in Word but when I
choose View\header and footer\insert auto text\filename and path i
get this message:
filename\p
but it does not give me the actual name and path of the file. I
toggled the Alt F9 but it does not change the coding in the header. I
even went to Tools\options\view tab and checked and uncheck the box
that says "field codes" but nothing change. I hightled the code in
the header box and toggled the field codes on and off and the coding
in the header never changed. Is there something that I am missing? It
has something to do with the profile b\c when I log on to the same
computer but with a different profile the toggle of 'field code'
works but it is only with the other profile that we have the problem.
Is there a registry setting that I can check either under his profile
or somewhere else? Can you help me?

Thanks for your help



  #3   Report Post  
robin
 
Posts: n/a
Default

Jay,

I did exactly what you told me and it worked for the most part. But the
problem I am running into now is it creates the filename but not the path of
the file. In other words when I select Filename and path and hit ctrl and F9
it turns the code into the actual name (which is normal.dot) and I save the
changes but when I use that feature again it only displayes the filename not
the path. What am I missing?

Then too, I also noticed that all of those options under header and
footer\insert... does not work. I guess I would have to do that to all of
them but it is not working for filename and path yet.

Please help!

"Jay Freedman" wrote:

Hi Robin,

It sounds like the AutoText entry for Filename and Path (which normally is a
field containing the field code filename \p) has been replaced with plain
text. That's stored in the Normal.dot template, not in the registry.

Select the text filename \p and then press Ctrl+F9 to turn it into a field.
Press F9 to update it. While that field is selected, press Alt+F3 and type
in the name Filename and Path. Word should ask you whether you want to
replace the existing AutoText entry of that name; answer yes. If you're
asked to save Normal.dot when you exit from Word, answer yes again.

All of this will affect only the user profile in which you do it, since each
profile has its own copy of Normal.dot.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
I have Office 2003.

I am trying to access the header and footer feature in Word but when I
choose View\header and footer\insert auto text\filename and path i
get this message:
filename\p
but it does not give me the actual name and path of the file. I
toggled the Alt F9 but it does not change the coding in the header. I
even went to Tools\options\view tab and checked and uncheck the box
that says "field codes" but nothing change. I hightled the code in
the header box and toggled the field codes on and off and the coding
in the header never changed. Is there something that I am missing? It
has something to do with the profile b\c when I log on to the same
computer but with a different profile the toggle of 'field code'
works but it is only with the other profile that we have the problem.
Is there a registry setting that I can check either under his profile
or somewhere else? Can you help me?

Thanks for your help




  #4   Report Post  
Jay Freedman
 
Posts: n/a
Default

Hi Robin,

1: Press Alt+F9 to display the field code and look at it. It should look
like
{ filename \p }
It should NOT look like either of these:
{ filename }
{ filename and path }

2: If the field is in a template, and you create a new document from the
template, all the field will show is something like "Document1". Until you
save the document, it doesn't have a path; this is normal behavior. After
you save the document, you have to update the field -- either select it and
press F9, or go to Print Preview and back (assuming the "Update fields" box
is checked in Tools Options Print).

3: It's an official Bad Idea to put anything in the header or footer of the
normal.dot template. That template is used for other things such as labels,
where you don't want anything in the header/footer because it will interfere
with the proper spacing. Instead, use the File New dialog to make a new
template, and put the field in there.

4 and most important: Probably the reason none of the AutoTexts on the
header/footer toolbar work is either (a) you replaced your normal.dot with
some other document or template that didn't contain any AutoText, or (b)
your normal.dot is damaged. Instead of spending a lot of time rebuilding the
AutoText, go to http://word.mvps.org/FAQs/AppErrors/...ocNotBlank.htm and
use the steps under "Creating a new Normal.dot from scratch". That will
bring them all back at once.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
Jay,

I did exactly what you told me and it worked for the most part. But
the problem I am running into now is it creates the filename but not
the path of the file. In other words when I select Filename and path
and hit ctrl and F9 it turns the code into the actual name (which is
normal.dot) and I save the changes but when I use that feature again
it only displayes the filename not the path. What am I missing?

Then too, I also noticed that all of those options under header and
footer\insert... does not work. I guess I would have to do that to
all of them but it is not working for filename and path yet.

Please help!

"Jay Freedman" wrote:

Hi Robin,

It sounds like the AutoText entry for Filename and Path (which
normally is a field containing the field code filename \p) has been
replaced with plain text. That's stored in the Normal.dot template,
not in the registry.

Select the text filename \p and then press Ctrl+F9 to turn it into a
field. Press F9 to update it. While that field is selected, press
Alt+F3 and type in the name Filename and Path. Word should ask you
whether you want to replace the existing AutoText entry of that
name; answer yes. If you're asked to save Normal.dot when you exit
from Word, answer yes again.

All of this will affect only the user profile in which you do it,
since each profile has its own copy of Normal.dot.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
I have Office 2003.

I am trying to access the header and footer feature in Word but
when I choose View\header and footer\insert auto text\filename and
path i get this message:
filename\p
but it does not give me the actual name and path of the file. I
toggled the Alt F9 but it does not change the coding in the header.
I even went to Tools\options\view tab and checked and uncheck the
box that says "field codes" but nothing change. I hightled the code
in the header box and toggled the field codes on and off and the
coding in the header never changed. Is there something that I am
missing? It has something to do with the profile b\c when I log on
to the same computer but with a different profile the toggle of
'field code' works but it is only with the other profile that we
have the problem. Is there a registry setting that I can check
either under his profile or somewhere else? Can you help me?

Thanks for your help



  #5   Report Post  
robin
 
Posts: n/a
Default

WORK LIKE A CHARM!!!!! Thanks! You're the GREATEST!!!

"Jay Freedman" wrote:

Hi Robin,

1: Press Alt+F9 to display the field code and look at it. It should look
like
{ filename \p }
It should NOT look like either of these:
{ filename }
{ filename and path }

2: If the field is in a template, and you create a new document from the
template, all the field will show is something like "Document1". Until you
save the document, it doesn't have a path; this is normal behavior. After
you save the document, you have to update the field -- either select it and
press F9, or go to Print Preview and back (assuming the "Update fields" box
is checked in Tools Options Print).

3: It's an official Bad Idea to put anything in the header or footer of the
normal.dot template. That template is used for other things such as labels,
where you don't want anything in the header/footer because it will interfere
with the proper spacing. Instead, use the File New dialog to make a new
template, and put the field in there.

4 and most important: Probably the reason none of the AutoTexts on the
header/footer toolbar work is either (a) you replaced your normal.dot with
some other document or template that didn't contain any AutoText, or (b)
your normal.dot is damaged. Instead of spending a lot of time rebuilding the
AutoText, go to http://word.mvps.org/FAQs/AppErrors/...ocNotBlank.htm and
use the steps under "Creating a new Normal.dot from scratch". That will
bring them all back at once.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
Jay,

I did exactly what you told me and it worked for the most part. But
the problem I am running into now is it creates the filename but not
the path of the file. In other words when I select Filename and path
and hit ctrl and F9 it turns the code into the actual name (which is
normal.dot) and I save the changes but when I use that feature again
it only displayes the filename not the path. What am I missing?

Then too, I also noticed that all of those options under header and
footer\insert... does not work. I guess I would have to do that to
all of them but it is not working for filename and path yet.

Please help!

"Jay Freedman" wrote:

Hi Robin,

It sounds like the AutoText entry for Filename and Path (which
normally is a field containing the field code filename \p) has been
replaced with plain text. That's stored in the Normal.dot template,
not in the registry.

Select the text filename \p and then press Ctrl+F9 to turn it into a
field. Press F9 to update it. While that field is selected, press
Alt+F3 and type in the name Filename and Path. Word should ask you
whether you want to replace the existing AutoText entry of that
name; answer yes. If you're asked to save Normal.dot when you exit
from Word, answer yes again.

All of this will affect only the user profile in which you do it,
since each profile has its own copy of Normal.dot.

--
Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org

robin wrote:
I have Office 2003.

I am trying to access the header and footer feature in Word but
when I choose View\header and footer\insert auto text\filename and
path i get this message:
filename\p
but it does not give me the actual name and path of the file. I
toggled the Alt F9 but it does not change the coding in the header.
I even went to Tools\options\view tab and checked and uncheck the
box that says "field codes" but nothing change. I hightled the code
in the header box and toggled the field codes on and off and the
coding in the header never changed. Is there something that I am
missing? It has something to do with the profile b\c when I log on
to the same computer but with a different profile the toggle of
'field code' works but it is only with the other profile that we
have the problem. Is there a registry setting that I can check
either under his profile or somewhere else? Can you help me?

Thanks for your help




Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I turn off fading of the header and footer in Word? Smiley Microsoft Word Help 1 January 5th 05 07:36 PM
Master document with different header and footer for subdocuments Richard Balfour Microsoft Word Help 2 January 4th 05 02:00 PM
How can I copy and paste a page showing the header and footer Theresa Standley Microsoft Word Help 1 January 4th 05 01:35 PM
header and footer eric Microsoft Word Help 1 December 11th 04 12:44 PM
Header and footer Pinar. Microsoft Word Help 1 December 6th 04 09:33 PM


All times are GMT +1. The time now is 10:56 AM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"