Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
JHeckman JHeckman is offline
external usenet poster
 
Posts: 2
Default merged document field not displaying all source data

[Win Vista, Office 2007 SP2]
I'm using a single Excel spreadsheet as a data source for a Word merged
document. My problematic field is 'comments.' While the merged doc DOES show
multi-lines, it cuts off after about 250 characters of source data. Is there
a field switch I can use to eliminiate this problem?

  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP Doug Robbins - Word MVP is offline
external usenet poster
 
Posts: 8,832
Default merged document field not displaying all source data

Using the default method of connection to the database, the type of data in
each field is deduced from the first eight or so records so if those records
do have sufficiently long comments associated with them, the data type may
be deduced to one with a limit of 255/256 characters.

You should be able to overcome the issue if in Word, you click on the Office
Button and then on Word Options and go to the Advanced tab and scroll down
to the General section of the dialog and check the box for "Confirm file
format conversion on open". Then when you attach your data source to the
mail merge main document, a Confirm Data Source dialog will open. Click on
the Show all box on this dialog and then select the MS Excel Worksheets via
DDE (*.xls) method of connection.

The alternative is to insert some dummy records at the top of the data
source that contain comments longer than 256 characters.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP, originally posted via msnews.microsoft.com

"JHeckman" wrote in message
...
[Win Vista, Office 2007 SP2]
I'm using a single Excel spreadsheet as a data source for a Word merged
document. My problematic field is 'comments.' While the merged doc DOES
show
multi-lines, it cuts off after about 250 characters of source data. Is
there
a field switch I can use to eliminiate this problem?

  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
JHeckman JHeckman is offline
external usenet poster
 
Posts: 2
Default merged document field not displaying all source data

Checking "Confirm...Format" box did not work. The false data field @ the top
works like a charm. THANK YOU!!

"Doug Robbins - Word MVP" wrote:

Using the default method of connection to the database, the type of data in
each field is deduced from the first eight or so records so if those records
do have sufficiently long comments associated with them, the data type may
be deduced to one with a limit of 255/256 characters.

You should be able to overcome the issue if in Word, you click on the Office
Button and then on Word Options and go to the Advanced tab and scroll down
to the General section of the dialog and check the box for "Confirm file
format conversion on open". Then when you attach your data source to the
mail merge main document, a Confirm Data Source dialog will open. Click on
the Show all box on this dialog and then select the MS Excel Worksheets via
DDE (*.xls) method of connection.

The alternative is to insert some dummy records at the top of the data
source that contain comments longer than 256 characters.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP, originally posted via msnews.microsoft.com

"JHeckman" wrote in message
...
[Win Vista, Office 2007 SP2]
I'm using a single Excel spreadsheet as a data source for a Word merged
document. My problematic field is 'comments.' While the merged doc DOES
show
multi-lines, it cuts off after about 250 characters of source data. Is
there
a field switch I can use to eliminiate this problem?

Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Merge Field Not Displaying Same Data as In Source MaxArk[_8_] Mailmerge 1 May 1st 08 04:40 AM
Displaying Two Decimal Places in Merged Excel Data Debs Mailmerge 3 December 20th 07 03:48 PM
how to keep date format in merged document same as in data source clivedaniels Microsoft Word Help 1 October 5th 06 06:52 AM
how do i include data source into merged document? Jason Mailmerge 2 January 27th 06 08:02 AM
Merged data that is present in data source is missing in merge mbd_newjersey Mailmerge 1 December 17th 04 10:52 AM


All times are GMT +1. The time now is 04:49 AM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"