Reply
 
Thread Tools Display Modes
  #1   Report Post  
ASwadener
 
Posts: n/a
Default Reading layout loses table of contents

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.
  #2   Report Post  
ASwadener
 
Posts: n/a
Default

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.

  #3   Report Post  
Cindy M -WordMVP-
 
Posts: n/a
Default

Hi ?B?QVN3YWRlbmVy?=,

Can't remember ever hearing of this, before. What, exactly, is being lost? The
entire field code? The bookmarks on which the TOC is built? Something else?

Can you give us a set of steps to reproduce the problem so that we can test it?

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.



Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply in
the newsgroup and not by e-mail :-)

  #4   Report Post  
ASwadener
 
Posts: n/a
Default

The TOC is actually displayed in Reading Layout, but the page numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save the
attachment to my hard drive (don't try to open it from an email attachment),
then open it from the hard drive all the page #s are correct.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

Can't remember ever hearing of this, before. What, exactly, is being lost? The
entire field code? The bookmarks on which the TOC is built? Something else?

Can you give us a set of steps to reproduce the problem so that we can test it?

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.



Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply in
the newsgroup and not by e-mail :-)


  #5   Report Post  
Cindy M -WordMVP-
 
Posts: n/a
Default

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save the
attachment to my hard drive (don't try to open it from an email attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the Reading Layout the TOC
shows no page numbers at all. This actually makes sense, since the RL "screens" usually
will not match up with the actual page numbers. And the TOC field is not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word 2003 apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are you sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is being lost? The
entire field code? The bookmarks on which the TOC is built? Something else?

Can you give us a set of steps to reproduce the problem so that we can test it?

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.


Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply in the
newsgroup and not by e-mail :-)



  #6   Report Post  
ASwadener
 
Posts: n/a
Default

Word2003. Sorry, one more clarification... you are correct, no TOC page #s
show at all in reading layout... it's when you open in reading layout and
THEN press Esc or change your view that the page numbers all turn to page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save the
attachment to my hard drive (don't try to open it from an email attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the Reading Layout the TOC
shows no page numbers at all. This actually makes sense, since the RL "screens" usually
will not match up with the actual page numbers. And the TOC field is not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word 2003 apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are you sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is being lost? The
entire field code? The bookmarks on which the TOC is built? Something else?

Can you give us a set of steps to reproduce the problem so that we can test it?

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.


Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply in the
newsgroup and not by e-mail :-)


  #7   Report Post  
ASwadener
 
Posts: n/a
Default

Oh, and how would one use the \z in the field code? I'm not familiar with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no TOC page #s
show at all in reading layout... it's when you open in reading layout and
THEN press Esc or change your view that the page numbers all turn to page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save the
attachment to my hard drive (don't try to open it from an email attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the Reading Layout the TOC
shows no page numbers at all. This actually makes sense, since the RL "screens" usually
will not match up with the actual page numbers. And the TOC field is not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word 2003 apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are you sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is being lost? The
entire field code? The bookmarks on which the TOC is built? Something else?

Can you give us a set of steps to reproduce the problem so that we can test it?

Additional finding is that docs created in older versions of MSWord when
attached to emails do not lose their TOC reference #s in Reading Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least) file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook 2003,
automatically shows the doc in Reading Layout... an annoyance, but that would
be fine if it didn't also lose all of the table of contents entries from the
original document before it was attached to the email. If you force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains as it should
be. But the default behavior of MSWord IS to view in Reading Layout, so most
users who receive docs with TOCs will have this problem. When I'm creating
docs for prospective clients, I CANNOT have this problem. I've been having
to generate the table of contents and then copy-and-paste it as text to get
the document to be presented correctly to the email recipient.


Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply in the
newsgroup and not by e-mail :-)


  #8   Report Post  
Suzanne S. Barnhill
 
Posts: n/a
Default

Word inserts it by default, but only in conjunction with the \h switch, so
if you have deselected the "Use hyperlinks instead of page numbers" box in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
news
Oh, and how would one use the \z in the field code? I'm not familiar with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no TOC page

#s
show at all in reading layout... it's when you open in reading layout

and
THEN press Esc or change your view that the page numbers all turn to

page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page

numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save

the
attachment to my hard drive (don't try to open it from an email

attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the Reading

Layout the TOC
shows no page numbers at all. This actually makes sense, since the RL

"screens" usually
will not match up with the actual page numbers. And the TOC field is

not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word 2003

apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC

without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are you

sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is

being lost? The
entire field code? The bookmarks on which the TOC is built?

Something else?

Can you give us a set of steps to reproduce the problem so that we

can test it?

Additional finding is that docs created in older versions of

MSWord when
attached to emails do not lose their TOC reference #s in Reading

Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least)

file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook

2003,
automatically shows the doc in Reading Layout... an annoyance,

but that would
be fine if it didn't also lose all of the table of contents

entries from the
original document before it was attached to the email. If you

force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains

as it should
be. But the default behavior of MSWord IS to view in Reading

Layout, so most
users who receive docs with TOCs will have this problem. When

I'm creating
docs for prospective clients, I CANNOT have this problem.

I've been having
to generate the table of contents and then copy-and-paste it

as text to get
the document to be presented correctly to the email recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question

or reply in the
newsgroup and not by e-mail :-)



  #9   Report Post  
ASwadener
 
Posts: n/a
Default

Well that's a workaround that fixes my problem. Thanks. However, there's no
way to change the default behavior permanently within MSWord for future docs.
I'll have to remember to do this every time... AND users won't be able to
use the TOC to hyperlink to a doc section. Rats! That seems like really
ludicrous behavior. Reading layout was a really bad idea, in my opinion.

"Suzanne S. Barnhill" wrote:

Word inserts it by default, but only in conjunction with the \h switch, so
if you have deselected the "Use hyperlinks instead of page numbers" box in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
news
Oh, and how would one use the \z in the field code? I'm not familiar with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no TOC page

#s
show at all in reading layout... it's when you open in reading layout

and
THEN press Esc or change your view that the page numbers all turn to

page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page

numbers all
show up as page #1. Then when you get out of Reading Layout on that
document, the page numbers are still #1. If, however, I simply save

the
attachment to my hard drive (don't try to open it from an email

attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the Reading

Layout the TOC
shows no page numbers at all. This actually makes sense, since the RL

"screens" usually
will not match up with the actual page numbers. And the TOC field is

not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word 2003

apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC

without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are you

sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is

being lost? The
entire field code? The bookmarks on which the TOC is built?

Something else?

Can you give us a set of steps to reproduce the problem so that we

can test it?

Additional finding is that docs created in older versions of

MSWord when
attached to emails do not lose their TOC reference #s in Reading

Layout.
Doesn't fix the problem, but does show that MSWord v9 (at least)

file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from Outlook

2003,
automatically shows the doc in Reading Layout... an annoyance,

but that would
be fine if it didn't also lose all of the table of contents

entries from the
original document before it was attached to the email. If you

force MSWord
to NOT automatically show documents in Reading Layout (via the
ToolsOptionsGeneral function), the table of contents remains

as it should
be. But the default behavior of MSWord IS to view in Reading

Layout, so most
users who receive docs with TOCs will have this problem. When

I'm creating
docs for prospective clients, I CANNOT have this problem.

I've been having
to generate the table of contents and then copy-and-paste it

as text to get
the document to be presented correctly to the email recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question

or reply in the
newsgroup and not by e-mail :-)




  #10   Report Post  
Suzanne S. Barnhill
 
Posts: n/a
Default

I think you've misunderstood; it seems like using the \h and \z switches
would solve your problem (along with not allowing starting in Reading Layout
view). But in any case, page numbers in a TOC are always hyperlinked. The \h
switch just determines whether the entire entry is also hyperlinked.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Well that's a workaround that fixes my problem. Thanks. However, there's

no
way to change the default behavior permanently within MSWord for future

docs.
I'll have to remember to do this every time... AND users won't be able to
use the TOC to hyperlink to a doc section. Rats! That seems like really
ludicrous behavior. Reading layout was a really bad idea, in my opinion.

"Suzanne S. Barnhill" wrote:

Word inserts it by default, but only in conjunction with the \h switch,

so
if you have deselected the "Use hyperlinks instead of page numbers" box

in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"ASwadener" wrote in message
news
Oh, and how would one use the \z in the field code? I'm not familiar

with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no TOC

page
#s
show at all in reading layout... it's when you open in reading

layout
and
THEN press Esc or change your view that the page numbers all turn to

page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page

numbers all
show up as page #1. Then when you get out of Reading Layout on

that
document, the page numbers are still #1. If, however, I simply

save
the
attachment to my hard drive (don't try to open it from an email

attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the

Reading
Layout the TOC
shows no page numbers at all. This actually makes sense, since the

RL
"screens" usually
will not match up with the actual page numbers. And the TOC field

is
not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word

2003
apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC

without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are

you
sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is

being lost? The
entire field code? The bookmarks on which the TOC is built?

Something else?

Can you give us a set of steps to reproduce the problem so

that we
can test it?

Additional finding is that docs created in older versions of

MSWord when
attached to emails do not lose their TOC reference #s in Rea

ding
Layout.
Doesn't fix the problem, but does show that MSWord v9 (at

least)
file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from

Outlook
2003,
automatically shows the doc in Reading Layout... an

annoyance,
but that would
be fine if it didn't also lose all of the table of

contents
entries from the
original document before it was attached to the email. If

you
force MSWord
to NOT automatically show documents in Reading Layout (via

the
ToolsOptionsGeneral function), the table of contents

remains
as it should
be. But the default behavior of MSWord IS to view in

Reading
Layout, so most
users who receive docs with TOCs will have this problem.

When
I'm creating
docs for prospective clients, I CANNOT have this problem.

I've been having
to generate the table of contents and then copy-and-paste

it
as text to get
the document to be presented correctly to the email

recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8

2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow

question
or reply in the
newsgroup and not by e-mail :-)







  #11   Report Post  
ASwadener
 
Posts: n/a
Default

Ah, I see what you mean. Thanks. By the way, turning off the heading
hyperlink option when I insert the TOC solves the problem. I don't have to
worry about Reading Layout now. Reading Layout shows the TOC headings with
page #s. The concern is that I can't control what others do with their
settings, so I have to "dumb this down". When they receive my attachment, if
they automatically go into Reading Layout, I don't want them to have
regenerate the TOC after changing their view from within that now-open
attachment. Anyway, I still think I don't really understand why MS ever came
up with Reading Layout anyway. It always shows things pretty much
peculiarly. I wish they'd get rid of it.

"Suzanne S. Barnhill" wrote:

I think you've misunderstood; it seems like using the \h and \z switches
would solve your problem (along with not allowing starting in Reading Layout
view). But in any case, page numbers in a TOC are always hyperlinked. The \h
switch just determines whether the entire entry is also hyperlinked.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Well that's a workaround that fixes my problem. Thanks. However, there's

no
way to change the default behavior permanently within MSWord for future

docs.
I'll have to remember to do this every time... AND users won't be able to
use the TOC to hyperlink to a doc section. Rats! That seems like really
ludicrous behavior. Reading layout was a really bad idea, in my opinion.

"Suzanne S. Barnhill" wrote:

Word inserts it by default, but only in conjunction with the \h switch,

so
if you have deselected the "Use hyperlinks instead of page numbers" box

in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"ASwadener" wrote in message
news Oh, and how would one use the \z in the field code? I'm not familiar

with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no TOC

page
#s
show at all in reading layout... it's when you open in reading

layout
and
THEN press Esc or change your view that the page numbers all turn to
page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the page
numbers all
show up as page #1. Then when you get out of Reading Layout on

that
document, the page numbers are still #1. If, however, I simply

save
the
attachment to my hard drive (don't try to open it from an email
attachment),
then open it from the hard drive all the page #s are correct.

Interesting. When I view a TOC (created in Word 2003) in the

Reading
Layout the TOC
shows no page numbers at all. This actually makes sense, since the

RL
"screens" usually
will not match up with the actual page numbers. And the TOC field

is
not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which Word

2003
apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a TOC
without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created? Are

you
sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What, exactly, is
being lost? The
entire field code? The bookmarks on which the TOC is built?
Something else?

Can you give us a set of steps to reproduce the problem so

that we
can test it?

Additional finding is that docs created in older versions of
MSWord when
attached to emails do not lose their TOC reference #s in Rea

ding
Layout.
Doesn't fix the problem, but does show that MSWord v9 (at

least)
file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from

Outlook
2003,
automatically shows the doc in Reading Layout... an

annoyance,
but that would
be fine if it didn't also lose all of the table of

contents
entries from the
original document before it was attached to the email. If

you
force MSWord
to NOT automatically show documents in Reading Layout (via

the
ToolsOptionsGeneral function), the table of contents

remains
as it should
be. But the default behavior of MSWord IS to view in

Reading
Layout, so most
users who receive docs with TOCs will have this problem.

When
I'm creating
docs for prospective clients, I CANNOT have this problem.
I've been having
to generate the table of contents and then copy-and-paste

it
as text to get
the document to be presented correctly to the email

recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8

2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow

question
or reply in the
newsgroup and not by e-mail :-)






  #12   Report Post  
Suzanne S. Barnhill
 
Posts: n/a
Default

I suspect there is a reason for Reading Layout. I can only assume it's for
reading Word docs on your cell phone (or something like that). I personally
have no use for it, either; it's certainly quite useless for highly
formatted documents (with tables, graphics, etc.).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Ah, I see what you mean. Thanks. By the way, turning off the heading
hyperlink option when I insert the TOC solves the problem. I don't have

to
worry about Reading Layout now. Reading Layout shows the TOC headings

with
page #s. The concern is that I can't control what others do with their
settings, so I have to "dumb this down". When they receive my attachment,

if
they automatically go into Reading Layout, I don't want them to have
regenerate the TOC after changing their view from within that now-open
attachment. Anyway, I still think I don't really understand why MS ever

came
up with Reading Layout anyway. It always shows things pretty much
peculiarly. I wish they'd get rid of it.

"Suzanne S. Barnhill" wrote:

I think you've misunderstood; it seems like using the \h and \z switches
would solve your problem (along with not allowing starting in Reading

Layout
view). But in any case, page numbers in a TOC are always hyperlinked.

The \h
switch just determines whether the entire entry is also hyperlinked.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Well that's a workaround that fixes my problem. Thanks. However,

there's
no
way to change the default behavior permanently within MSWord for

future
docs.
I'll have to remember to do this every time... AND users won't be

able to
use the TOC to hyperlink to a doc section. Rats! That seems like

really
ludicrous behavior. Reading layout was a really bad idea, in my

opinion.

"Suzanne S. Barnhill" wrote:

Word inserts it by default, but only in conjunction with the \h

switch,
so
if you have deselected the "Use hyperlinks instead of page numbers"

box
in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"ASwadener" wrote in message
news Oh, and how would one use the \z in the field code? I'm not

familiar
with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no

TOC
page
#s
show at all in reading layout... it's when you open in reading

layout
and
THEN press Esc or change your view that the page numbers all

turn to
page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the

page
numbers all
show up as page #1. Then when you get out of Reading Layout

on
that
document, the page numbers are still #1. If, however, I

simply
save
the
attachment to my hard drive (don't try to open it from an

email
attachment),
then open it from the hard drive all the page #s are

correct.

Interesting. When I view a TOC (created in Word 2003) in the

Reading
Layout the TOC
shows no page numbers at all. This actually makes sense, since

the
RL
"screens" usually
will not match up with the actual page numbers. And the TOC

field
is
not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which

Word
2003
apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a

TOC
without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created?

Are
you
sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What,

exactly, is
being lost? The
entire field code? The bookmarks on which the TOC is

built?
Something else?

Can you give us a set of steps to reproduce the problem so

that we
can test it?

Additional finding is that docs created in older

versions of
MSWord when
attached to emails do not lose their TOC reference #s in

Rea
ding
Layout.
Doesn't fix the problem, but does show that MSWord v9

(at
least)
file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from

Outlook
2003,
automatically shows the doc in Reading Layout... an

annoyance,
but that would
be fine if it didn't also lose all of the table of

contents
entries from the
original document before it was attached to the email.

If
you
force MSWord
to NOT automatically show documents in Reading Layout

(via
the
ToolsOptionsGeneral function), the table of contents

remains
as it should
be. But the default behavior of MSWord IS to view in

Reading
Layout, so most
users who receive docs with TOCs will have this

problem.
When
I'm creating
docs for prospective clients, I CANNOT have this

problem.
I've been having
to generate the table of contents and then

copy-and-paste
it
as text to get
the document to be presented correctly to the email

recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8

2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow

question
or reply in the
newsgroup and not by e-mail :-)







  #13   Report Post  
ASwadener
 
Posts: n/a
Default

I think I've found my soul mate! :-) Thanks for helping! Time for bed.
Goodnight!

"Suzanne S. Barnhill" wrote:

I suspect there is a reason for Reading Layout. I can only assume it's for
reading Word docs on your cell phone (or something like that). I personally
have no use for it, either; it's certainly quite useless for highly
formatted documents (with tables, graphics, etc.).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Ah, I see what you mean. Thanks. By the way, turning off the heading
hyperlink option when I insert the TOC solves the problem. I don't have

to
worry about Reading Layout now. Reading Layout shows the TOC headings

with
page #s. The concern is that I can't control what others do with their
settings, so I have to "dumb this down". When they receive my attachment,

if
they automatically go into Reading Layout, I don't want them to have
regenerate the TOC after changing their view from within that now-open
attachment. Anyway, I still think I don't really understand why MS ever

came
up with Reading Layout anyway. It always shows things pretty much
peculiarly. I wish they'd get rid of it.

"Suzanne S. Barnhill" wrote:

I think you've misunderstood; it seems like using the \h and \z switches
would solve your problem (along with not allowing starting in Reading

Layout
view). But in any case, page numbers in a TOC are always hyperlinked.

The \h
switch just determines whether the entire entry is also hyperlinked.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"ASwadener" wrote in message
...
Well that's a workaround that fixes my problem. Thanks. However,

there's
no
way to change the default behavior permanently within MSWord for

future
docs.
I'll have to remember to do this every time... AND users won't be

able to
use the TOC to hyperlink to a doc section. Rats! That seems like

really
ludicrous behavior. Reading layout was a really bad idea, in my

opinion.

"Suzanne S. Barnhill" wrote:

Word inserts it by default, but only in conjunction with the \h

switch,
so
if you have deselected the "Use hyperlinks instead of page numbers"

box
in
the TOC dialog, you won't get either one.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so
all may benefit.

"ASwadener" wrote in message
news Oh, and how would one use the \z in the field code? I'm not

familiar
with
that process. Thanks.

"ASwadener" wrote:

Word2003. Sorry, one more clarification... you are correct, no

TOC
page
#s
show at all in reading layout... it's when you open in reading
layout
and
THEN press Esc or change your view that the page numbers all

turn to
page #1.

"Cindy M -WordMVP-" wrote:

Hi ?B?QVN3YWRlbmVy?=,

The TOC is actually displayed in Reading Layout, but the

page
numbers all
show up as page #1. Then when you get out of Reading Layout

on
that
document, the page numbers are still #1. If, however, I

simply
save
the
attachment to my hard drive (don't try to open it from an

email
attachment),
then open it from the hard drive all the page #s are

correct.

Interesting. When I view a TOC (created in Word 2003) in the
Reading
Layout the TOC
shows no page numbers at all. This actually makes sense, since

the
RL
"screens" usually
will not match up with the actual page numbers. And the TOC

field
is
not consctructed
to work with RL "screens".

It appears this behavior is controlled by this switch, which

Word
2003
apparently
includes in the TOC field by default:
\z: Hides tab leader and page numbers in Web layout view.

However, when I test sending myself a document containing a

TOC
without this switch the
page numbers have not reset to 1.

In which version of Word are these documents being created?

Are
you
sure the TOC was
showing values other than 1 when it was sent to you?

Can't remember ever hearing of this, before. What,

exactly, is
being lost? The
entire field code? The bookmarks on which the TOC is

built?
Something else?

Can you give us a set of steps to reproduce the problem so
that we
can test it?

Additional finding is that docs created in older

versions of
MSWord when
attached to emails do not lose their TOC reference #s in

Rea
ding
Layout.
Doesn't fix the problem, but does show that MSWord v9

(at
least)
file don't
get corrupted by Reading Layout.

"ASwadener" wrote:

MSWord 2003, when opening an attached document from
Outlook
2003,
automatically shows the doc in Reading Layout... an
annoyance,
but that would
be fine if it didn't also lose all of the table of
contents
entries from the
original document before it was attached to the email.

If
you
force MSWord
to NOT automatically show documents in Reading Layout

(via
the
ToolsOptionsGeneral function), the table of contents
remains
as it should
be. But the default behavior of MSWord IS to view in
Reading
Layout, so most
users who receive docs with TOCs will have this

problem.
When
I'm creating
docs for prospective clients, I CANNOT have this

problem.
I've been having
to generate the table of contents and then

copy-and-paste
it
as text to get
the document to be presented correctly to the email
recipient.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8
2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow
question
or reply in the
newsgroup and not by e-mail :-)








  #14   Report Post  
Cindy M -WordMVP-
 
Posts: n/a
Default

Hi ?B?QVN3YWRlbmVy?=,

When they receive my attachment, if
they automatically go into Reading Layout, I don't want them to

have
regenerate the TOC after changing their view from within that

now-open
attachment.

Are other users also opening the TOC in Word 2003, or an earlier
version? As I mentioned, I haven't been able to duplicate the problem
you describe (page numbers resetting to 1). I seem to recall there
being a problem, in one version of Word, where all page numbers would
display as 1...

Hmm, as best I can remember, it had something to do with graphics
objects being anchored in the document header. Or maybe it was having
a table in the document header. Does the document you're seeing this
with have something in the header? If yes, create a copy and delete
everything in the header, then test whether you still see the same
behavior with the TOC?

don't really understand why MS ever came
up with Reading Layout anyway. It always shows things pretty much
peculiarly.

Reading Layout was created in order to read/scan reams of text.
Apparently, in corporate environments, people write reports, memos,
etc. in Word, then mail them out as attachments. Reading a document
on-screen, in a standard Word window isn't particularly efficient
(too wide and/or text is too small). The Reading Layout puts the text
on the screen in a manageable width and (with any luck) readable
size. Plus, you can set it up to display two pages by default.

Personally, I like it a lot when I have to read a lot.

Have you tried deactivating "Allow starting in Reading Layout" in
Tools/Options/General?

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow
question or reply in the newsgroup and not by e-mail :-)

  #15   Report Post  
Suzanne S. Barnhill
 
Posts: n/a
Default

The problem you're remembering, Cindy (which still exists AFAIK), results in
all page numbers being displayed as 0, not 1.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cindy M -WordMVP-" wrote in message
news:VA.0000a567.0077bcd5@speedy...
Hi ?B?QVN3YWRlbmVy?=,

When they receive my attachment, if
they automatically go into Reading Layout, I don't want them to

have
regenerate the TOC after changing their view from within that

now-open
attachment.

Are other users also opening the TOC in Word 2003, or an earlier
version? As I mentioned, I haven't been able to duplicate the problem
you describe (page numbers resetting to 1). I seem to recall there
being a problem, in one version of Word, where all page numbers would
display as 1...

Hmm, as best I can remember, it had something to do with graphics
objects being anchored in the document header. Or maybe it was having
a table in the document header. Does the document you're seeing this
with have something in the header? If yes, create a copy and delete
everything in the header, then test whether you still see the same
behavior with the TOC?

don't really understand why MS ever came
up with Reading Layout anyway. It always shows things pretty much
peculiarly.

Reading Layout was created in order to read/scan reams of text.
Apparently, in corporate environments, people write reports, memos,
etc. in Word, then mail them out as attachments. Reading a document
on-screen, in a standard Word window isn't particularly efficient
(too wide and/or text is too small). The Reading Layout puts the text
on the screen in a manageable width and (with any luck) readable
size. Plus, you can set it up to display two pages by default.

Personally, I like it a lot when I have to read a lot.

Have you tried deactivating "Allow starting in Reading Layout" in
Tools/Options/General?

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow
question or reply in the newsgroup and not by e-mail :-)


Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Table of Contents G Microsoft Word Help 2 November 27th 07 04:01 PM
Automatic Table of Contents Question Jen M Microsoft Word Help 3 December 9th 04 05:08 PM
Navigate from document to Table of Contents Marilyn Microsoft Word Help 1 December 8th 04 11:44 PM
How do i get table of contents of 5 different documents in 6th do. KK Microsoft Word Help 1 December 6th 04 06:24 PM
Wrong Page Numbers in Table of Contents latteluvva Microsoft Word Help 1 November 26th 04 07:01 AM


All times are GMT +1. The time now is 10:37 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"