Reply
 
Thread Tools Display Modes
  #1   Report Post  
 
Posts: n/a
Default macros and SharePoint WSS document libraries

Hi,
I am new at macros. I have a macro that is stored in a document project
in "this document". When run, the macro opens a second document and
passes values entered by the user into the first document into
corresponding fields in the second document. This works well from Word.

Now, the first document is used as a template in a document library in
a SharePoint WSS site stored in the Forms folder where the template is
typically kept. The template is used when the user clicks on New
Document from within the document library.

I tried this two ways and am unable to get this to work.
1. I tried using the template as a .doc which is typcially how it is
done. When I create a new document, the code is passed to the new
document, but when I try to run the macro from Word (Tools Macros
Macro Run) the macro is not listed.

I tried creating a module and copying the code into it, with the same
results.

If I press Alt+F11, I see the code and can run it from the VBA menu,
but not from the Word document.

2. The same results occur if I use template.dot.

I am confused as to why the code is not attaching itself to a new
document that is created through the document library, and where the
code should be stored. In the project for the document called "this
document" or in a module. This is code that is written and not
recorded.

I appreciate any help you can provide as I have spent many hours on
this. Thank you.

Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:21 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"