Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Rone
 
Posts: n/a
Default Merge with Percentage field looses formatting

I'm having difficulty getting a percentage field from and Excel sheet to
properly format when I merge it with Word. I've had no problems getting
currency fields to format, but for some reason I can't get the percentages to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%. I've
also tried using 0's and moving the decimal around, but it hasn't helped me
any. I saw somewhere where someone used \#"0%", but this only displays '0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone
  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Doug Robbins - Word MVP
 
Posts: n/a
Default Merge with Percentage field looses formatting

For the following values of CAM_PERCENT, the following field construction
will give the results indicated

{ = { MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

0.0388 3.88%
3.88 388.00%

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Rone" wrote in message
...
I'm having difficulty getting a percentage field from and Excel sheet to
properly format when I merge it with Word. I've had no problems getting
currency fields to format, but for some reason I can't get the percentages
to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%. I've
also tried using 0's and moving the decimal around, but it hasn't helped
me
any. I saw somewhere where someone used \#"0%", but this only displays
'0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone



  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Graham Mayor
 
Posts: n/a
Default Merge with Percentage field looses formatting

See http://www.gmayor.com/formatting_word_fields.htm

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org


Rone wrote:
I'm having difficulty getting a percentage field from and Excel sheet
to properly format when I merge it with Word. I've had no problems
getting currency fields to format, but for some reason I can't get
the percentages to format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%.
I've also tried using 0's and moving the decimal around, but it
hasn't helped me any. I saw somewhere where someone used \#"0%", but
this only displays '0%' when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help



  #4   Report Post  
Posted to microsoft.public.word.mailmerge.fields
PA
 
Posts: n/a
Default Merge with Percentage field looses formatting

There is certainly nothing wrong with using switches, but the problem is
solved in a more complex manner than is necessary.
In Word, select Options from the Tools menu, and then select the General
tab. Put a check in Confirm Conversion at Open and click OK.
Henceforth, when merging from Excel, you will be given a choice of
conversion protocols while attaching your Excel data file to the Word
document. Choose DDE.
Using this solution you need never be concerned in the future when merging
formatted data, currency, percentage, date, etc, not only from Excel but
Access as well. Except in extrodinary circumstance, forget that switches
even exist. Just always choose DDE.


"Rone" wrote:

I'm having difficulty getting a percentage field from and Excel sheet to
properly format when I merge it with Word. I've had no problems getting
currency fields to format, but for some reason I can't get the percentages to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%. I've
also tried using 0's and moving the decimal around, but it hasn't helped me
any. I saw somewhere where someone used \#"0%", but this only displays '0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone

  #5   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Rone
 
Posts: n/a
Default Merge with Percentage field looses formatting

Doug -- I get a "Syntax Error" when I use the following switch: { = {
MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

I also tried connecting using the DDE stuff, but I lost all my fields during
the merge, and there are a lot of fields to lose. I think at this point I'd
rather try to get the percent stuff to work. I just don't understand why it
works fine for currency fields, but the percent fields it does not.

....any ideas why?

--
Rone


"Doug Robbins - Word MVP" wrote:

For the following values of CAM_PERCENT, the following field construction
will give the results indicated

{ = { MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

0.0388 3.88%
3.88 388.00%

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Rone" wrote in message
...
I'm having difficulty getting a percentage field from and Excel sheet to
properly format when I merge it with Word. I've had no problems getting
currency fields to format, but for some reason I can't get the percentages
to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%. I've
also tried using 0's and moving the decimal around, but it hasn't helped
me
any. I saw somewhere where someone used \#"0%", but this only displays
'0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone






  #6   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson
 
Posts: n/a
Default Merge with Percentage field looses formatting

All the {} need to be the special field braces you can insert using ctrl-F9,
not the ordinary { and } characters you can insert using the keyboard.

that's my best guess as to what's wrong, anyway...

Peter Jamieson
"Rone" wrote in message
...
Doug -- I get a "Syntax Error" when I use the following switch: { = {
MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

I also tried connecting using the DDE stuff, but I lost all my fields
during
the merge, and there are a lot of fields to lose. I think at this point
I'd
rather try to get the percent stuff to work. I just don't understand why
it
works fine for currency fields, but the percent fields it does not.

...any ideas why?

--
Rone


"Doug Robbins - Word MVP" wrote:

For the following values of CAM_PERCENT, the following field construction
will give the results indicated

{ = { MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

0.0388 3.88%
3.88 388.00%

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Rone" wrote in message
...
I'm having difficulty getting a percentage field from and Excel sheet
to
properly format when I merge it with Word. I've had no problems
getting
currency fields to format, but for some reason I can't get the
percentages
to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%.
I've
also tried using 0's and moving the decimal around, but it hasn't
helped
me
any. I saw somewhere where someone used \#"0%", but this only displays
'0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone






  #7   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Rone
 
Posts: n/a
Default Merge with Percentage field looses formatting

It worked! Thanks Peter. You were exactly right. I was typing in the {}
instead of using CTRL-F9 to insert them. I've been messing around for hours
on that! Thanks again for your help. Must be a common newbie mistake.

Thanks again!
--
Rone


"Peter Jamieson" wrote:

All the {} need to be the special field braces you can insert using ctrl-F9,
not the ordinary { and } characters you can insert using the keyboard.

that's my best guess as to what's wrong, anyway...

Peter Jamieson
"Rone" wrote in message
...
Doug -- I get a "Syntax Error" when I use the following switch: { = {
MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

I also tried connecting using the DDE stuff, but I lost all my fields
during
the merge, and there are a lot of fields to lose. I think at this point
I'd
rather try to get the percent stuff to work. I just don't understand why
it
works fine for currency fields, but the percent fields it does not.

...any ideas why?

--
Rone


"Doug Robbins - Word MVP" wrote:

For the following values of CAM_PERCENT, the following field construction
will give the results indicated

{ = { MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

0.0388 3.88%
3.88 388.00%

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Rone" wrote in message
...
I'm having difficulty getting a percentage field from and Excel sheet
to
properly format when I merge it with Word. I've had no problems
getting
currency fields to format, but for some reason I can't get the
percentages
to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%.
I've
also tried using 0's and moving the decimal around, but it hasn't
helped
me
any. I saw somewhere where someone used \#"0%", but this only displays
'0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone






  #8   Report Post  
Posted to microsoft.public.word.mailmerge.fields
llmed
 
Posts: n/a
Default Merge with Percentage field looses formatting

Thank you so much! I wish I had read this about 2 hours ago!

"Peter Jamieson" wrote:

All the {} need to be the special field braces you can insert using ctrl-F9,
not the ordinary { and } characters you can insert using the keyboard.

that's my best guess as to what's wrong, anyway...

Peter Jamieson
"Rone" wrote in message
...
Doug -- I get a "Syntax Error" when I use the following switch: { = {
MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

I also tried connecting using the DDE stuff, but I lost all my fields
during
the merge, and there are a lot of fields to lose. I think at this point
I'd
rather try to get the percent stuff to work. I just don't understand why
it
works fine for currency fields, but the percent fields it does not.

...any ideas why?

--
Rone


"Doug Robbins - Word MVP" wrote:

For the following values of CAM_PERCENT, the following field construction
will give the results indicated

{ = { MERGEFIELD CAM_PERCENT } * 100 \# 0.00% }

0.0388 3.88%
3.88 388.00%

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Rone" wrote in message
...
I'm having difficulty getting a percentage field from and Excel sheet
to
properly format when I merge it with Word. I've had no problems
getting
currency fields to format, but for some reason I can't get the
percentages
to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%.
I've
also tried using 0's and moving the decimal around, but it hasn't
helped
me
any. I saw somewhere where someone used \#"0%", but this only displays
'0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone






  #9   Report Post  
Posted to microsoft.public.word.mailmerge.fields
FLSusanC
 
Posts: n/a
Default Merge with Percentage field looses formatting

I thought this was a great suggestion and tried it right away, however, there
is a huge delay during the merge and the connection times out and the merge
is not completed. Any ideas about that?

"PA" wrote:

There is certainly nothing wrong with using switches, but the problem is
solved in a more complex manner than is necessary.
In Word, select Options from the Tools menu, and then select the General
tab. Put a check in Confirm Conversion at Open and click OK.
Henceforth, when merging from Excel, you will be given a choice of
conversion protocols while attaching your Excel data file to the Word
document. Choose DDE.
Using this solution you need never be concerned in the future when merging
formatted data, currency, percentage, date, etc, not only from Excel but
Access as well. Except in extrodinary circumstance, forget that switches
even exist. Just always choose DDE.


"Rone" wrote:

I'm having difficulty getting a percentage field from and Excel sheet to
properly format when I merge it with Word. I've had no problems getting
currency fields to format, but for some reason I can't get the percentages to
format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%. I've
also tried using 0's and moving the decimal around, but it hasn't helped me
any. I saw somewhere where someone used \#"0%", but this only displays '0%'
when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone

  #10   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Graham Mayor
 
Posts: n/a
Default Merge with Percentage field looses formatting

DDE is less reliable, which presumably is why Microsoft changed it as
default. Use switches http://www.gmayor.com/formatting_word_fields.htm

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org


FLSusanC wrote:
I thought this was a great suggestion and tried it right away,
however, there is a huge delay during the merge and the connection
times out and the merge is not completed. Any ideas about that?

"PA" wrote:

There is certainly nothing wrong with using switches, but the
problem is solved in a more complex manner than is necessary.
In Word, select Options from the Tools menu, and then select the
General tab. Put a check in Confirm Conversion at Open and click OK.
Henceforth, when merging from Excel, you will be given a choice of
conversion protocols while attaching your Excel data file to the Word
document. Choose DDE.
Using this solution you need never be concerned in the future when
merging formatted data, currency, percentage, date, etc, not only
from Excel but Access as well. Except in extrodinary circumstance,
forget that switches even exist. Just always choose DDE.


"Rone" wrote:

I'm having difficulty getting a percentage field from and Excel
sheet to properly format when I merge it with Word. I've had no
problems getting currency fields to format, but for some reason I
can't get the percentages to format right.

Here is the switch code I'm using: {MERGEFIELD "CAM_PERCENT" * 100
\#"##.##%"} This displays .0388% But I want it to display 3.88%.
I've also tried using 0's and moving the decimal around, but it
hasn't helped me any. I saw somewhere where someone used \#"0%",
but this only displays '0%' when merged.

I'm a bit new to this switching stuff. Does my version of Word have
anything to do with this? Its Word 2003 Professional v. 11.5604

Thanks for the help
--
Rone



Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding a field to an Off 97 mail merge using Office Pro 2003 TomC Mailmerge 1 January 5th 06 08:00 AM
Suppressing Merge Field and text before/after julie Microsoft Word Help 8 November 14th 05 02:50 PM
Formatting merge fields: inserting a paragraph mark before a field Justin Cascio Mailmerge 1 August 30th 05 08:18 PM
How do I omit an empty date merge field? Phildeman Microsoft Word Help 5 June 13th 05 03:29 PM
Formatting a percentage mail merge field Kylor Microsoft Word Help 5 March 18th 05 07:04 PM


All times are GMT +1. The time now is 02:33 AM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"