Reply
 
Thread Tools Display Modes
  #1   Report Post  
Wordmerger Wordmerger is offline
Junior Member
 
Posts: 6
Default unwanted formatting (Word 2007)

Hello,
I have a template in Word 2007 that does a mailmerge with a .CSV file.
The CSV file contains fields with document names (p.e. "ST 900.docx").
During the merge, the contents of these small documents is inserted.
The documents are made in Courier 12.
The template is also in Courier 12 and the default font in Normal.dotx is also Courier 12.

After the merge, in the "output" document, the layout of the inserted text is completely messed up:
in one line the font changes from Courier to Times New Roman and back and the text will be bold where it is not in the inserted documents.
Also, indentation is not kept the way it was in the original imported documents.

What can be the cause of this behavior and what can I do to fix it?

Thanks for your help!
  #2   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default unwanted formatting (Word 2007)

Toggle the field display - ALT+F9 - in your merge document and the fields
will change from Fieldname to {Mergefield Fieldname} add a charformat
switch eg

{Mergefield Fieldname \*Charformat} then press F9 to update the field. Do
the same for all the fields that display incorrectly. Then toggle the
display back again ALT+F9 and re-merge.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




"Wordmerger" wrote in message
...

Hello,
I have a template in Word 2007 that does a mailmerge with a .CSV file.
The CSV file contains fields with document names (p.e. "ST 900.docx").
During the merge, the contents of these small documents is inserted.
The documents are made in Courier 12.
The template is also in Courier 12 and the default font in Normal.dotx
is also Courier 12.

After the merge, in the "output" document, the layout of the inserted
text is completely messed up:
in one line the font changes from Courier to Times New Roman and back
and the text will be bold where it is not in the inserted documents.
Also, indentation is not kept the way it was in the original imported
documents.

What can be the cause of this behavior and what can I do to fix it?

Thanks for your help!




--
Wordmerger



  #3   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default unwanted formatting (Word 2007)


Toggle the field display - ALT+F9 - in your merge document and the fields
will change from Fieldname to {Mergefield Fieldname} add a charformat
switch eg

{Mergefield Fieldname \*Charformat} then press F9 to update the field. Do
the same for all the fields that display incorrectly. Then toggle the
display back again ALT+F9 and re-merge.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




"Wordmerger" wrote in message
...

Hello,
I have a template in Word 2007 that does a mailmerge with a .CSV file.
The CSV file contains fields with document names (p.e. "ST 900.docx").
During the merge, the contents of these small documents is inserted.
The documents are made in Courier 12.
The template is also in Courier 12 and the default font in Normal.dotx
is also Courier 12.

After the merge, in the "output" document, the layout of the inserted
text is completely messed up:
in one line the font changes from Courier to Times New Roman and back
and the text will be bold where it is not in the inserted documents.
Also, indentation is not kept the way it was in the original imported
documents.

What can be the cause of this behavior and what can I do to fix it?

Thanks for your help!




--
Wordmerger



  #4   Report Post  
Wordmerger Wordmerger is offline
Junior Member
 
Posts: 6
Default

Hi Graham,

I'm afraid that doesn't work, because the field that I use, inserts a complete (small) Word file in which there is formatting at different places.

In the template, the fields I use a

{ QUOTE { INCLUDETEXT "E:\\ {MERGEFIELD "art" } " }}

The contents of the field "art" is the name of a small Word document (p.e. ST 900.docx).
This can be a text of several lines with tabs, indents, bold and/or other formatting.

I already found out that I had to leave out the \*MERGEFORMAT part.
Right now it leaves the formatting OK for the inserted documents IF they are created on my computer.
I still have to do some testing to find out if it has something to do with the fact that the template was created on my computer and the small article-documents on my clients computer.

In the end this will have to work on my clients computer.
Would it help if I recreated the template on their computer ?

Thanks!



  #5   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default unwanted formatting (Word 2007)

Copying the document template to the client's PC would certainly be a place
to start. There appears to be a style related conflict between the two. Also
ensure that the automatically update styles check box in the Developer
Templates Document Template dialog is unchecked.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



"Wordmerger" wrote in message
...

Hi Graham,

I'm afraid that doesn't work, because the field that I use, inserts a
complete (small) Word file in which there is formatting at different
places.

In the template, the fields I use a

{ QUOTE { INCLUDETEXT "E:\\ {MERGEFIELD "art" } " }}

The contents of the field "art" is the name of a small Word document
(p.e. ST 900.docx).
This can be a text of several lines with tabs, indents, bold and/or
other formatting.

I already found out that I had to leave out the \*MERGEFORMAT part.
Right now it leaves the formatting OK for the inserted documents IF
they are created on my computer.
I still have to do some testing to find out if it has something to do
with the fact that the template was created on my computer and the
small article-documents on my clients computer.

In the end this will have to work on my clients computer.
Would it help if I recreated the template on their computer ?

Thanks!



Graham Mayor;468195 Wrote:
Toggle the field display - ALT+F9 - in your merge document and the
fields
will change from Fieldname to {Mergefield Fieldname} add a charformat
switch eg

{Mergefield Fieldname \*Charformat} then press F9 to update the field.
Do
the same for all the fields that display incorrectly. Then toggle the
display back again ALT+F9 and re-merge.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




"Wordmerger" wrote in message
...-

Hello,
I have a template in Word 2007 that does a mailmerge with a .CSV
file.
The CSV file contains fields with document names (p.e. "ST
900.docx").
During the merge, the contents of these small documents is inserted.
The documents are made in Courier 12.
The template is also in Courier 12 and the default font in
Normal.dotx
is also Courier 12.

After the merge, in the "output" document, the layout of the inserted
text is completely messed up:
in one line the font changes from Courier to Times New Roman and back
and the text will be bold where it is not in the inserted documents.
Also, indentation is not kept the way it was in the original imported
documents.

What can be the cause of this behavior and what can I do to fix it?

Thanks for your help!




--
Wordmerger -





--
Wordmerger





  #6   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default unwanted formatting (Word 2007)


Copying the document template to the client's PC would certainly be a place
to start. There appears to be a style related conflict between the two. Also
ensure that the automatically update styles check box in the Developer
Templates Document Template dialog is unchecked.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org



"Wordmerger" wrote in message
...

Hi Graham,

I'm afraid that doesn't work, because the field that I use, inserts a
complete (small) Word file in which there is formatting at different
places.

In the template, the fields I use a

{ QUOTE { INCLUDETEXT "E:\\ {MERGEFIELD "art" } " }}

The contents of the field "art" is the name of a small Word document
(p.e. ST 900.docx).
This can be a text of several lines with tabs, indents, bold and/or
other formatting.

I already found out that I had to leave out the \*MERGEFORMAT part.
Right now it leaves the formatting OK for the inserted documents IF
they are created on my computer.
I still have to do some testing to find out if it has something to do
with the fact that the template was created on my computer and the
small article-documents on my clients computer.

In the end this will have to work on my clients computer.
Would it help if I recreated the template on their computer ?

Thanks!



Graham Mayor;468195 Wrote:
Toggle the field display - ALT+F9 - in your merge document and the
fields
will change from Fieldname to {Mergefield Fieldname} add a charformat
switch eg

{Mergefield Fieldname \*Charformat} then press F9 to update the field.
Do
the same for all the fields that display incorrectly. Then toggle the
display back again ALT+F9 and re-merge.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




"Wordmerger" wrote in message
...-

Hello,
I have a template in Word 2007 that does a mailmerge with a .CSV
file.
The CSV file contains fields with document names (p.e. "ST
900.docx").
During the merge, the contents of these small documents is inserted.
The documents are made in Courier 12.
The template is also in Courier 12 and the default font in
Normal.dotx
is also Courier 12.

After the merge, in the "output" document, the layout of the inserted
text is completely messed up:
in one line the font changes from Courier to Times New Roman and back
and the text will be bold where it is not in the inserted documents.
Also, indentation is not kept the way it was in the original imported
documents.

What can be the cause of this behavior and what can I do to fix it?

Thanks for your help!




--
Wordmerger -





--
Wordmerger



Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
removing unwanted formatting from word whit Microsoft Word Help 5 December 14th 08 10:58 PM
Unwanted formatting changes vinceh Microsoft Word Help 12 August 27th 08 01:23 PM
Word causes unwanted formatting brianpals Page Layout 2 February 2nd 08 11:46 AM
unwanted global formatting [email protected] Microsoft Word Help 1 July 26th 07 09:14 PM
Unwanted Text Formatting lmr Microsoft Word Help 2 December 22nd 05 04:17 PM


All times are GMT +1. The time now is 12:54 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"