Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Sasquatch Sasquatch is offline
external usenet poster
 
Posts: 3
Default IF fields disappear upon printing

I have a Word doc that is merging data from an Access table (Office XP) and
there are merge fields in the doc (name, address, dates, currency values,
etc...) along with some {IF} fields for 7 classes that may or may not need to
show based on if the class's amount (merge field) is 0.

When the document opens all of the fields appear as needed but as soon as I
either preview or print the document, the {IF} fields will all vanish. Here
are my fields:

{ IF {MergeField Class1Amt } 0 "A. { MergeField Class1Text }" "" }
{ IF {MergeField Class2Amt } 0 "B. { MergeField Class2Text }" "" }
etc...
{ IF {MergeField Class7Amt } 0 "G. { MergeField Class7Text }" "" }

Can anyone give me any clues as to why these IF statements vanish upon
printing?

Thanks in advance.
  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
macropod macropod is offline
external usenet poster
 
Posts: 1,002
Default IF fields disappear upon printing

Hi Sasquatch,

They vanish because you'd normally want the field results to be printed, not the field codes. If you want to print the field code,
check the 'field codes' option under Tools|Options|Print.

Cheers

--
macropod
[MVP - Microsoft Word]


"Sasquatch" wrote in message ...
| I have a Word doc that is merging data from an Access table (Office XP) and
| there are merge fields in the doc (name, address, dates, currency values,
| etc...) along with some {IF} fields for 7 classes that may or may not need to
| show based on if the class's amount (merge field) is 0.
|
| When the document opens all of the fields appear as needed but as soon as I
| either preview or print the document, the {IF} fields will all vanish. Here
| are my fields:
|
| { IF {MergeField Class1Amt } 0 "A. { MergeField Class1Text }" "" }
| { IF {MergeField Class2Amt } 0 "B. { MergeField Class2Text }" "" }
| etc...
| { IF {MergeField Class7Amt } 0 "G. { MergeField Class7Text }" "" }
|
| Can anyone give me any clues as to why these IF statements vanish upon
| printing?
|
| Thanks in advance.


  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Sasquatch Sasquatch is offline
external usenet poster
 
Posts: 3
Default IF fields disappear upon printing

Maybe I didn't explain this well enough...

They vanish because you'd normally want the field results to be
printed, not the field codes. If you want to print the field code,
check the 'field codes' option under Tools|Options|Print.


I don't want to see the field codes, it's the field results I'm after. The
problem is that when the document opens the necessary field results are
visible BUT when I preview or print the document then nothing shows for those
fields results...as if they don't exist.

Here is an example of the IF statements I'm using:

{ IF {MergeField Class1Amt } 0 "A. { MergeField Class1Text }" "" }
{ IF {MergeField Class2Amt } 0 "B. { MergeField Class2Text }" "" }
etc...
{ IF {MergeField Class7Amt } 0 "G. { MergeField Class7Text }" "" }

So, for instance, if Class1Amt and Class2Amt are both greater than 0 and the
other ClassAmts equal 0 then it will show:
=============
A. some text...
B. some text...
=============
and the other 5 classes stay hidden (which is exactly what I want) BUT when
the document previews or prints all 7 classes are hidden, as if all the
ClassAmts = 0.

I played around with the statements and found that if I remove the {
MergeField Class#Text } from the "True" results then when I previewed/printed
the document it would in fact show the results.
=============
A.
B.
  #4   Report Post  
Posted to microsoft.public.word.mailmerge.fields
macropod macropod is offline
external usenet poster
 
Posts: 1,002
Default IF fields disappear upon printing

Hi Sasquatch,

Are you actually running the mailmerge, or just previewing it from the master? Also, were *all* the braces (ie '{ }') created by
Ctrl-F9, or did you simply type them? If its the latter for any of them, the fields concerned won't work

Cheers

--
macropod
[MVP - Microsoft Word]


"Sasquatch" wrote in message ...
| Maybe I didn't explain this well enough...
|
| They vanish because you'd normally want the field results to be
| printed, not the field codes. If you want to print the field code,
| check the 'field codes' option under Tools|Options|Print.
|
| I don't want to see the field codes, it's the field results I'm after. The
| problem is that when the document opens the necessary field results are
| visible BUT when I preview or print the document then nothing shows for those
| fields results...as if they don't exist.
|
| Here is an example of the IF statements I'm using:
|
| { IF {MergeField Class1Amt } 0 "A. { MergeField Class1Text }" "" }
| { IF {MergeField Class2Amt } 0 "B. { MergeField Class2Text }" "" }
| etc...
| { IF {MergeField Class7Amt } 0 "G. { MergeField Class7Text }" "" }
|
| So, for instance, if Class1Amt and Class2Amt are both greater than 0 and the
| other ClassAmts equal 0 then it will show:
| =============
| A. some text...
| B. some text...
| =============
| and the other 5 classes stay hidden (which is exactly what I want) BUT when
| the document previews or prints all 7 classes are hidden, as if all the
| ClassAmts = 0.
|
| I played around with the statements and found that if I remove the {
| MergeField Class#Text } from the "True" results then when I previewed/printed
| the document it would in fact show the results.
| =============
| A.
| B.
| =============
|
| SO, having said all that, why is it that once the document previews/prints
| the IF statements won't print these sentences?


  #5   Report Post  
Shannon Haley Shannon Haley is offline
Junior Member
 
Posts: 1
Default

I googled this issue and it took some piecing together to figure it out. This method worked for me (note that the field codes will go away)

Ctrl + A (select all text)

Ctrl + Shift + A (removes the field codes without removing the imported text)





Quote:
Originally Posted by macropod View Post
Hi Sasquatch,

Are you actually running the mailmerge, or just previewing it from the master? Also, were *all* the braces (ie '{ }') created by
Ctrl-F9, or did you simply type them? If its the latter for any of them, the fields concerned won't work

Cheers

--
macropod
[MVP - Microsoft Word]


"Sasquatch" wrote in message ...
| Maybe I didn't explain this well enough...
|
| They vanish because you'd normally want the field results to be
| printed, not the field codes. If you want to print the field code,
| check the 'field codes' option under Tools|Options|Print.
|
| I don't want to see the field codes, it's the field results I'm after. The
| problem is that when the document opens the necessary field results are
| visible BUT when I preview or print the document then nothing shows for those
| fields results...as if they don't exist.
|
| Here is an example of the IF statements I'm using:
|
| { IF {MergeField Class1Amt } 0 "A. { MergeField Class1Text }" "" }
| { IF {MergeField Class2Amt } 0 "B. { MergeField Class2Text }" "" }
| etc...
| { IF {MergeField Class7Amt } 0 "G. { MergeField Class7Text }" "" }
|
| So, for instance, if Class1Amt and Class2Amt are both greater than 0 and the
| other ClassAmts equal 0 then it will show:
| =============
| A. some text...
| B. some text...
| =============
| and the other 5 classes stay hidden (which is exactly what I want) BUT when
| the document previews or prints all 7 classes are hidden, as if all the
| ClassAmts = 0.
|
| I played around with the statements and found that if I remove the {
| MergeField Class#Text } from the "True" results then when I previewed/printed
| the document it would in fact show the results.
| =============
| A.
| B.
| =============
|
| SO, having said all that, why is it that once the document previews/prints
| the IF statements won't print these sentences?
Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bookmarks, TOC fields, PageRef fields disappear after print previe sjnet Microsoft Word Help 1 August 2nd 06 08:49 AM
Non Printing of blank fields Tony Williams Mailmerge 6 May 31st 06 07:50 PM
Non printing fields Kevan Williams Microsoft Word Help 3 January 27th 06 11:57 PM
printing form fields tam Microsoft Word Help 0 September 14th 05 05:17 PM
Merged fields not printing Tina L. Mailmerge 5 June 11th 05 04:44 PM


All times are GMT +1. The time now is 11:03 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"