Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Nina S Nina S is offline
external usenet poster
 
Posts: 1
Default merge field only shows 28 of 30 characters

the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina
  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson Peter Jamieson is offline
external usenet poster
 
Posts: 4,582
Default merge field only shows 28 of 30 characters

Some techie questions that you may have to refer to your programmer:

What type of database is it (SQL Server, mySQL, Oracle,...?)

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..? Is the field
coming directly from a table, or via a View or a stored procedure?

Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.

(I don't know a problem in this area, and the above info. would really
only allow us to try to replicate the problem if we happen to have the
necessary database software etc. available).

Peter Jamieson

http://tips.pjmsn.me.uk

On 14/01/2010 16:53, Nina S wrote:
the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina

  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Nina S[_2_] Nina S[_2_] is offline
external usenet poster
 
Posts: 2
Default merge field only shows 28 of 30 characters

I have the answers to all but the last question. Still waiting to hear from
the CRM programmer.

What type of database is it (SQL Server, mySQL, Oracle,...?)
SQL Server

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..?
PanelDescription (varchar(30), not null)

Is the field coming directly from a table, or via a View or a stored
procedure?
These are the views I looked at that I thought you might be using to get the
data
vDocRouterOPPOQuoter
vDocRouterQuoter


Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.
I do not know the answer to this question
Can you ask the CRM programmer?


"Peter Jamieson" wrote:

Some techie questions that you may have to refer to your programmer:

What type of database is it (SQL Server, mySQL, Oracle,...?)

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..? Is the field
coming directly from a table, or via a View or a stored procedure?

Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.

(I don't know a problem in this area, and the above info. would really
only allow us to try to replicate the problem if we happen to have the
necessary database software etc. available).

Peter Jamieson

http://tips.pjmsn.me.uk

On 14/01/2010 16:53, Nina S wrote:
the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina

.

  #4   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson Peter Jamieson is offline
external usenet poster
 
Posts: 4,582
Default merge field only shows 28 of 30 characters

Unfortunately I spent some time trying to replicate this problem but
could not do so (SQL Server 2008, VARCHAR(30) containing a 30-char text,
etc.). I've tried both OLE DB and ODBC connections, and both the old SQL
Server client and the newer Native Client. No difference.

If you have another program on your system that you could use to open
this data - for example Excel or Access - it might be worth trying that
to see if the same truncation is occurring.

If you are actually seeing two question marks at the end instead of the
two characters you expect, the problem probably results from the
"character translation" settings. However, for this to happen for every
value in the field, there would have to be two unusual characters at the
end of /every/ value, which would seem a little strange.

Peter Jamieson

http://tips.pjmsn.me.uk

On 25/01/2010 20:38, Nina S wrote:
I have the answers to all but the last question. Still waiting to hear from
the CRM programmer.

What type of database is it (SQL Server, mySQL, Oracle,...?)
SQL Server

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..?
PanelDescription (varchar(30), not null)

Is the field coming directly from a table, or via a View or a stored
procedure?
These are the views I looked at that I thought you might be using to get the
data
vDocRouterOPPOQuoter
vDocRouterQuoter


Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.
I do not know the answer to this question
Can you ask the CRM programmer?


"Peter Jamieson" wrote:

Some techie questions that you may have to refer to your programmer:

What type of database is it (SQL Server, mySQL, Oracle,...?)

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..? Is the field
coming directly from a table, or via a View or a stored procedure?

Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.

(I don't know a problem in this area, and the above info. would really
only allow us to try to replicate the problem if we happen to have the
necessary database software etc. available).

Peter Jamieson

http://tips.pjmsn.me.uk

On 14/01/2010 16:53, Nina S wrote:
the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina

.

  #5   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Nina S[_2_] Nina S[_2_] is offline
external usenet poster
 
Posts: 2
Default merge field only shows 28 of 30 characters

I asked my CRM programmer about this a while back and he did not respond
until I copied my boss on an email. Now he has the answer and needs to make
an adjustment and recompile docRouter. He will have the problem fixed. Thank
you for your time.
Nina

"Peter Jamieson" wrote:

Unfortunately I spent some time trying to replicate this problem but
could not do so (SQL Server 2008, VARCHAR(30) containing a 30-char text,
etc.). I've tried both OLE DB and ODBC connections, and both the old SQL
Server client and the newer Native Client. No difference.

If you have another program on your system that you could use to open
this data - for example Excel or Access - it might be worth trying that
to see if the same truncation is occurring.

If you are actually seeing two question marks at the end instead of the
two characters you expect, the problem probably results from the
"character translation" settings. However, for this to happen for every
value in the field, there would have to be two unusual characters at the
end of /every/ value, which would seem a little strange.

Peter Jamieson

http://tips.pjmsn.me.uk

On 25/01/2010 20:38, Nina S wrote:
I have the answers to all but the last question. Still waiting to hear from
the CRM programmer.

What type of database is it (SQL Server, mySQL, Oracle,...?)
SQL Server

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..?
PanelDescription (varchar(30), not null)

Is the field coming directly from a table, or via a View or a stored
procedure?
These are the views I looked at that I thought you might be using to get the
data
vDocRouterOPPOQuoter
vDocRouterQuoter


Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.
I do not know the answer to this question
Can you ask the CRM programmer?


"Peter Jamieson" wrote:

Some techie questions that you may have to refer to your programmer:

What type of database is it (SQL Server, mySQL, Oracle,...?)

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..? Is the field
coming directly from a table, or via a View or a stored procedure?

Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.

(I don't know a problem in this area, and the above info. would really
only allow us to try to replicate the problem if we happen to have the
necessary database software etc. available).

Peter Jamieson

http://tips.pjmsn.me.uk

On 14/01/2010 16:53, Nina S wrote:
the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina
.

.



  #6   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson Peter Jamieson is offline
external usenet poster
 
Posts: 4,582
Default merge field only shows 28 of 30 characters

OK, glad you got it sorted.

Peter Jamieson

http://tips.pjmsn.me.uk

On 26/01/2010 17:52, Nina S wrote:
I asked my CRM programmer about this a while back and he did not respond
until I copied my boss on an email. Now he has the answer and needs to make
an adjustment and recompile docRouter. He will have the problem fixed. Thank
you for your time.
Nina

"Peter Jamieson" wrote:

Unfortunately I spent some time trying to replicate this problem but
could not do so (SQL Server 2008, VARCHAR(30) containing a 30-char text,
etc.). I've tried both OLE DB and ODBC connections, and both the old SQL
Server client and the newer Native Client. No difference.

If you have another program on your system that you could use to open
this data - for example Excel or Access - it might be worth trying that
to see if the same truncation is occurring.

If you are actually seeing two question marks at the end instead of the
two characters you expect, the problem probably results from the
"character translation" settings. However, for this to happen for every
value in the field, there would have to be two unusual characters at the
end of /every/ value, which would seem a little strange.

Peter Jamieson

http://tips.pjmsn.me.uk

On 25/01/2010 20:38, Nina S wrote:
I have the answers to all but the last question. Still waiting to hear from
the CRM programmer.

What type of database is it (SQL Server, mySQL, Oracle,...?)
SQL Server

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..?
PanelDescription (varchar(30), not null)

Is the field coming directly from a table, or via a View or a stored
procedure?
These are the views I looked at that I thought you might be using to get the
data
vDocRouterOPPOQuoter
vDocRouterQuoter


Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.
I do not know the answer to this question
Can you ask the CRM programmer?


"Peter Jamieson" wrote:

Some techie questions that you may have to refer to your programmer:

What type of database is it (SQL Server, mySQL, Oracle,...?)

What is the field type? VARCHAR, CHAR, NCHAR, NVARCHAR,..? Is the field
coming directly from a table, or via a View or a stored procedure?

Are you using an OLE DB connection in Word (that would be the default in
Word 2003, but you could be using ODBC if there is no OLE DB provider
for the database concerned.

(I don't know a problem in this area, and the above info. would really
only allow us to try to replicate the problem if we happen to have the
necessary database software etc. available).

Peter Jamieson

http://tips.pjmsn.me.uk

On 14/01/2010 16:53, Nina S wrote:
the field in my sql database allows 30 characters, but when we merge the
field in Word 2003 it only shows 28 characters. The database programmer said
the problem is in the Word doc. Do I need a switch to have all 30 characters
merge?
Please help!
Nina
.

.

Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
International Characters in a merge field Jessica B. Mailmerge 4 January 16th 09 07:20 PM
Word is adding characters to a merge field Doug Adams Mailmerge 2 October 2nd 07 12:36 AM
How do I correct how a birth date shows in a mail merge field? Grace Mailmerge 1 January 31st 06 09:53 PM
How to merge a memo field greater than 255 characters? Orbid Mailmerge 1 June 1st 05 11:12 AM
Date mail merge field shows as serial Hiking Mailmerge 5 March 18th 05 10:25 AM


All times are GMT +1. The time now is 02:40 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"