Reply
 
Thread Tools Display Modes
  #1   Report Post  
Posted to microsoft.public.word.mailmerge.fields
tighe tighe is offline
external usenet poster
 
Posts: 11
Default excel merege Confirmation Dialog

All,

Whenever I run an automated merge with excel as the data source a dialog box
appears and the user has to confirm the data source. How can I avoid this?

Set objWord =
appWord.Documents.Open("G:\cmcdb\20080922_CMCDB2\D ocuments\Ext_IA_prop_cvr_and_quote.dotm")

' Set the mail merge data source as the database.
objWord.MailMerge.OpenDataSource "G:\cmcdb\Employees\" &
[Forms]![001_Start]![consultant_ini] & "\Prospect_IA_Proposal.xlsx",
LinkToSource = True, ConfirmConversions = False

' Execute the mail merge.
objWord.MailMerge.Execute

If I merge in the same manner from a rtf file no further user input is
required.
This is a cross office product issue, I run this code from access, but
thought this the best place to post. I know you can cross post issues but
not exactly sure what the "use full USENET designation" would be.

Office 2007/XP

  #2   Report Post  
Posted to microsoft.public.word.mailmerge.fields
Peter Jamieson Peter Jamieson is offline
external usenet poster
 
Posts: 4,582
Default excel merege Confirmation Dialog

1. I guess you have already taken account of the registry change
described in the following article:

http://support.microsoft.com/kb/825765/

2. There are a couple of other dialog boxes you might be describing.
a. The Confirm data source dialog box is displayed when Word can't
deterine what type of data source is being used. That behaviour depends
on the Word setting at

Office button-Word options-Advanced-Confirm file format conversion on
open

which you can set programmatically using

objWord.ConfirmConversions = False

b. the OLE DB Select Table dialog box. To avoid that, you need to
specify a SELECT query n your open data source,e.g.

objWord.MailMerge.OpenDataSource _
Name:="G:\cmcdb\Employees\" & _
[Forms]![001_Start]![consultant_ini] & _
"\Prospect_IA_Proposal.xlsx",
SQLStatement:="SELECT * FROM [Sheet1$]"



Peter Jamieson

http://tips.pjmsn.me.uk

On 27/01/2010 14:29, tighe wrote:
All,

Whenever I run an automated merge with excel as the data source a dialog box
appears and the user has to confirm the data source. How can I avoid this?

Set objWord =
appWord.Documents.Open("G:\cmcdb\20080922_CMCDB2\D ocuments\Ext_IA_prop_cvr_and_quote.dotm")

' Set the mail merge data source as the database.
objWord.MailMerge.OpenDataSource "G:\cmcdb\Employees\"&
[Forms]![001_Start]![consultant_ini]& "\Prospect_IA_Proposal.xlsx",
LinkToSource = True, ConfirmConversions = False

' Execute the mail merge.
objWord.MailMerge.Execute

If I merge in the same manner from a rtf file no further user input is
required.
This is a cross office product issue, I run this code from access, but
thought this the best place to post. I know you can cross post issues but
not exactly sure what the "use full USENET designation" would be.

Office 2007/XP

  #3   Report Post  
Posted to microsoft.public.word.mailmerge.fields
tighe tighe is offline
external usenet poster
 
Posts: 11
Default excel merege Confirmation Dialog

Peter,
perfect went with the "SQLStatement," this is great since users never know
what is going on.

"Peter Jamieson" wrote:

1. I guess you have already taken account of the registry change
described in the following article:

http://support.microsoft.com/kb/825765/

2. There are a couple of other dialog boxes you might be describing.
a. The Confirm data source dialog box is displayed when Word can't
deterine what type of data source is being used. That behaviour depends
on the Word setting at

Office button-Word options-Advanced-Confirm file format conversion on
open

which you can set programmatically using

objWord.ConfirmConversions = False

b. the OLE DB Select Table dialog box. To avoid that, you need to
specify a SELECT query n your open data source,e.g.

objWord.MailMerge.OpenDataSource _
Name:="G:\cmcdb\Employees\" & _
[Forms]![001_Start]![consultant_ini] & _
"\Prospect_IA_Proposal.xlsx",
SQLStatement:="SELECT * FROM [Sheet1$]"



Peter Jamieson

http://tips.pjmsn.me.uk

On 27/01/2010 14:29, tighe wrote:
All,

Whenever I run an automated merge with excel as the data source a dialog box
appears and the user has to confirm the data source. How can I avoid this?

Set objWord =
appWord.Documents.Open("G:\cmcdb\20080922_CMCDB2\D ocuments\Ext_IA_prop_cvr_and_quote.dotm")

' Set the mail merge data source as the database.
objWord.MailMerge.OpenDataSource "G:\cmcdb\Employees\"&
[Forms]![001_Start]![consultant_ini]& "\Prospect_IA_Proposal.xlsx",
LinkToSource = True, ConfirmConversions = False

' Execute the mail merge.
objWord.MailMerge.Execute

If I merge in the same manner from a rtf file no further user input is
required.
This is a cross office product issue, I run this code from access, but
thought this the best place to post. I know you can cross post issues but
not exactly sure what the "use full USENET designation" would be.

Office 2007/XP

.

Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Confirmation then, bretsharon New Users 1 April 28th 07 03:42 PM
ASP.NET - Excel - Mail Merge in Word causes "Data Link Properties" dialog to appear. [email protected] Mailmerge 1 April 18th 06 02:38 PM
Dropdown menu in Word,Excel 2003 Open dialog box is taking long ti Ramakanth Microsoft Word Help 1 January 24th 06 12:46 PM
Activation- I don't know what the confirmation ID is? Diane Tables 1 August 10th 05 03:31 AM
how do you mail merege into business cards? VJ Mailmerge 1 July 13th 05 09:13 PM


All times are GMT +1. The time now is 07:34 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"