Reply
 
Thread Tools Display Modes
  #1   Report Post  
Merging Zip Code Errors
 
Posts: n/a
Default My zip code format is lost when merging from Excel to Word...

I am having the same problem as Suzanne. I FOLLOWED THE POSTED DIRECTIONS!
How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message ...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!




  #2   Report Post  
Graham Mayor
 
Posts: n/a
Default

The use of zip codes formatting switches is explained in detail in my web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will strip
leading zeros from numbers. You can use a number switch or mask to restore
that zero. At the place you want the zip code press CTRL+F9. This will give
you a pair of field brackets {}

Between the brackets type the required field data, presumably {Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9 to
update. This should toggle the field display, but if it doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see the web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!



  #3   Report Post  
camell
 
Posts: n/a
Default



"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in my web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will strip
leading zeros from numbers. You can use a number switch or mask to restore
that zero. At the place you want the zip code press CTRL+F9. This will give
you a pair of field brackets {}

Between the brackets type the required field data, presumably {Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9 to
update. This should toggle the field display, but if it doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see the web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!




  #4   Report Post  
Posted to microsoft.public.word.docmanagement
Cate Cate is offline
external usenet poster
 
Posts: 3
Default My zip code format is lost when merging from Excel to Word...

I have read the entire steam, carefully read your linked page, and also
checked & double checked my typing. I continue to get an error message that
the mergefield zip \# (the backslash doesn't show, though) is not found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in my web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will strip
leading zeros from numbers. You can use a number switch or mask to restore
that zero. At the place you want the zip code press CTRL+F9. This will give
you a pair of field brackets {}

Between the brackets type the required field data, presumably {Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9 to
update. This should toggle the field display, but if it doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see the web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!




  #5   Report Post  
Posted to microsoft.public.word.docmanagement
Suzanne S. Barnhill Suzanne S. Barnhill is offline
external usenet poster
 
Posts: 33,624
Default My zip code format is lost when merging from Excel to Word...

The "\# 00000" is a formatting switch. In the example, you must substitute
for "Zip" whatever is the name of the field in your database that contains
the ZIP code. The alternative is to link to the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and also
checked & double checked my typing. I continue to get an error message

that
the mergefield zip \# (the backslash doesn't show, though) is not found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in my

web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will strip
leading zeros from numbers. You can use a number switch or mask to

restore
that zero. At the place you want the zip code press CTRL+F9. This will

give
you a pair of field brackets {}

Between the brackets type the required field data, presumably

{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9 to
update. This should toggle the field display, but if it doesn't ALT+F9

will.

If you need one of the more complicated formatting options, see the web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!







  #6   Report Post  
Posted to microsoft.public.word.docmanagement
Cate Cate is offline
external usenet poster
 
Posts: 3
Default My zip code format is lost when merging from Excel to Word...

Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet, but for
simplicity didn't include it in my last message to this stream. My system
seems to be refusing to recognize the switch. Any ideas how to trick it into
recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must substitute
for "Zip" whatever is the name of the field in your database that contains
the ZIP code. The alternative is to link to the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and also
checked & double checked my typing. I continue to get an error message

that
the mergefield zip \# (the backslash doesn't show, though) is not found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in my

web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will strip
leading zeros from numbers. You can use a number switch or mask to

restore
that zero. At the place you want the zip code press CTRL+F9. This will

give
you a pair of field brackets {}

Between the brackets type the required field data, presumably

{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9 to
update. This should toggle the field display, but if it doesn't ALT+F9

will.

If you need one of the more complicated formatting options, see the web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the "0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0 and
when I merge only the "0" without the remaining digits in the zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip code
formatting during the merge so that for all zip codes that begin
with a zreo, the zero is dropped. I have never had this problem
before, how can I fix this? Thanks!





  #7   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default My zip code format is lost when merging from Excel to Word...

Did you toggle the field to show {Mergefield Zip} rather than Zip before
adding the switch?
Did you update the field after adding the switch?
As for DDE - see the Excel data section of
http://www.gmayor.com/mail_merge_lab...th_word_xp.htm

DDE, when it works, will bring in the formatting from Excel - but it isn't
very reliable.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org


Cate wrote:
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet,
but for simplicity didn't include it in my last message to this
stream. My system seems to be refusing to recognize the switch. Any
ideas how to trick it into recognizing it? What is a DDE?

The "\# 00000" is a formatting switch. In the example, you must
substitute for "Zip" whatever is the name of the field in your
database that contains the ZIP code. The alternative is to link to
the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and
also checked & double checked my typing. I continue to get an
error message that the mergefield zip \# (the backslash doesn't
show, though) is not found in the header row of my database.
Everything stops at that point. --
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in
my web page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will
strip leading zeros from numbers. You can use a number switch or
mask to restore that zero. At the place you want the zip code
press CTRL+F9. This will give you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press
F9 to update. This should toggle the field display, but if it
doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see
the web page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both
advice, but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I
do not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the
"0" without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0
and when I merge only the "0" without the remaining digits in
the zip code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to
the newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip
code formatting during the merge so that for all zip codes
that begin with a zreo, the zero is dropped. I have never
had this problem before, how can I fix this? Thanks!



  #8   Report Post  
Posted to microsoft.public.word.docmanagement
Suzanne S. Barnhill Suzanne S. Barnhill is offline
external usenet poster
 
Posts: 33,624
Default My zip code format is lost when merging from Excel to Word...

There are two ways to force Word to use the number formatting you have
applied in Excel. One is to use a formatting switch as described by Graham.
The other is to connect to Excel using DDE (the old method) instead of OLEDB
(the method introduced in Word 2002, which preserves Unicode characters but
not number formatting). To do the latter, you'll need to check the box for
"Confirm conversion at Open" on the General tab of Tools | Options. After
doing that, reattach the data source to your mail merge main document. When
you do, you'll get a dialog asking you to choose the connection method, and
you can choose DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \# "00000" }."
If I have correctly read Word's Help topic "Numeric Picture (\#) field
switch," the quotes around the numeric picture are unnecessary and perhaps
incorrect (and may be part of the problem).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet, but

for
simplicity didn't include it in my last message to this stream. My system
seems to be refusing to recognize the switch. Any ideas how to trick it

into
recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must

substitute
for "Zip" whatever is the name of the field in your database that

contains
the ZIP code. The alternative is to link to the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and

also
checked & double checked my typing. I continue to get an error

message
that
the mergefield zip \# (the backslash doesn't show, though) is not

found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in

my
web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will

strip
leading zeros from numbers. You can use a number switch or mask to

restore
that zero. At the place you want the zip code press CTRL+F9. This

will
give
you a pair of field brackets {}

Between the brackets type the required field data, presumably

{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9

to
update. This should toggle the field display, but if it doesn't

ALT+F9
will.

If you need one of the more complicated formatting options, see the

web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both

advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I

do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the

"0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0

and
when I merge only the "0" without the remaining digits in the

zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to

the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip

code
formatting during the merge so that for all zip codes that

begin
with a zreo, the zero is dropped. I have never had this

problem
before, how can I fix this? Thanks!






  #9   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default My zip code format is lost when merging from Excel to Word...

The quotes should not cause a problem!

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org


Suzanne S. Barnhill wrote:
There are two ways to force Word to use the number formatting you have
applied in Excel. One is to use a formatting switch as described by
Graham. The other is to connect to Excel using DDE (the old method)
instead of OLEDB (the method introduced in Word 2002, which preserves
Unicode characters but not number formatting). To do the latter,
you'll need to check the box for "Confirm conversion at Open" on the
General tab of Tools | Options. After doing that, reattach the data
source to your mail merge main document. When you do, you'll get a
dialog asking you to choose the connection method, and you can choose
DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \#
"00000" }." If I have correctly read Word's Help topic "Numeric
Picture (\#) field switch," the quotes around the numeric picture are
unnecessary and perhaps incorrect (and may be part of the problem).


"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet,
but for simplicity didn't include it in my last message to this
stream. My system seems to be refusing to recognize the switch.
Any ideas how to trick it into recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must
substitute for "Zip" whatever is the name of the field in your
database that contains the ZIP code. The alternative is to link to
the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and
also checked & double checked my typing. I continue to get an
error message that the mergefield zip \# (the backslash doesn't
show, though) is not found in the header row of my database.
Everything stops at that point. --
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail
in my web page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will
strip leading zeros from numbers. You can use a number switch or
mask to restore that zero. At the place you want the zip code
press CTRL+F9. This will give you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press
F9 to update. This should toggle the field display, but if it
doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see
the web page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both
advice, but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to
the newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge,
I do not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the
"0" without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0
and when I merge only the "0" without the remaining digits
in the zip code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to
the newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip
code formatting during the merge so that for all zip codes
that begin with a zreo, the zero is dropped. I have never
had this problem before, how can I fix this? Thanks!



  #10   Report Post  
Posted to microsoft.public.word.docmanagement
Cate Cate is offline
external usenet poster
 
Posts: 3
Default My zip code format is lost when merging from Excel to Word...

Suzanne! Removing those quotation marks seems to have done the trick with
the 5-digit zip codes!! Hurray, we're half-way there. I've tried several
variations on the 9-digit portion of the coding, but get only five zeros to
show. I can remove the 4-digit extensions, but would much rather be able to
solve this once and for all. I really appreciate all your and Graham's help,
as I'm sure others will, too.
--
Cate


"Suzanne S. Barnhill" wrote:

There are two ways to force Word to use the number formatting you have
applied in Excel. One is to use a formatting switch as described by Graham.
The other is to connect to Excel using DDE (the old method) instead of OLEDB
(the method introduced in Word 2002, which preserves Unicode characters but
not number formatting). To do the latter, you'll need to check the box for
"Confirm conversion at Open" on the General tab of Tools | Options. After
doing that, reattach the data source to your mail merge main document. When
you do, you'll get a dialog asking you to choose the connection method, and
you can choose DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \# "00000" }."
If I have correctly read Word's Help topic "Numeric Picture (\#) field
switch," the quotes around the numeric picture are unnecessary and perhaps
incorrect (and may be part of the problem).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet, but

for
simplicity didn't include it in my last message to this stream. My system
seems to be refusing to recognize the switch. Any ideas how to trick it

into
recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must

substitute
for "Zip" whatever is the name of the field in your database that

contains
the ZIP code. The alternative is to link to the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and

also
checked & double checked my typing. I continue to get an error

message
that
the mergefield zip \# (the backslash doesn't show, though) is not

found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in

my
web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will

strip
leading zeros from numbers. You can use a number switch or mask to
restore
that zero. At the place you want the zip code press CTRL+F9. This

will
give
you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9

to
update. This should toggle the field display, but if it doesn't

ALT+F9
will.

If you need one of the more complicated formatting options, see the

web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both

advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I

do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the

"0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0

and
when I merge only the "0" without the remaining digits in the

zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to

the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip

code
formatting during the merge so that for all zip codes that

begin
with a zreo, the zero is dropped. I have never had this

problem
before, how can I fix this? Thanks!









  #11   Report Post  
Posted to microsoft.public.word.docmanagement
Suzanne S. Barnhill Suzanne S. Barnhill is offline
external usenet poster
 
Posts: 33,624
Default My zip code format is lost when merging from Excel to Word...

If you have a mixture of 5-digit and 9-digit ZIPs, then you'd be better off
using DDE to connect.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
Suzanne! Removing those quotation marks seems to have done the trick with
the 5-digit zip codes!! Hurray, we're half-way there. I've tried several
variations on the 9-digit portion of the coding, but get only five zeros

to
show. I can remove the 4-digit extensions, but would much rather be able

to
solve this once and for all. I really appreciate all your and Graham's

help,
as I'm sure others will, too.
--
Cate


"Suzanne S. Barnhill" wrote:

There are two ways to force Word to use the number formatting you have
applied in Excel. One is to use a formatting switch as described by

Graham.
The other is to connect to Excel using DDE (the old method) instead of

OLEDB
(the method introduced in Word 2002, which preserves Unicode characters

but
not number formatting). To do the latter, you'll need to check the box

for
"Confirm conversion at Open" on the General tab of Tools | Options.

After
doing that, reattach the data source to your mail merge main document.

When
you do, you'll get a dialog asking you to choose the connection method,

and
you can choose DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \#

"00000" }."
If I have correctly read Word's Help topic "Numeric Picture (\#) field
switch," the quotes around the numeric picture are unnecessary and

perhaps
incorrect (and may be part of the problem).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet,

but
for
simplicity didn't include it in my last message to this stream. My

system
seems to be refusing to recognize the switch. Any ideas how to trick

it
into
recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must

substitute
for "Zip" whatever is the name of the field in your database that

contains
the ZIP code. The alternative is to link to the Excel file using

DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and

also
checked & double checked my typing. I continue to get an error

message
that
the mergefield zip \# (the backslash doesn't show, though) is not

found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail

in
my
web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will

strip
leading zeros from numbers. You can use a number switch or mask

to
restore
that zero. At the place you want the zip code press CTRL+F9.

This
will
give
you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press

F9
to
update. This should toggle the field display, but if it doesn't

ALT+F9
will.

If you need one of the more complicated formatting options, see

the
web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both

advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to

the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I

merge, I
do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get

the
"0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the

0
and
when I merge only the "0" without the remaining digits in

the
zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see

http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups

to
the
newsgroup so all may benefit.

"MarianneME" wrote

in
message

...
I am merging addresses from Excel to Work and I lose

zip
code
formatting during the merge so that for all zip codes

that
begin
with a zreo, the zero is dropped. I have never had this

problem
before, how can I fix this? Thanks!








  #12   Report Post  
Posted to microsoft.public.word.docmanagement
Graham Mayor Graham Mayor is offline
external usenet poster
 
Posts: 19,312
Default My zip code format is lost when merging from Excel to Word...

My web page - http://www.gmayor.com/formatting_word_fields.htm shows how to
obtain 5 and 9 digit zips using switches. remember that you have to use
CTRL+F9 for each pair of field boundaries and then update the field. I don't
see why removing the quotes should make any difference (though the fields
were all tested on Word 2003). However if it works for you then remove
them -
{ IF{ Mergefield Zip } "99999" "{ Mergefield Zip \# 00000'-'0000 }" "{
Mergefield Zip \# 00000 }" }
or if you want 9 digits for all
{ IF{ Mergefield Zip } "99999" "{ Mergefield Zip \# 00000'-'0000 }" "{
Mergefield Zip \# 00000 }-0000" }

I have just tested this again and it works either with or without the
quotes.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org


Cate wrote:
Suzanne! Removing those quotation marks seems to have done the trick
with the 5-digit zip codes!! Hurray, we're half-way there. I've
tried several variations on the 9-digit portion of the coding, but
get only five zeros to show. I can remove the 4-digit extensions,
but would much rather be able to solve this once and for all. I
really appreciate all your and Graham's help, as I'm sure others
will, too.

There are two ways to force Word to use the number formatting you
have applied in Excel. One is to use a formatting switch as
described by Graham. The other is to connect to Excel using DDE (the
old method) instead of OLEDB (the method introduced in Word 2002,
which preserves Unicode characters but not number formatting). To do
the latter, you'll need to check the box for "Confirm conversion at
Open" on the General tab of Tools | Options. After doing that,
reattach the data source to your mail merge main document. When you
do, you'll get a dialog asking you to choose the connection method,
and you can choose DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \#
"00000" }." If I have correctly read Word's Help topic "Numeric
Picture (\#) field switch," the quotes around the numeric picture
are unnecessary and perhaps incorrect (and may be part of the
problem).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet,
but for simplicity didn't include it in my last message to this
stream. My system seems to be refusing to recognize the switch.
Any ideas how to trick it into recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must
substitute for "Zip" whatever is the name of the field in your
database that contains the ZIP code. The alternative is to link to
the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page,
and also checked & double checked my typing. I continue to get
an error message that the mergefield zip \# (the backslash
doesn't show, though) is not found in the header row of my
database. Everything stops at that point. --
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail
in my web page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will
strip leading zeros from numbers. You can use a number switch or
mask to restore that zero. At the place you want the zip code
press CTRL+F9. This will give you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press
F9 to update. This should toggle the field display, but if it
doesn't ALT+F9 will.

If you need one of the more complicated formatting options, see
the web page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both
advice, but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to
the newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge,
I do not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get
the "0" without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0
and when I merge only the "0" without the remaining digits
in the zip code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups
to the newsgroup so all may benefit.

"MarianneME" wrote
in message
...
I am merging addresses from Excel to Work and I lose zip
code formatting during the merge so that for all zip
codes that begin with a zreo, the zero is dropped. I
have never had this problem before, how can I fix this?
Thanks!



  #13   Report Post  
Posted to microsoft.public.word.docmanagement
Diana L Middleton Diana L Middleton is offline
external usenet poster
 
Posts: 1
Default My zip code format is lost when merging from Excel to Word...

The DDE method worked well. I had trouble merging zip codes w/ 9 digits and a
hyphen, but this solved the problem.

"Suzanne S. Barnhill" wrote:

There are two ways to force Word to use the number formatting you have
applied in Excel. One is to use a formatting switch as described by Graham.
The other is to connect to Excel using DDE (the old method) instead of OLEDB
(the method introduced in Word 2002, which preserves Unicode characters but
not number formatting). To do the latter, you'll need to check the box for
"Confirm conversion at Open" on the General tab of Tools | Options. After
doing that, reattach the data source to your mail merge main document. When
you do, you'll get a dialog asking you to choose the connection method, and
you can choose DDE.

Also, I notice that Graham's reply suggests "{ Mergefield Zip \# "00000" }."
If I have correctly read Word's Help topic "Numeric Picture (\#) field
switch," the quotes around the numeric picture are unnecessary and perhaps
incorrect (and may be part of the problem).

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.

"Cate" wrote in message
...
Dear Suzanne & Graham,
Yes, I did actually use the heading specific to my Excel datasheet, but

for
simplicity didn't include it in my last message to this stream. My system
seems to be refusing to recognize the switch. Any ideas how to trick it

into
recognizing it? What is a DDE?
--
Cate


"Suzanne S. Barnhill" wrote:

The "\# 00000" is a formatting switch. In the example, you must

substitute
for "Zip" whatever is the name of the field in your database that

contains
the ZIP code. The alternative is to link to the Excel file using DDE.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the

newsgroup so
all may benefit.

"Cate" wrote in message
...
I have read the entire steam, carefully read your linked page, and

also
checked & double checked my typing. I continue to get an error

message
that
the mergefield zip \# (the backslash doesn't show, though) is not

found in
the header row of my database. Everything stops at that point.
--
Cate


"Graham Mayor" wrote:

The use of zip codes formatting switches is explained in detail in

my
web
page http://www.gmayor.com/formatting_word_fields.htm

Essentially Word is expected to provide the formatting and will

strip
leading zeros from numbers. You can use a number switch or mask to
restore
that zero. At the place you want the zip code press CTRL+F9. This

will
give
you a pair of field brackets {}

Between the brackets type the required field data, presumably
{Mergefield
Zip} then add the switch i.e.
{Mergefield Zip \# "00000"}. With the cursor in the field. Press F9

to
update. This should toggle the field display, but if it doesn't

ALT+F9
will.

If you need one of the more complicated formatting options, see the

web
page for the content.

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Merging Zip Code Errors wrote:
I am having the same problem as Suzanne. I FOLLOWED THE POSTED
DIRECTIONS! How about a detailed example?

"Graham Mayor" wrote:

Did you update the field after adding the switch?

--

Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org




Judy F. wrote:
yes I have viewed both website suggestions and followed both

advice,
but it is not showing the "0"

"Suzanne S. Barnhill" wrote:

Did you look at the recommended Web page?

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to the
newsgroup so all may benefit.

"Judy F." wrote in message
...
I am also having the same problem.
I have changed the format to specialzip code when I merge, I

do
not get the initial "0" in my zip code.
I change the format to text, and when I merge I only get the

"0"
without the remaining digits in the zip code.
I entered the questioning zip codes with a ' prior to the 0

and
when I merge only the "0" without the remaining digits in the

zip
code show up.

Help?


"Suzanne S. Barnhill" wrote:

If you're using Word 2002 or 2003, see
http://homepage.swissonline.ch/cindy...002/MM2002.htm

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
Word MVP FAQ site: http://word.mvps.org
Email cannot be acknowledged; please post all follow-ups to

the
newsgroup so all may benefit.

"MarianneME" wrote in
message
...
I am merging addresses from Excel to Work and I lose zip

code
formatting during the merge so that for all zip codes that

begin
with a zreo, the zero is dropped. I have never had this

problem
before, how can I fix this? Thanks!







Reply
Thread Tools
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Excel date format merging to Word XP version Linda - Xtremly Peeved Mailmerge 11 April 12th 05 06:50 AM
How do I get UK date format merging into word from Access? Gavvers Mailmerge 3 March 18th 05 12:24 PM
How do you keep the currency format when merging data from Excel? MJW Mailmerge 2 February 22nd 05 06:33 PM
Zip code merging when 5 AND 9 digits Spring Velazquez, Widener University Mailmerge 13 January 21st 05 01:54 AM
Mail Merge Zip Code will not format correctly ba Mailmerge 1 December 8th 04 02:15 AM


All times are GMT +1. The time now is 02:43 PM.

Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 Microsoft Office Word Forum - WordBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Word"